Error during compilation math.js by Google Closue #503

Closed
gang65 opened this Issue Nov 12, 2015 · 1 comment

Projects

None yet

2 participants

@gang65
gang65 commented Nov 12, 2015

During compilation by Google closure:
https://developers.google.com/closure/

I have errors, which is quite easy to fix.
Maybe it is worth to fix that?

java -jar ~/Dokumenty/compiler.jar < ~/Pulpit/math.js
The compiler is waiting for input via stdin.
stdin:115: WARNING - Keywords and reserved words are not allowed as unquoted property names in older versions of JavaScript. If you are targeting newer versions of JavaScript, set the appropriate language_in option.
math.import(webpack_require(13));
^

stdin:9121: ERROR - Parse error. IE8 (and below) will parse trailing commas in array and object literals incorrectly. If you are targeting newer versions of JS, set the appropriate language_in option.
power: 1.0,
^

stdin:10491: ERROR - Parse error. IE8 (and below) will parse trailing commas in array and object literals incorrectly. If you are targeting newer versions of JS, set the appropriate language_in option.
offset: 0,
^

stdin:10937: ERROR - Parse error. IE8 (and below) will parse trailing commas in array and object literals incorrectly. If you are targeting newer versions of JS, set the appropriate language_in option.
+ latex.symbols['i'] + '\cdot\left(${args[1]}\right)\right)',
^

stdin:19616: ERROR - Parse error. IE8 (and below) will parse trailing commas in array and object literals incorrectly. If you are targeting newer versions of JS, set the appropriate language_in option.
'lup(sparse([[2, 1], [1, 4]]))',
^

stdin:19680: ERROR - Parse error. IE8 (and below) will parse trailing commas in array and object literals incorrectly. If you are targeting newer versions of JS, set the appropriate language_in option.
'x=usolve(sparse([1, 1, 1, 1; 0, 1, 1, 1; 0, 0, 1, 1; 0, 0, 0, 1]), [1; 2; 3; 4])',
^

stdin:25239: ERROR - Parse error. IE8 (and below) will parse trailing commas in array and object literals incorrectly. If you are targeting newer versions of JS, set the appropriate language_in option.
latexRightParens: false,
^

6 error(s), 1 warning(s)

@josdejong
Owner

Thanks, fixed that on the develop branch.

@josdejong josdejong added the bug label Nov 13, 2015
@josdejong josdejong added a commit that closed this issue Nov 14, 2015
@josdejong Fixed #503: Removed trailing commas and the use of keyword `import` as
  property, as this gives issues with old JavaScript engines
526c1dd
@josdejong josdejong closed this in 526c1dd Nov 14, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment