Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

WARNING: Invalid .gemspec format in '/var/lib/gems/1.8/specifications/http_router-0.11.0.gemspec' #27

Open
igrep opened this Issue · 7 comments

4 participants

@igrep

I got a warning every time require 'rubygems' after updating this library into 0.11.0.

#The Warning

WARNING:  #<ArgumentError: Illformed requirement ["#<YAML::Syck::DefaultKey:0xb6a1d89c> 1.2.8"]>
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = %q{http_router}
  s.version = "0.11.0"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = ["Joshua Hull"]
  s.date = %q{2012-04-11}
  s.description = %q{This library allows you to recognize and build URLs in a Rack application.}
  s.email = %q{joshbuddy@gmail.com}
  s.extra_rdoc_files = ["README.md", "LICENSE"]
  s.files = [".gitignore", "Gemfile", "LICENSE", "README.md", "Rakefile", "benchmarks/gen2.rb", "benchmarks/generation_bm.rb", "benchmarks/rack_mount.rb", "benchmarks/rack_recognition_bm.rb", "benchmarks/rec2.rb", "benchmarks/recognition_bm.rb", "examples/glob.ru", "examples/rack_mapper.ru", "examples/simple.ru", "examples/static/config.ru", "examples/static/favicon.ico", "examples/static/images/cat1.jpg", "examples/static/images/cat2.jpg", "examples/static/images/cat3.jpg", "examples/variable.ru", "examples/variable_with_regex.ru", "http_router.gemspec", "js/lib/http_router.coffee", "js/lib/http_router.js", "js/package.json", "js/test/test.coffee", "js/test/test.js", "lib/http_router.rb", "lib/http_router/generation_helper.rb", "lib/http_router/generator.rb", "lib/http_router/node.rb", "lib/http_router/node/abstract_request_node.rb", "lib/http_router/node/free_regex.rb", "lib/http_router/node/glob.rb", "lib/http_router/node/glob_regex.rb", "lib/http_router/node/host.rb", "lib/http_router/node/lookup.rb", "lib/http_router/node/path.rb", "lib/http_router/node/regex.rb", "lib/http_router/node/request_method.rb", "lib/http_router/node/root.rb", "lib/http_router/node/scheme.rb", "lib/http_router/node/spanning_regex.rb", "lib/http_router/node/user_agent.rb", "lib/http_router/node/variable.rb", "lib/http_router/regex_route_generation.rb", "lib/http_router/request.rb", "lib/http_router/response.rb", "lib/http_router/route.rb", "lib/http_router/route_helper.rb", "lib/http_router/util.rb", "lib/http_router/version.rb", "test/common/generate.txt", "test/common/http_recognize.txt", "test/common/recognize.txt", "test/generation.rb", "test/generic.rb", "test/helper.rb", "test/rack/test_route.rb", "test/recognition.rb", "test/test_misc.rb", "test/test_mounting.rb", "test/test_recognition.rb", "test/test_trailing_slash.rb"]
  s.homepage = %q{http://github.com/joshbuddy/http_router}
  s.rdoc_options = ["--charset=UTF-8"]
  s.require_paths = ["lib"]
  s.rubyforge_project = %q{http_router}
  s.rubygems_version = %q{1.3.7}
  s.summary = %q{A kick-ass HTTP router for use in Rack}
  s.test_files = ["test/common/generate.txt", "test/common/http_recognize.txt", "test/common/recognize.txt", "test/generation.rb", "test/generic.rb", "test/helper.rb", "test/rack/test_route.rb", "test/recognition.rb", "test/test_misc.rb", "test/test_mounting.rb", "test/test_recognition.rb", "test/test_trailing_slash.rb"]

  if s.respond_to? :specification_version then
    current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
    s.specification_version = 3

    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
      s.add_runtime_dependency(%q<rack>, [">= 1.0.0"])
      s.add_runtime_dependency(%q<url_mount>, ["~> 0.2.1"])
      s.add_development_dependency(%q<minitest>, ["~> 2.0.0"])
      s.add_development_dependency(%q<code_stats>, [">= 0"])
      s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
      s.add_development_dependency(%q<rbench>, [">= 0"])
      s.add_development_dependency(%q<json>, [">= 0"])
      s.add_development_dependency(%q<phocus>, [">= 0"])
      s.add_development_dependency(%q<bundler>, [">= 0"])
      s.add_development_dependency(%q<thin>, ["#<YAML::Syck::DefaultKey:0xb6a1d89c> 1.2.8"])
    else
      s.add_dependency(%q<rack>, [">= 1.0.0"])
      s.add_dependency(%q<url_mount>, ["~> 0.2.1"])
      s.add_dependency(%q<minitest>, ["~> 2.0.0"])
      s.add_dependency(%q<code_stats>, [">= 0"])
      s.add_dependency(%q<rake>, ["~> 0.8.7"])
      s.add_dependency(%q<rbench>, [">= 0"])
      s.add_dependency(%q<json>, [">= 0"])
      s.add_dependency(%q<phocus>, [">= 0"])
      s.add_dependency(%q<bundler>, [">= 0"])
      s.add_dependency(%q<thin>, ["#<YAML::Syck::DefaultKey:0xb6a1d89c> 1.2.8"])
    end
  else
    s.add_dependency(%q<rack>, [">= 1.0.0"])
    s.add_dependency(%q<url_mount>, ["~> 0.2.1"])
    s.add_dependency(%q<minitest>, ["~> 2.0.0"])
    s.add_dependency(%q<code_stats>, [">= 0"])
    s.add_dependency(%q<rake>, ["~> 0.8.7"])
    s.add_dependency(%q<rbench>, [">= 0"])
    s.add_dependency(%q<json>, [">= 0"])
    s.add_dependency(%q<phocus>, [">= 0"])
    s.add_dependency(%q<bundler>, [">= 0"])
    s.add_dependency(%q<thin>, ["#<YAML::Syck::DefaultKey:0xb6a1d89c> 1.2.8"])
  end
end
WARNING:  Invalid .gemspec format in '/var/lib/gems/1.8/specifications/http_router-0.11.0.gemspec'

#My Environment

  • Ruby 1.8.7 (2010-08-16 patchlevel 302) [i686-linux]
  • Ubuntu 11.04
@igrep

I'm sorry for forgetting to write my gem version: 1.3.7.

@Xeus

I get this exact error too on OS X Lion, ruby 1.8.7 (2010-01-10 patchlevel 249) [universal-darwin11.0]. Tried gem update --system, upgrading http_router & installing thin.

@igrep
@Xeus

Ah okay, gem install http_router seemed to install the latest version 0.11.0 alongside my older version (0.10.2) and now the problem is gone.

@antonh

I had to replace every occurrence of #YAML::Syck::DefaultKey:0x... with = in the .gemspec file (like in version 0.10.2) to get rid of the warning.

@edap

same problem for me. I'm trying to install padrino on dreamhost (shared hosting). If I run bundle install it seems that all the gems are correctly installed in my .gems folder. But if launch "bundle show sinatra" i've got the same error posted by @igrep :

WARNING:  #<ArgumentError: Illformed requirement ["#<YAML::Syck::DefaultKey:0x35bcab52a38> 1.2.8"]>
@edap

Installing the gem from the github repo fixes the problem for me.

gem 'http_router', '0.11.0', :git => 'git://github.com/joshbuddy/http_router.git'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.