Permalink
Browse files

Ensure package works with node 0.7 (bump ctype dep)

  • Loading branch information...
1 parent f8f8929 commit a995d20b9cb5634903411dc8a5cfbb6a9bef19b3 @mcavage mcavage committed Mar 19, 2012
Showing with 7 additions and 8 deletions.
  1. +1 −1 lib/signer.js
  2. +6 −7 package.json
View
@@ -4,7 +4,7 @@ var assert = require('assert');
var crypto = require('crypto');
var http = require('http');
-var sprintf = require('sprintf').sprintf;
+var sprintf = require('util').format;
View
@@ -2,27 +2,26 @@
"author": "Joyent, Inc",
"name": "http-signature",
"description": "Reference implementation of Joyent's HTTP Signature Scheme",
- "version": "0.9.8",
+ "version": "0.9.9",
"repository": {
"type": "git",
"url": "git://github.com/joyent/node-http-signature.git"
},
"engines": {
- "node": ">=0.4.9"
+ "node": ">=0.6"
},
"main": "lib/index.js",
"scripts": {
"pretest": "which gjslint; if [[ \"$?\" = 0 ]] ; then gjslint --nojsdoc -r . -e node_modules; else echo \"Missing gjslint. Skipping lint\"; fi",
"test": "./node_modules/.bin/tap tst/*.js"
},
"dependencies": {
- "asn1": "0.1.9",
- "ctype": "0.3.1",
- "sprintf": "0.1.1"
+ "asn1": "0.1.11",
+ "ctype": "0.5.0"
},
"devDependencies": {
"httpu": "1.0.0",
- "node-uuid": "1.2.0",
- "tap": "0.0.14"
+ "node-uuid": "1.3.3",
+ "tap": "0.2.4"
}
}

2 comments on commit a995d20

Phew! Glad this is just window dressing! :)

Contributor

mcavage replied Mar 19, 2012

Yeah - this was nothing ;) - the ctype library at older versions was hard-requiring node 0.4 || 0.6, thus making npm install http-signature fail on the 0.7 branch of node.

Please sign in to comment.