Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100755 402 lines (316 sloc) 11.146 kb
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
1 #!/usr/bin/env python
2 import optparse
3 import os
45605c9 @jbergstroem gyp: switch json for pprint when generating config
jbergstroem authored
4 import pprint
30b29d8 @bnoordhuis build: disable -fstrict-aliasing if gcc < 4.6.0
bnoordhuis authored
5 import re
b9e1bb3 @bnoordhuis build: auto-run tools/gyp_node after ./configure
bnoordhuis authored
6 import subprocess
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
7 import sys
5cf4cef @ry add configure
ry authored
8
5062741 @bnoordhuis build: make CC command in -fstrict-aliasing check configurable
bnoordhuis authored
9 CC = os.environ.get('CC', 'cc')
10
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
11 root_dir = os.path.dirname(__file__)
12 sys.path.insert(0, os.path.join(root_dir, 'deps', 'v8', 'tools'))
97c9745 @ry Back to WAF
ry authored
13
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
14 # parse our options
15 parser = optparse.OptionParser()
97c9745 @ry Back to WAF
ry authored
16
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
17 parser.add_option("--debug",
18 action="store_true",
19 dest="debug",
20 help="Also build debug build")
21
22 parser.add_option("--prefix",
23 action="store",
24 dest="prefix",
25 help="Select the install prefix (defaults to /usr/local)")
26
a9f2c4a @indutny --without-npm option
indutny authored
27 parser.add_option("--without-npm",
28 action="store_true",
29 dest="without_npm",
30 help="Don\'t install the bundled npm package manager")
31
6e76a7c @indutny installer: install node-waf
indutny authored
32 parser.add_option("--without-waf",
33 action="store_true",
34 dest="without_waf",
35 help="Don\'t install node-waf")
36
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
37 parser.add_option("--without-ssl",
38 action="store_true",
39 dest="without_ssl",
40 help="Build without SSL")
41
42 parser.add_option("--without-snapshot",
43 action="store_true",
44 dest="without_snapshot",
45 help="Build without snapshotting V8 libraries. You might want to set"
46 " this for cross-compiling. [Default: False]")
47
48 parser.add_option("--shared-v8",
49 action="store_true",
50 dest="shared_v8",
51 help="Link to a shared V8 DLL instead of static linking")
52
53 parser.add_option("--shared-v8-includes",
54 action="store",
55 dest="shared_v8_includes",
56 help="Directory containing V8 header files")
57
58 parser.add_option("--shared-v8-libpath",
59 action="store",
60 dest="shared_v8_libpath",
61 help="A directory to search for the shared V8 DLL")
62
63 parser.add_option("--shared-v8-libname",
64 action="store",
65 dest="shared_v8_libname",
66 help="Alternative lib name to link to (default: 'v8')")
67
e61de70 @ry gyp: use built-in openssl by default
ry authored
68 parser.add_option("--openssl-use-sys",
70e6889 @TooTallNate build: make --openssl-use-sys a boolean option
TooTallNate authored
69 action="store_true",
e61de70 @ry gyp: use built-in openssl by default
ry authored
70 dest="openssl_use_sys",
71 help="Use the system OpenSSL instead of one included with Node")
72
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
73 parser.add_option("--openssl-includes",
74 action="store",
75 dest="openssl_includes",
76 help="A directory to search for the OpenSSL includes")
77
78 parser.add_option("--openssl-libpath",
79 action="store",
80 dest="openssl_libpath",
81 help="A directory to search for the OpenSSL libraries")
82
83 parser.add_option("--no-ssl2",
84 action="store_true",
85 dest="no_ssl2",
86 help="Disable OpenSSL v2")
87
d03b848 @tchollingsworth build: support shared zlib
tchollingsworth authored
88 parser.add_option("--shared-zlib",
89 action="store_true",
90 dest="shared_zlib",
91 help="Link to a shared zlib DLL instead of static linking")
92
93 parser.add_option("--shared-zlib-includes",
94 action="store",
95 dest="shared_zlib_includes",
96 help="Directory containing zlib header files")
97
98 parser.add_option("--shared-zlib-libpath",
99 action="store",
100 dest="shared_zlib_libpath",
101 help="A directory to search for the shared zlib DLL")
102
103 parser.add_option("--shared-zlib-libname",
104 action="store",
105 dest="shared_zlib_libname",
106 help="Alternative lib name to link to (default: 'z')")
107
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
108 parser.add_option("--with-dtrace",
109 action="store_true",
110 dest="with_dtrace",
cc15299 @davepacheco build: add support for DTrace and postmortem
davepacheco authored
111 help="Build with DTrace (default is true on supported systems)")
112
113 parser.add_option("--without-dtrace",
114 action="store_true",
115 dest="without_dtrace",
116 help="Build without DTrace")
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
117
35a1421 Windows: Enable ETW events.
Igor Zinkovsky authored
118 parser.add_option("--with-etw",
119 action="store_true",
120 dest="with_etw",
121 help="Build with ETW (default is true on Windows)")
122
123 parser.add_option("--without-etw",
124 action="store_true",
125 dest="without_etw",
126 help="Build without ETW")
127
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
128 # CHECKME does this still work with recent releases of V8?
129 parser.add_option("--gdb",
130 action="store_true",
131 dest="gdb",
132 help="add gdb support")
133
134 parser.add_option("--dest-cpu",
135 action="store",
136 dest="dest_cpu",
137 help="CPU architecture to build for. Valid values are: arm, ia32, x64")
138
0ef6cfd @isaacs Fix #3465 Add ./configure --no-ifaddrs flag
isaacs authored
139 parser.add_option("--no-ifaddrs",
140 action="store_true",
141 dest="no_ifaddrs",
142 help="Use on deprecated SunOS systems that do not support ifaddrs.h")
143
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
144 (options, args) = parser.parse_args()
145
146
a033261 @bnoordhuis build: DRY configure script
bnoordhuis authored
147 def b(value):
148 """Returns the string 'true' if value is truthy, 'false' otherwise."""
149 if value:
150 return 'true'
151 else:
152 return 'false'
153
154
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
155 def pkg_config(pkg):
156 cmd = os.popen('pkg-config --libs %s' % pkg, 'r')
157 libs = cmd.readline().strip()
158 ret = cmd.close()
159 if (ret): return None
160
161 cmd = os.popen('pkg-config --cflags %s' % pkg, 'r')
162 cflags = cmd.readline().strip()
163 ret = cmd.close()
164 if (ret): return None
165
166 return (libs, cflags)
167
168
dc75232 @TooTallNate vcbuild: run the 'configure' script in vcbuild.bat
TooTallNate authored
169 def host_arch_cc():
170 """Host architecture check using the CC command."""
19133ca @TooTallNate build: better host_arch() definition in configure
TooTallNate authored
171
792d9a9 @javihernandez build: print error message if no compiler found
javihernandez authored
172 try:
173 p = subprocess.Popen(CC.split() + ['-dM', '-E', '-'],
174 stdin=subprocess.PIPE,
175 stdout=subprocess.PIPE,
176 stderr=subprocess.PIPE)
177 except OSError:
178 print '''Node.js configure error: No acceptable C compiler found!
179
180 Please make sure you have a C compiler installed on your system and/or
181 consider adjusting the CC environment variable if you installed
182 it in a non-standard prefix.
183 '''
184 sys.exit()
185
19133ca @TooTallNate build: better host_arch() definition in configure
TooTallNate authored
186 p.stdin.write('\n')
187 out = p.communicate()[0]
188
189 out = str(out).split('\n')
190
191 k = {}
192 for line in out:
193 import shlex
194 lst = shlex.split(line)
195 if len(lst) > 2:
196 key = lst[1]
197 val = lst[2]
198 k[key] = val
199
200 matchup = {
201 '__x86_64__' : 'x64',
202 '__i386__' : 'ia32',
203 '__arm__' : 'arm',
09ccbef @Skomski build: detect host_arch better
Skomski authored
204 }
205
19133ca @TooTallNate build: better host_arch() definition in configure
TooTallNate authored
206 rtn = 'ia32' # default
207
208 for i in matchup:
209 if i in k and k[i] != '0':
210 rtn = matchup[i]
211 break
09ccbef @Skomski build: detect host_arch better
Skomski authored
212
19133ca @TooTallNate build: better host_arch() definition in configure
TooTallNate authored
213 return rtn
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
214
215
dc75232 @TooTallNate vcbuild: run the 'configure' script in vcbuild.bat
TooTallNate authored
216 def host_arch_win():
217 """Host architecture check using environ vars (better way to do this?)"""
218
219 arch = os.environ.get('PROCESSOR_ARCHITECTURE', 'x86')
220
221 matchup = {
222 'AMD64' : 'x64',
223 'x86' : 'ia32',
224 'arm' : 'arm',
225 }
226
227 return matchup.get(arch, 'ia32')
228
229
230 def host_arch():
231 """Host architecture. One of arm, ia32 or x64."""
232 if os.name == 'nt':
233 arch = host_arch_win()
234 else:
235 arch = host_arch_cc()
236 return arch
237
238
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
239 def target_arch():
240 return host_arch()
241
c9676c9 @sdqali build: improve c compiler detection
sdqali authored
242 def cc_version():
30b29d8 @bnoordhuis build: disable -fstrict-aliasing if gcc < 4.6.0
bnoordhuis authored
243 try:
5062741 @bnoordhuis build: make CC command in -fstrict-aliasing check configurable
bnoordhuis authored
244 proc = subprocess.Popen([CC, '-v'], stderr=subprocess.PIPE)
30b29d8 @bnoordhuis build: disable -fstrict-aliasing if gcc < 4.6.0
bnoordhuis authored
245 except OSError:
246 return None
c9676c9 @sdqali build: improve c compiler detection
sdqali authored
247 lines = proc.communicate()[1].split('\n')
248 version_line = None
249 for i, line in enumerate(lines):
250 if 'version' in line:
251 version_line = line
252 if not version_line:
253 return None
254 version = version_line.split("version")[1].strip().split()[0].split(".")
255 if not version:
256 return None
257 return ['LLVM' in version_line] + version
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
258
259 def configure_node(o):
93465d3 @bnoordhuis build: support --dest-cpu configure switch again
bnoordhuis authored
260 # TODO add gdb
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
261 o['variables']['node_prefix'] = options.prefix if options.prefix else ''
a9f2c4a @indutny --without-npm option
indutny authored
262 o['variables']['node_install_npm'] = b(not options.without_npm)
6e76a7c @indutny installer: install node-waf
indutny authored
263 o['variables']['node_install_waf'] = b(not options.without_waf)
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
264 o['variables']['host_arch'] = host_arch()
93465d3 @bnoordhuis build: support --dest-cpu configure switch again
bnoordhuis authored
265 o['variables']['target_arch'] = options.dest_cpu or target_arch()
680d75a @shigeki build: make default_configuration consistent with BUILDTYPE
shigeki authored
266 o['default_configuration'] = 'Debug' if options.debug else 'Release'
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
267
30b29d8 @bnoordhuis build: disable -fstrict-aliasing if gcc < 4.6.0
bnoordhuis authored
268 # turn off strict aliasing if gcc < 4.6.0 unless it's llvm-gcc
269 # see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=45883
270 # see http://code.google.com/p/v8/issues/detail?id=884
5062741 @bnoordhuis build: make CC command in -fstrict-aliasing check configurable
bnoordhuis authored
271 o['variables']['strict_aliasing'] = b(
c9676c9 @sdqali build: improve c compiler detection
sdqali authored
272 'clang' in CC or cc_version() >= [False, 4, 6, 0])
30b29d8 @bnoordhuis build: disable -fstrict-aliasing if gcc < 4.6.0
bnoordhuis authored
273
5ebc05f @bnoordhuis build: disable -fvisibility=hidden if gcc < 4.0.0
bnoordhuis authored
274 # clang has always supported -fvisibility=hidden, right?
c9676c9 @sdqali build: improve c compiler detection
sdqali authored
275 if 'clang' not in CC and cc_version() < [False, 4, 0, 0]:
5ebc05f @bnoordhuis build: disable -fvisibility=hidden if gcc < 4.0.0
bnoordhuis authored
276 o['variables']['visibility'] = ''
30b29d8 @bnoordhuis build: disable -fstrict-aliasing if gcc < 4.6.0
bnoordhuis authored
277
cc15299 @davepacheco build: add support for DTrace and postmortem
davepacheco authored
278 # By default, enable DTrace on SunOS systems. Don't allow it on other
279 # systems, since it won't work. (The MacOS build process is different than
280 # SunOS, and we haven't implemented it.)
281 if sys.platform.startswith('sunos'):
282 o['variables']['node_use_dtrace'] = b(not options.without_dtrace);
c393853 @isaacs build: Set strict_aliasing on SunOS always
isaacs authored
283 # Strict aliasing causes problems with the V8 snapshots on SunOS
284 o['variables']['strict_aliasing'] = b(False);
cc15299 @davepacheco build: add support for DTrace and postmortem
davepacheco authored
285 elif b(options.with_dtrace) == 'true':
286 raise Exception('DTrace is currently only supported on SunOS systems.')
287 else:
288 o['variables']['node_use_dtrace'] = 'false'
289
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
290
35a1421 Windows: Enable ETW events.
Igor Zinkovsky authored
291 # By default, enable ETW on Windows.
292 if sys.platform.startswith('win32'):
293 o['variables']['node_use_etw'] = b(not options.without_etw);
294 elif b(options.with_etw) == 'true':
295 raise Exception('ETW is only supported on Windows.')
296 else:
297 o['variables']['node_use_etw'] = 'false'
298
299
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
300 def configure_libz(o):
d03b848 @tchollingsworth build: support shared zlib
tchollingsworth authored
301 o['variables']['node_shared_zlib'] = b(options.shared_zlib)
302
303 # assume shared_zlib if one of these is set?
304 if options.shared_zlib_libpath:
305 o['libraries'] += ['-L%s' % options.shared_zlib_libpath]
306 if options.shared_zlib_libname:
307 o['libraries'] += ['-l%s' % options.shared_zlib_libname]
308 elif options.shared_zlib:
309 o['libraries'] += ['-lz']
310 if options.shared_zlib_includes:
311 o['include_dirs'] += [options.shared_zlib_includes]
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
312
313
314 def configure_v8(o):
a033261 @bnoordhuis build: DRY configure script
bnoordhuis authored
315 o['variables']['v8_use_snapshot'] = b(not options.without_snapshot)
316 o['variables']['node_shared_v8'] = b(options.shared_v8)
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
317
318 # assume shared_v8 if one of these is set?
319 if options.shared_v8_libpath:
320 o['libraries'] += ['-L%s' % options.shared_v8_libpath]
321 if options.shared_v8_libname:
322 o['libraries'] += ['-l%s' % options.shared_v8_libname]
59ecf2c @isaacs Revert "Revert "build: support shared V8 properly""
isaacs authored
323 elif options.shared_v8:
324 o['libraries'] += ['-lv8']
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
325 if options.shared_v8_includes:
326 o['include_dirs'] += [options.shared_v8_includes]
59ecf2c @isaacs Revert "Revert "build: support shared V8 properly""
isaacs authored
327 o['variables']['node_shared_v8_includes'] = options.shared_v8_includes
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
328
329
330 def configure_openssl(o):
a033261 @bnoordhuis build: DRY configure script
bnoordhuis authored
331 o['variables']['node_use_openssl'] = b(not options.without_ssl)
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
332
333 if options.without_ssl:
334 return
335
0ef6cfd @isaacs Fix #3465 Add ./configure --no-ifaddrs flag
isaacs authored
336 if options.no_ifaddrs:
337 o['defines'] += ['SUNOS_NO_IFADDRS']
338
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
339 if options.no_ssl2:
340 o['defines'] += ['OPENSSL_NO_SSL2=1']
341
e61de70 @ry gyp: use built-in openssl by default
ry authored
342 if not options.openssl_use_sys:
fe464a2 @ry Rename GYP variable node_use_system_openssl to be consistent
ry authored
343 o['variables']['node_shared_openssl'] = b(False)
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
344 else:
e61de70 @ry gyp: use built-in openssl by default
ry authored
345 out = pkg_config('openssl')
346 (libs, cflags) = out if out else ('', '')
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
347
e61de70 @ry gyp: use built-in openssl by default
ry authored
348 if options.openssl_libpath:
349 o['libraries'] += ['-L%s' % options.openssl_libpath, '-lssl', '-lcrypto']
350 else:
351 o['libraries'] += libs.split()
352
353 if options.openssl_includes:
354 o['include_dirs'] += [options.openssl_includes]
355 else:
356 o['cflags'] += cflags.split()
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
357
fe464a2 @ry Rename GYP variable node_use_system_openssl to be consistent
ry authored
358 o['variables']['node_shared_openssl'] = b(
e61de70 @ry gyp: use built-in openssl by default
ry authored
359 libs or cflags or options.openssl_libpath or options.openssl_includes)
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
360
361
362 output = {
363 'variables': {},
364 'include_dirs': [],
365 'libraries': [],
366 'defines': [],
367 'cflags': [],
368 }
369
370 configure_node(output)
371 configure_libz(output)
372 configure_v8(output)
373 configure_openssl(output)
374
375 # variables should be a root level element,
376 # move everything else to target_defaults
377 variables = output['variables']
378 del output['variables']
379 output = {
380 'variables': variables,
381 'target_defaults': output
382 }
624f70e @ry GYP: rename options.gypi to config.gypi
ry authored
383 pprint.pprint(output, indent=2)
14b04b0 @ry Remove SCONS deprecate WAF
ry authored
384
e493b29 @bnoordhuis build: respect --debug configure switch
bnoordhuis authored
385 def write(filename, data):
386 filename = os.path.join(root_dir, filename)
387 print "creating ", filename
fdeeabb @TooTallNate configure: don't use "with" for Python 2.5 and older
TooTallNate authored
388 f = open(filename, 'w+')
389 f.write(data)
e493b29 @bnoordhuis build: respect --debug configure switch
bnoordhuis authored
390
391 write('config.gypi', "# Do not edit. Generated by the configure script.\n" +
9b7a6c5 @TooTallNate configure: output a newline at the end of config.gypi
TooTallNate authored
392 pprint.pformat(output, indent=2) + "\n")
e493b29 @bnoordhuis build: respect --debug configure switch
bnoordhuis authored
393
394 write('config.mk', "# Do not edit. Generated by the configure script.\n" +
395 ("BUILDTYPE=%s\n" % ('Debug' if options.debug else 'Release')))
97c9745 @ry Back to WAF
ry authored
396
dc75232 @TooTallNate vcbuild: run the 'configure' script in vcbuild.bat
TooTallNate authored
397 if os.name == 'nt':
398 subprocess.call(['python', 'tools/gyp_node', '-f', 'msvs',
399 '-G', 'msvs_version=2010'])
400 else:
401 subprocess.call(['tools/gyp_node', '-f', 'make'])
Something went wrong with that request. Please try again.