Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Is `require.extensions` not documented on purpose? #3028

Closed
beatgammit opened this Issue · 3 comments

4 participants

@beatgammit

I've seen a few node modules using require.extensions (such as js-yaml), but I haven't found it in the node docs. I'm checking here.

If this is a supported feature, then it should be documented. If it is undocumented because it was not meant to be documented, then perhaps it should be a read-only object (writable: false) instead.

I understand that no changes are being made to the module system at this time, but I think this should be documented.

@TooTallNate
Owner

Ya it should be documented. Patches welcome :)

@isaacs
Owner

Precisely because it's not going to change, yes. Patch welcome.

@shama shama referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@shama shama referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@shama shama referenced this issue from a commit in shama/node
@shama shama doc: add require.extensions to globals
Closes #3028
6dbe155
@bnoordhuis

Fixed in 718aa50.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.