Skip to content

g++: error: /opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtbegin.o: No such file or directory #10

Closed
risto3 opened this Issue Oct 25, 2012 · 2 comments

2 participants

@risto3
risto3 commented Oct 25, 2012

Now actually pleased with progress and have been able to build a number of packages, I wanted to build pkgsrc/doc/guide wherein a depency on textutils/opensp croaks...
seems to be a libtool problem with gcc47, looking in the wrong place.... /opt/pbulk

libtool: link: g++ -shared -nostdlib -L/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0 -Wl,-R/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0 -L/opt/pkg/gcc47/lib -Wl,-R/opt/pkg/gcc47/lib -L/opt/pkg/lib -Wl,-R/opt/pkg/lib -L/usr/lib -Wl,-R/usr/lib /usr/lib/amd64/crti.o /usr/lib/amd64/values-Xa.o /opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtbegin.o  .libs/Allocator.o .libs/ArcEngine.o .libs/Attribute.o .libs/Big5CodingSystem.o .libs/CharsetDecl.o .libs/CharsetInfo.o .libs/CharsetRegistry.o .libs/CmdLineApp.o .libs/CodingSystem.o .libs/CodingSystemKit.o .libs/ConsoleOutput.o .libs/ContentState.o .libs/ContentToken.o .libs/DescriptorManager.o .libs/Dtd.o .libs/DtdDeclEventHandler.o .libs/EUCJPCodingSystem.o .libs/ElementType.o .libs/Entity.o .libs/EntityApp.o .libs/EntityCatalog.o .libs/EntityDecl.o .libs/EntityManager.o .libs/ErrnoMessageArg.o .libs/ErrorCountEventHandler.o .libs/Event.o .libs/EventGenerator.o .libs/ExtendEntityManager.o .libs/ExternalId.o .libs/Fixed2CodingSystem.o .libs/GenericEventHandler.o .libs/Group.o .libs/Hash.o .libs/IListBase.o .libs/Id.o .libs/IdentityCodingSystem.o .libs/InputSource.o .libs/InternalInputSource.o .libs/Link.o .libs/LinkProcess.o .libs/LiteralStorage.o .libs/Location.o .libs/Lpd.o .libs/Markup.o .libs/Message.o .libs/MessageArg.o .libs/MessageEventHandler.o .libs/MessageFormatter.o .libs/MessageReporter.o .libs/MessageTable.o .libs/ModeInfo.o .libs/Notation.o .libs/NotationStorage.o .libs/NumericCharRefOrigin.o .libs/OffsetOrderedList.o .libs/OpenElement.o .libs/OutputByteStream.o .libs/OutputCharStream.o .libs/OutputState.o .libs/Param.o .libs/Parser.o .libs/ParserApp.o .libs/ParserEventGeneratorKit.o .libs/ParserMessages.o .libs/ParserOptions.o .libs/ParserState.o .libs/Partition.o .libs/PosixStorage.o .libs/Recognizer.o .libs/RewindStorageObject.o .libs/SGMLApplication.o .libs/SJISCodingSystem.o .libs/SOEntityCatalog.o .libs/Sd.o .libs/SdText.o .libs/SearchResultMessageArg.o .libs/SgmlParser.o .libs/ShortReferenceMap.o .libs/StdioStorage.o .libs/StorageManager.o .libs/Syntax.o .libs/Text.o .libs/TokenMessageArg.o .libs/TranslateCodingSystem.o .libs/TrieBuilder.o .libs/TypeId.o .libs/URLStorage.o .libs/UTF8CodingSystem.o .libs/Undo.o .libs/UnicodeCodingSystem.o .libs/UnivCharsetDesc.o .libs/XMLCodingSystem.o .libs/assert.o .libs/parseAttribute.o .libs/parseCommon.o .libs/parseDecl.o .libs/parseInstance.o .libs/parseMode.o .libs/parseParam.o .libs/parseSd.o .libs/splib.o .libs/app_inst.o .libs/arc_inst.o .libs/entmgr_inst.o .libs/parser_inst.o .libs/xentmgr_inst.o .libs/SubstTable.o .libs/UTF16CodingSystem.o .libs/Fixed4CodingSystem.o .libs/memcmp.o .libs/memmove.o .libs/strerror.o   -Wl,-R -Wl,/home/richard/src/pkgsrc/textproc/opensp/work.devzone/.buildlink/lib -Wl,-R -Wl,/opt/pkg/gcc47/lib -Wl,-R -Wl,/home/richard/src/pkgsrc/textproc/opensp/work.devzone/.buildlink/lib -Wl,-R -Wl,/opt/pkg/gcc47/lib -Wl,-R -Wl,/opt/pkg/lib -L/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0 -L/opt/pkg/gcc47/lib -L/home/richard/src/pkgsrc/textproc/opensp/work.devzone/.buildlink/lib /home/richard/src/pkgsrc/textproc/opensp/work.devzone/.buildlink/lib/libintl.so /home/richard/src/pkgsrc/textproc/opensp/work.devzone/.buildlink/lib/libiconv.so -lpthread -lnsl -lsocket -L/opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0 -L/opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/../../../amd64 -L/lib/amd64 -L/usr/lib/amd64 -L/opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/../../.. /opt/pkg/gcc47/lib/libstdc++.so -lm -lc -lgcc_s /opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtend.o /usr/lib/amd64/crtn.o  -Wl,-R/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0 -Wl,-R/opt/pkg/gcc47/lib -Wl,-R/opt/pkg/lib   -Wl,-h -Wl,libosp.so.5 -o .libs/libosp.so.5.0.0
g++: error: /opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtbegin.o: No such file or directory
g++: error: /opt/pbulk/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtend.o: No such file or directory
make[3]: *** [libosp.la] Error 1
make[3]: Leaving directory `/home/richard/src/pkgsrc/textproc/opensp/work.devzone/OpenSP-1.5.2/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/richard/src/pkgsrc/textproc/opensp/work.devzone/OpenSP-1.5.2/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/richard/src/pkgsrc/textproc/opensp/work.devzone/OpenSP-1.5.2'
gmake: *** [all] Error 2
*** Error code 2

Stop.
bmake: stopped in /home/richard/src/pkgsrc/textproc/opensp
*** Error code 1

Stop.
bmake: stopped in /home/richard/src/pkgsrc/textproc/opensp

the files sought after are here:

richard@devzone:~/src/pkgsrc/textproc/opensp$ find /opt -name crtend.o
/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/32/crtend.o
/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtend.o
richard@devzone:~/src/pkgsrc/textproc/opensp$ find /opt -name crtbegin.o
/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/32/crtbegin.o
/opt/pkg/gcc47/lib/gcc/x86_64-sun-solaris2.11/4.7.0/crtbegin.o

thoughts as to at least a temporary workaround?

@jperkin
Joyent member
@risto3
risto3 commented Oct 25, 2012

ok, globally changed /opt/pbulk/... to /opt/pkg/... and opensp seemed to complete and was able to bmake install.
Now on to finish doc/guide.
cheers

@jperkin jperkin pushed a commit that referenced this issue Nov 13, 2012
pettai 1.1.4
  - Fix X-HKP-Results-Count so that limit=0 returns no results, but include
    the header, to let a client poll for how many results exist, without
    retrieving any. See:
    http://lists.nongnu.org/archive/html/sks-devel/2010-11/msg00015.html
  - Add UPGRADING document to explain upgrading Berkeley DB without
    rebuilding. System bdb versions often change with new SKS releases
    for .deb and .rpm distros.
  - Cleanup build errors for bdb/bdb_stubs.c. Patch from Mike Doty
  - Update cryptokit from version 1.0 to 1.5 without requiring OASIS
    build system or other additional dependencies
  - build, fastbuild, & pbuild fixed to ignore signals USR1 and USR2
  - common.ml and reconSC.ml were using different values for minumimum
    compatible version. This has been fixed.
  - Added new server mime-types, and trying another default document (Issue 6)
    In addition to the new MIME types added in 1.1.[23], the server now
    looks over a list and and serves the first index file that it finds
    Current list: index.html, index.htm, index.xhtml, index.xhtm, index.xml.
  - options=mr now works on get as well as (v)index operations. This is
    described in http://tools.ietf.org/html/draft-shaw-openpgp-hkp-00
    sections 3.2.1.1. and 5.1.
  - Updated copyright notices in source files
  - Added sksclient tool, similar to old pksclient
  - Add no-cache instructions to HTTP response (in order for reverse proxies
    not to cache the output from SKS)
  - Use unique timestamps for keydb to reduce occurrances of Ptree corruption.
  - Added Interface specifications (.mli files) for modules that were missing
    them
  - Yaron pruned some no longer needed source files from the tree.
  - Improved the HTTP status and HTTP error codes returned for various
    situations and added checks for more error conditions.
  - Add a suffix to version (+) indicating non-release or development builds
  - Add an option to specify the contact details of the server administrator
    that shows in the status page of the server. The information is in the
    form of an OpenPGP KeyID and set by server_contact: in sksconf
  - Add a `sks version` command to provide information on the setup.
  - Added configuration settings for the remaining database table files. If
    no pagesize settings are in sksconf, SKS will use 2048 bytes for key
    and 512 for ptree. The remainining files' pagesize will be set by BDB
    based on the filesystem settings, typically this is 4096 bytes.
    See sampleConfig/sksconf.typical for settings recommended by db_tuner.
  - Makefile: Added distclean target. Dropped autogenerated file from VCS.
  - Allow tuning BDB environment before creation in [fast]build and pbuild.
    If DB_CONFIG exists in basedir, copy it to DB dir before DB creation.
    Preference is given to DB_CONFIG.KDB and DB_CONFIG.PTree over DB_CONFIG.
  - Add support for Elliptic Curve Public keys (ECDSA, ECDH)
  - Add check if an upload is a revocation certificate, and if it is,
    produce an error message tailored for this.

1.1.3
  - Makefile fix for 'make dep' if .depend does not exist. Issue #4
  - Makefile fix: sks and sks_add_mail fail to link w/o '-ccopt -pg'
    Issue #23
  - Added -disable_mailsync and -disable_log_diffs to sks.pod
  - Added file extensions .css, .jpeg, .htm, .es, .js, .xml, .shtml, .xhtm,
    .xhtml and associated MIME types to server code. Part of Issue #6
  - Added sample configuration files in sampleConfig directory
  - Added sample web page files in sampleWeb directory. Issues #7, 9, 19
  - Allow requests for non-official options hget, hash, status, & clean to
    be preceded by '-x'. Closes issues #10, 11, 13, & 14.
  - Allow &search with long subkey ID (16 digit) and subkey fingerprint
    subkey lookup was failing with other than a short key ID. However,
    public key lookup was working with short and long key ID and fingerprints.
    This patch makes subkey lookup behave the same as full key lookup.
    http://lists.gnupg.org/pipermail/gnupg-users/2012-January/043495.html
  - Patch recon script so that POST includes HTTP version number.
2d044be
@jperkin jperkin pushed a commit that referenced this issue Dec 11, 2012
wen Update to 0.95
Upstream changes:
0.95  Sat Dec  8 15:11:09 2012
    - U::C::Locale newly supports locales: bs_Cyrl, ee.
    - updated to CLDR 21: uk.
    - updated to CLDR 22: th, to.
    - added loc_bscy.t, loc_ee.t in t.
    - modified tests: loc_th.t, loc_to.t, loc_uk.t in t.

0.94  Fri Nov 23 18:45:53 2012
    - U::C::Locale newly supports locale: zh__zhuyin.
    - added Unicode::Collate::CJK::Zhuyin for zh__zhuyin.
    - doc: added CAVEAT to CJK/Stroke.pm
    - modified tests: loc_cjk.t, loc_cjkc.t in t.
    - added cjk_zy.t, loc_zhzy.t in t.

0.93  Sun Nov 18 18:13:42 2012
    - DUCET is updated (for Unicode 6.2.0) as Collate/allkeys.txt.
    ! Please notice that allkeys.txt will be overwritten if you have had
      other allkeys.txt already.
    - The default UCA_Version is 26.
    - Locale/*.pl (except fr.pl) and CJK/Korean.pm are updated.
    - modified tests: loc_es.t, loc_estr.t, version.t in t.

0.92  Wed Nov 14 20:58:19 2012
    - fix: index() etc. with preprocess/normalization should be always croaked.
    - doc: referred to the latest UTS #10 and updated its section numbers.
    - supported the identical level (see 'identical' in POD).
    - Now UCA_Version 26 (for Unicode 6.2.0) is supported.
      * But the default UCA_Version is still 24.
    - added ident.t in t.
    - modified tests: cjkrange.t, compatui.t, hangtype.t, index.t,
      overcjk0.t, overcjk1.t, test.t, view.t in t.

0.91  Sun Nov  4 17:00:20 2012
    - XSUB: use PERL_NO_GET_CONTEXT (see perlguts)
      (see [rt.cpan.org #80313])

0.90  Sun Sep 23 10:42:26 2012
    - perl 5.11.0 or later: Install to 'site' instead of 'perl'
      (see [rt.cpan.org #79800])
c8471d0
@jperkin jperkin pushed a commit that referenced this issue Jan 2, 2013
obache Update ruby-ole to 1.2.11.5.
== 1.2.11.5 / 2012-11-06

- Fix breakage of IO.parse_mode on Rubinius (issue #10).
- Make tests pass on rubinius (issue #11).
- Improve RangesIO test coverage.
- Don't warn when mbat_start is AVAIL instead of EOC (github #9).
98a7195
@jperkin jperkin pushed a commit that referenced this issue Feb 14, 2013
taca Update ruby-diff-lcs to 1.2.1.
== 1.2.1 / 2013-02-09

* Bugs Fixed:
  * As seen in rspec/rspec-expectations#200, the
    release of Diff::LCS 1.2 introduced an unnecessary public API change to
    Diff::LCS::Hunk (see the change at
    rspec/rspec-expectations@3d6fc82 for details).
    The new method name (and behaviour) is more correct, but I should not have
    renamed the function or should have at least provided an alias. This
    release restores Diff::LCS::Hunk#unshift as an alias to
    #merge. Note that the old #unshift behaviour was incorrect and will not be
    restored.

== 1.2.0 / 2013-01-21
* Minor Enhancements:
  * Added special case handling for Diff::LCS.patch so that it handles patches
    that are empty or contain no changes.
  * Added two new methods (#patch\_me and #unpatch\_me) to the includable
    module.
* Bugs Fixed:
  * Fixed issue #1 patch direction detection.
    halostatue/diff-lcs#1
  * Resolved issue #2 by handling string[string.size, 1] properly (it returns
    "" not nil). halostatue/diff-lcs#2
  * Michael Granger (ged) fixed an implementation error in Diff::LCS::Change
    and added specs in pull request #8. Thanks!
    halostatue/diff-lcs#8
  * Made the code auto-testable.
  * Vít Ondruch (voxik) provided the latest version of the GPL2 license file in
    pull request #10. Thanks! halostatue/diff-lcs#10
  * Fixed a documentation issue with the includable versions of #patch! and
    #unpatch! where they implied that they would replace the original value.
    Given that Diff::LCS.patch always returns a copy, the documentation was
    incorrect and has been corrected. To provide the behaviour that was
    originally documented, two new methods were added to provide this
    behaviour. Found by scooter-dangle in issue #12. Thanks!
    halostatue/diff-lcs#12
* Code Style Changes:
  * Removed trailing spaces.
  * Calling class methods using '.' instead of '::'.
  * Vít Ondruch (voxik) removed unnecessary shebangs in pull request #9.
    Thanks! halostatue/diff-lcs#9
  * Kenichi Kamiya (kachick) removed some warnings of an unused variable in
    lucky pull request #13. halostatue/diff-lcs#13
    Thanks!
  * Embarked on a major refactoring to make the files a little more manageable
    and understand the code on a deeper level.
  * Adding to http://travis-ci.org.
2670083
@risto3 risto3 closed this Mar 6, 2013
@jperkin jperkin pushed a commit that referenced this issue Jul 4, 2013
wiz Update to 0.7.7. Simplify. Set LICENSE. Allow python-3.x.
-----
0.7.7
-----

* Distribute #375: Repair AttributeError created in last release (redo).
* Issue #30: Added test for get_cache_path.

-----
0.7.6
-----

* Distribute #375: Repair AttributeError created in last release.

-----
0.7.5
-----

* Issue #21: Restore Python 2.4 compatibility in ``test_easy_install``.
* Distribute #375: Merged additional warning from Distribute 0.6.46.
* Now honor the environment variable
  ``SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT`` in addition to the now
  deprecated ``DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT``.

-----
0.7.4
-----

* Issue #20: Fix comparison of parsed SVN version on Python 3.

-----
0.7.3
-----

* Issue #1: Disable installation of Windows-specific files on non-Windows systems.
* Use new sysconfig module with Python 2.7 or >=3.2.

-----
0.7.2
-----

* Issue #14: Use markerlib when the `parser` module is not available.
* Issue #10: ``ez_setup.py`` now uses HTTPS to download setuptools from PyPI.

-----
0.7.1
-----

* Fix NameError (Issue #3) again - broken in bad merge.

---
0.7
---

* Merged Setuptools and Distribute. See docs/merge.txt for details.

Added several features that were slated for setuptools 0.6c12:

* Index URL now defaults to HTTPS.
* Added experimental environment marker support. Now clients may designate a
  PEP-426 environment marker for "extra" dependencies. Setuptools uses this
  feature in ``setup.py`` for optional SSL and certificate validation support
  on older platforms. Based on Distutils-SIG discussions, the syntax is
  somewhat tentative. There should probably be a PEP with a firmer spec before
  the feature should be considered suitable for use.
* Added support for SSL certificate validation when installing packages from
  an HTTPS service.

-----
0.7b4
-----

* Issue #3: Fixed NameError in SSL support.
e522e30
@wiedi wiedi pushed a commit to wiedi/pkgsrc that referenced this issue Dec 4, 2013
wiz Update to 3.3.2:
Summary of changes between libmikmod 3.2.0 and libmikmod 3.3.2 ():
==========================================================================

libmikmod 3.3.2 was released on 05-Oct-2013.

This is a serious bug fix release after the previous 3.2.0 series, with
some additional new features. All who are using libmikmod-3.2.0 (or the
interim 3.3.1-beta) must upgrade to the new libmikmod-3.3.2 version.

THANKS

- Paul Spark <sparkynz74@gmail.com> for Microsoft Visual C 6.0 fixes.
- Ozkan Sezer: many changes.

NEW FEATURES

- New CMake build system.
- Updated configury, support for cross-compilation, support for building
  in a separate directory, support latest autotools.
- New SDL driver - works both with SDL-1.2.x and with SDL2, supports
  floating point output if compiled against SDL2.
- New OpenAL driver, originally suggested by 'kervala', with fixes and
  updates and with floating point output support.
- The multi-platform SDL and OpenAL drivers, if they are compiled, have
  priority over OS-specific hw drivers for MikMod_RegisterAllDrivers().
- New windows xaudio2 driver, originally suggested by 'honza.c', with
  updates, xaudio2.8 support and with floating point output support.
- ALSA driver now supports only the contemporary ALSA 1.0.x versions.
  All of the ancient ALSA 0.3.x-0.4.x code were removed.
- Floating point output mode support for ALSA, OSS, Direct Sound, WinMM
  drivers and for WAV file writer.
- The pipe and stdout drivers are now configurable
- Raw file-writer now has the lowest priority among the file-writers.
- GCC elf and macho symbol visibility attributes now supported.
- Windows: dllexport/dllimport attributes work properly for MinGW[-w64],
  as well as windows compilers. Static builds using MSVC, LCC, etc are
  now named mikmod_static.lib. When compiling against static libmikmod,
  MIKMOD_STATIC should be defined so that dllimport wouldn't be assumed.

BUGFIXES

- ALSA fixes from Fedora.
- ALSA fixes for "Write error: File descriptor in bad state" crashes,
  e.g. RedHat bug #915121. Now works stable.
- ESD (esound) updates from Fedora. Add esd back to configury which was
  removed in 3.2.0b3, now requiring >= 0.2.18.
- Minor OSS fixes.
- The NAS driver now actually compiles.
- 64 bit detection fixes.
- Fix BOOL type use all over the source.
- Several const correctness fixes.
- Fixes for CVE-2007-6720 and CVE-2009-0179.
- mmio: memreader fixes and updates.
- Fixes for access violations introduced in 3.2.0b3.
- Fixes for broken memory allocation wrappers introduced in 3.2.0b3.
- Fix MikMod_strerror() might read beyond end of a static array.
- Fix looping volume in Player_SetVolume(), based on an old patch by
  Yi-Huang Han.
- XM loader now reads songlength amount of orders from the file and
  then seeks to mh->headersize+60 (sf.net bug #10.)
- Fix "unclick" code to consider loop lengths shorter than 16: fixes
  crashes seen with several xm files (sf.net bug #12, mpd bug #3425.)
- Mac OS X: new standalone makefile with cross-compilation support.
- DJGPP build fixes.
- Windows: fixes/updates, win64 fully supported. MinGW[-w64] fully
  supported along with MSVC and LCC. new standalone MinGW makefile with
  cross-compilation support.
- SIMD (AltiVec and SSE2) option is now disabled by default. Can be
  enabled by --enable-simd configury option, similarly with cmake. (the
  standalone makefiles or project files are added instructions on how to
  enable the feature if required.)
- Many compiler warning fixes, other small cleanups.
18afe2e
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
wiz Update to 1.22:
2011-11-11  Dave Beckett <dave@dajobe.org>

	* Snapshotted flickcurl_1_22 for 1.22 release (GIT
	6698387f4240cec82b0e115adf8a863657dd7066)

	* utils/oauth-test.c:
	Update flickcurl_oauth_prepare_common call

	* NEWS.html, src/common.c, src/flickcurl_internal.h: Disable
	mtwist unless building experimental OAuth

	* src/Makefile.am: Do not use libmtwist without oauth

	* configure.ac, src/Makefile.am, src/common.c,
	src/flickcurl_internal.h, utils/Makefile.am: Add --enable-oauth
	default disabled

	* src/common.c:
	(flickcurl_free): Free OAuth urls

	* src/oauth.c:
	(test_signature_calc): Test free

	* src/oauth.c: Make oauth test work again

	* src/flickcurl_internal.h, src/oauth.c: Remove is_request arg -
	just use od->callback

	* src/common.c, src/flickcurl_internal.h, src/oauth.c,
	utils/oauth-test.c: Move flickcurl_oauth_data into flickcurl
	struct

	* docs/flickcurl-docs.xml, docs/tmpl/section-config.sgml: Add
	config section to docs

	* autogen.sh, docs/tmpl/section-auth.sgml,
	docs/tmpl/section-core.sgml, docs/tmpl/section-misc.sgml,
	docs/tmpl/section-unused.sgml, docs/tmpl/section-upload.sgml,
	libmtwist: Fix submodule checkouts

	* autogen.sh: Init and update any git submodules

2011-11-09  Dave Beckett <dave@dajobe.org>

	* src/flickcurl_internal.h, src/oauth.c:
	Reduce visibility of oauth
	internal functions These are internal to the library now because the
	flickcurl_oauth_data is an internal structure.

2011-11-01  Dave Beckett <dave@dajobe.org>

	* src/common.c: Return method details with curl errors

	* src/Makefile.am: Clean tests

2011-10-30  Dave Beckett <dave@dajobe.org>

	* utils/oauth-test.c: code style

	* utils/oauth-test.c: casts

	* src/oauth.c: docs

	* src/oauth.c: consts

	* docs/flickcurl-sections.txt: add oauth urls

	* src/flickcurl_internal.h, src/oauth.c: fix const char keys

	* src/oauth.c: docs

	* src/oauth.c:
	(flickcurl_oauth_access_token): Delete request token after success.

	* src/oauth.c:
	(flickcurl_oauth_build_key): Build sign key from request OR access
	token

	* utils/oauth-test.c: docs

	* src/Makefile.am, src/oauth.c, utils/oauth-test.c: Add oauth
	checksum test

	* src/.gitignore: ignore *_test

2011-10-29  Dave Beckett <dave@dajobe.org>

	* utils/oauth-test.c: Report request token

	* src/oauth.c:
	(flickcurl_oauth_prepare_common): docs and send all oauth params
	except callback to requests

	* src/flickcurl_internal.h, src/oauth.c, utils/oauth-test.c:
	(flickcurl_oauth_access_token): Pass in verifier

	* src/flickcurl_internal.h, src/oauth.c: request_token* fields
	renamed from tmp_token*

	* docs/flickcurl-sections.txt, src/auth-api.c, src/flickcurl.h:
	Added flickr.auth.oauth.getAccessToken partial support

	(flickcurl_auth_oauth_getAccessToken): Added for
	flickr.auth.oauth.getAccessToken - right now it exchanges the old
	tokens for OAuth ones and drops them both.

	* src/flickcurl_internal.h, utils/oauth-test.c: oauth field
	client_key_len renamed from client_len

	* utils/oauth-test.c: FLICKCURL_MAX_OAUTH_PARAM_COUNT

	* src/oauth.c: is_oauth_method fix

	* src/flickcurl_internal.h, src/oauth.c:
	FLICKCURL_MAX_OAUTH_PARAM_COUNT

	* src/flickcurl.h, src/flickcurl_internal.h, src/oauth.c,
	utils/oauth-test.c: Compute authorize URI after getting back oauth
	request token (flickcurl_oauth_get_authorize_uri): Added.

	* src/common.c, src/flickcurl_internal.h, src/oauth.c: Add utility
	functions for oauth responses as HTTP forms

	(flickcurl_invoke_get_form_content): Added to get content as k/v
	array of strings.

	(flickcurl_free_form): Added to free the above.

	(flickcurl_oauth_request_token), flickcurl_oauth_access_token):
	Use above.

	* src/common.c, src/flickcurl_internal.h, src/oauth.c,
	utils/Makefile.am, utils/oauth-test.c: Move OAuth test code into
	oauth.c and refactor a little

	* src/oauth.c:
	(flickcurl_oauth_prepare_common): Do not use oath method name in
	params

	* libmtwist: Update to libmtwist head

	* utils/oauth-test.c: Pass in (fake) flickr method for
	flickcurl_oauth_prepare_common()

	* src/oauth.c:
	(flickcurl_oauth_prepare_common): Use http method not flickr method

	* utils/oauth-test.c: remove unused srand()

	* src/common.c, src/flickcurl_internal.h, src/oauth.c,
	utils/oauth-test.c: Use libmtwist for PRNG for nonce

	* libmtwist: Update to libmtwist head

	* docs/flickcurl-sections.txt: Add symbols

	* src/Makefile.am:
	Add mtwist_config.h

	* NEWS.html, docs/flickcurl-sections.txt:
	flickcurl_get_hidden_from_string

	* README.html: libmtwist submodule

2011-10-28  Dave Beckett <dave@dajobe.org>

	* .gitmodules, configure.ac, libmtwist, src/Makefile.am,
	src/mtwist_config.h: Add libmtwist as a git submodule

2011-10-16  Dave Beckett <dave@dajobe.org>

	* src/oauth.c:
	(flickcurl_oauth_compute_signature): Simplify greatly.

	* src/config.c, src/flickcurl.h, utils/flickcurl.c:
	(flickcurl_config_write_ini): Now writes to a filename

	* utils/codegen.c, utils/flickcurl.c, utils/flickrdf.c,
	utils/list-methods.c, utils/oauth-test.c: Update the utilities to
	use flickcurl_config_ functions

	* docs/flickcurl-sections.txt, src/common.c, src/config.c,
	src/flickcurl.h: Update flickcurl config file reading and writing
	support Move ini reading and writing into the library.

	(flickcurl_config_read_ini): Added, deprecating read_ini_config()
	and adding a flickcurl* param.  Reads in library configuration.

	(flickcurl_config_var_handler): Added as standard handler for
	above.

	(flickcurl_config_write_ini): Added to write an ini file for
	library configuration.

	* src/oauth.c:
	(flickcurl_oauth_compute_signature): Docs and error path.

	* configure.ac: Fix libcurl version check to actually check curl
	not libxml twice

	* configure.ac: Remove unused libcurl_min_vernum

	* NEWS.html: Tim Harder is 'radhermit' on GitHub.

2011-10-15  Dave Beckett <dave@dajobe.org>

	* NEWS.html: 1.22

	* utils/flickcurl.c: Tidy help output; describe all upload params
	defaults

	* docs/flickcurl-sections.txt: Add flickcurl_get_hidden_label,
	flickcurl_get_hidden_level_from_string

	* src/common.c, src/flickcurl.h, src/upload-api.c,
	utils/flickcurl.c: Add support for upload field 'hidden'

	flickcurl_upload_params gains int param hidden with values 1 for
	global and 2 for hidden.

	(flickcurl_get_hidden_label, flickcurl_get_hidden_from_string):
	Added utility functions to turn the int to a label and vice versa

	* utils/flickcurl.c: Document upload params safety_level and
	content_type

	* docs/Makefile.am, docs/tmpl/section-favorite.sgml: Update tmpls

	* docs/flickcurl-sections.txt:
	Add flickcurl_favorites_getContext

	* src/favorites-api.c, src/flickcurl.h, utils/flickcurl.c:
	Implement API favorites.getContext

	(flickcurl_favorites_getContext): Added returning an array of two
	photo lists for previous and next photos.  flickcurl utility adds
	new command favorites.getContext to call above.

	* src/flickcurl_internal.h, src/photo.c:
	(flickcurl_new_photos_list): Added to construct a photos list

	* configure.ac, src/common.c, utils/flickrdf.c: Support Raptor V2
	only.  Raptor V1 was last supported in January 2010

	* src/panda-api.c: extras docs

2011-09-02  Dave Beckett <dajobe@digg.com>

	* utils/oauth-test.c: access token testing

	* src/flickcurl_internal.h: Add verifier field

2011-08-15  Dave Beckett <dave@dajobe.org>

	* Merge pull request #13 from kumanna/help-without-auth (below)
	Help without authentication

2011-08-14  Kumar Appaiah <a.kumar@alumni.iitm.ac.in>

	* utils/flickcurl.c: Use stdout for non-error user output

	Since users usually expect any non-error output to come to stdout,
	this commit changes all output except error reports to be directed
	to stdout.

	* utils/flickcurl.c: Fix indentation

	* utils/flickcurl.c: Provision for help message even when not
	authenticated.

	Even when not authenticated, the user might desire to see the list
	of API calls available. This commit facilitates the display of
	that message.

	* utils/flickcurl.c: Move printing help details to a function.

	This commit moves printing the help message to a function, viz.
	print_help_string, so that it can be called from multiple places
	without having to duplicate code. In addition, displays an extra
	newline at the end for neater output.

2011-08-14  Dave Beckett <dave@dajobe.org>

	* Merge pull request #12 from kumanna/kumar (below)
	Fix man page and documentation quirks reported at Debian.

	Debian bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=635892

2011-08-14  Kumar Appaiah <a.kumar@alumni.iitm.ac.in>

	* utils/flickcurl.c: Fix grammatical error in description of
	galleries.create

	* docs/flickrdf.1: Fix incorrect spacing in flickrdf man page
	Fixes an incorrect space in the reference to the flickcurl man
	page.

	* docs/flickrdf.1: Remove reference to missing README for flickrdf
	This removes the reference to a missing README file for flickrdf.
	This fixes Debian bug 637196 in flickcurl.

2011-07-28  Dave Beckett <dave@dajobe.org>

	* Merge pull request #10 from radhermit/curl-headers (below)
	Remove old curl header include

2011-06-25  Dave Beckett <dave@dajobe.org>

	* src/flickcurl_internal.h, src/oauth.c, utils/oauth-test.c: Test
	code calls Flickr OAuth endpoint with correctly signed call

2011-06-23  Dave Beckett <dave@dajobe.org>

	* src/flickcurl_internal.h: ws

	* src/flickcurl_internal.h, src/oauth.c, utils/oauth-test.c:
	(flickcurl_oauth_build_key_data): Added internal call with API
	that will change

	* utils/oauth-test.c:
	(oauth_build_key_data): Added

	* utils/oauth-test.c:
	Add a structure oauth_data

	* utils/oauth-test.c:
	Do URI encoding and concatenating

	* src/Makefile.am, src/flickcurl_internal.h, src/oauth.c,
	src/sha1.c, utils/.gitignore, utils/Makefile.am, utils/oauth-test.c:
	OAuth test code

2011-05-08  Dave Beckett <dave@dajobe.org>

	* src/galleries-api.c, src/method.c, src/photosets-api.c,
	src/prefs-api.c, src/test-api.c, src/upload-api.c: code style

	* src/person.c:
	(flickcurl_build_persons): Do not zap any existing data if a field
	is not found.

2011-03-31  Dave Beckett <dave@dajobe.org>

	* NEWS.html: 1.22

2011-03-31  Dave Beckett <dave@dajobe.org>

	* utils/Makefile.am: Add raptor_fake.h to sources and
	distribution.

2011-03-30  Dave Beckett <dave@dajobe.org>

	* NEWS.html, configure.ac:
	Bumped version to 1.22

	* docs/tmpl/section-tag.sgml:
	Added flickcurl_free_tags to doc tmpls

	* docs/flickcurl-sections.txt:
	(flickcurl_free_tags): Added

2011-03-30  Naruto TAKAHASHI <tnaruto@gmail.com>

	* src/flickcurl.h, src/photo.c, src/tags.c: add
	flickcurl_free_tags

	* docs/tmpl/section-photoset.sgml, src/flickcurl.h,
	src/photoset.c: move owner filed to the end of the structure.

2011-03-29  Naruto TAKAHASHI <tnaruto@gmail.com>

	* docs/tmpl/section-photoset.sgml, src/flickcurl.h,
	src/photoset.c: add owner to flickcurl_photoset
efa0b33
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
abs Updated www/p5-libwww to 6.04
_______________________________________________________________________________
2012-02-18  Release 6.04

Gisle Aas (4):
      Typo fix; envirionment [RT#72386]
      Implement $ua->is_online test
      Add separate option to enable the live jigsaw tests
      Merge pull request #10 from trcjr/master

Theodore Robert Campbell Jr (3):
      now with put and delete helpers
      updated POD
      unit tests for ua->put and ua->delete

Peter Rabbitson (1):
      These modules work with 5.8.1




_______________________________________________________________________________
2011-10-15  Release 6.03

Ville Skyttä (7):
      Link updates.
      Attribute documentation wording improvements.
      Don't parse robots.txt response content unless it's textual.
      Decode robots.txt response content before attempting to parse it.
      RobotUA robots.txt response parsing cleanups.
      Don't parse HEAD of robots.txt responses.
      Request handler doc grammar fixes.

Gisle Aas (6):
      Pass on HTTP/1.0 if set as request protocol
      Remove outdated docs (not touched since 1996 :-)
      Merge pull request #22 from madsen/RT67947-verify_hostname
      PERL_LWP_ENV_PROXY tweaks
      lwp-request didn't respect -H Content-type [RT#70488]
      lwp-request -H didn't allow repeated headers

Christopher J. Madsen (2):
      verify_hostname defaults to 0 if ssl_opts provided [RT#67947]
      Test verify_hostname setting

Bryan Cardillo (1):
      Fix expect header support to work with content refs.

Moritz Onken (1):
      add PERL_LWP_ENV_PROXY env variable to enable env_proxy globally
3f36bac
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
taca Update ruby-mime-types to 1.18.
== MIME::Types 1.18 / 2012-03-20
* New MIME Types:
  * Types reported in Issue #6
    (https://github.com/halostatue/mime-types/issues/6):
    * CoffeeScript (text/x-coffeescript; .coffee; 8bit).
    * AIR
      (application/vnd.adobe.air-applicationinstaller-package+zip, .air;
      base64).
    * WOFF (application/font-woff; .woff; base64).
    * TrueType (application/x-font-truetype; .ttf; base64).
    * OpenType (application/x-font-opentype; .otf; base64).
  * WebM (audio/webm, video/webm; .webm). Issue #11
    (https://github.com/halostatue/mime-types/issues/11).
* New extensions:
  * f4v/f4p (video/mp4, used by Adobe); f4a/fb4 (audio/mp4, used by Adobe).
* Bug Fixes:
  * It was pointed out that Licence.txt was incorrectly named. Fixed by
    renaming to Licence.rdoc (from Issue/Pull Request #8,
    https://github.com/halostatue/mime-types/issues/8).
  * It was pointed out that a plan to have the test output generated
    automatically never went through. Issue #10
    (https://github.com/halostatue/mime-types/issues/10)
caef141
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
taca Update ruby-logging to 1.7.2.
== 1.7.2 / 2012-04-03

Bug Fixes
- Fixed segmentation fault on exit [issue #30]
- Fixed syswrite warning when IO contains unflushed data in buffer [issue #31]
- Added "mingw" to the list of Windows host versions

== 1.7.1 / 2012-03-05

Bug Fixes
- Fixed deprecated use of Config::* [issue #29]

== 1.7.0 / 2012-02-18

Enhancements
- Move appender factories [issue #28]
- ActionMail compatible options in the email appender [issue #27]
- Add TLS support to the email appender [issue #25]
- Refactoring appender shutdown [issue #20]
Bug Fixes
- File locking fails on windows using JRuby [issue #22]

== 1.6.2 / 2012-01-05

Bug Fixes
- Fix typo in the Readme [issue #14]
- Fix spelling in a variety of places [issue #15]
- Solaris does not have Syslog#LOG_PERROR defined [issue #17]
- Fix failing tests for Ruby 1.9.3 [issue #18]
- Check for RUBY_ENGINE for Ruby 1.8.7 [issue #19]
- Whitespace and '# EOF' cleanup
- Support for Rubinious

== 1.6.1 / 2011-09-09

Bug Fixes
- Rails compatibility methods [issue #11]
- Blocked rolling file appender [issue #12]

== 1.6.0 / 2011-08-22

Enhancements
- Adding periodic flushing of buffered messages [issue #10]
- Accessor for a logger's appenders [issue #9]
- Better support for capturing log messages in RSpec version 1 & 2

== 1.5.2 / 2011-07-07

Bug Fixes
- Changing working directory breaks rolling file appenders [issue #8]

== 1.5.1 / 2011-06-03

Bug Fixes
- IO streams cannot be buffered when using syswrite
- JRuby does not allow shared locks on write only file descriptors
- Fixing tests for JRuby 1.6.X

== 1.5.0 / 2011-03-22

Minor Enhancements
- removed mutexes in favor of IO#syswrite
- no round tripping through the buffer array when auto_flushing is true
- added a Proxy object that will log all methods called on it
- colorization of log messages
f11b736
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
taca Update ruby-gettext to 2.3.1.
## 2.3.1: 2012-09-13

It's a Bug and package fix release.
Then, it's also encoding support release, only if you use Ruby 1.9.

### Improvements

  * [xgettext] Added backword compatibility method
    (GetText::RGetText.run).
    [Suggested by Fotos Georgiadis]
  * [xgettext] Removed deprecated parse argument support.
  * [erb parer] Assumed the encoding in the magic comment of the
    input file as the encoding of it.
  * [ruby parser] Assumed the encoding in the magic comment of the
    input file as the encoding of it.
  * [xgettext] Added the "--output-encoding" option to set encoding of
    output pot file.
  * [xgettext] Used UTF-8 as the default encoding of output pot file.
  * [xgettext] Supported multiple encoding sources.

### Changes

  * [MoFile] Returned nil instead of "" as msgstr when its msgid isn't
    translated (when this msgstr is "").
  * [PoParser] Converted msgstr from "" to nil when parsing.

### Fixes

  * Added missing .yardopts file. [Reported by Takahiro Kambe]
  * [news] Fixed Eddie Lau name instead of github name.
  * [msginit] Added the "Plural-Forms:" entry to the header even if a
    pot file doesn't have it.
  * [msgmerge] Fixed the bug the new line between a header and
    contents doesn't exist.
  * [msginit] Fixed the bug that msgstr with msgid_plural aren't
    generated in output po file.
  * [xgettext] Supported class based xgettext parser add API.
    [GitHub #10] [Suggested by Michael Grosser]
  * [erb parer] Fixed erb parser bug with unicode msgid in Ruby 1.9
    ERB templates.
    [Github #9] [Patch by Fotos Georgiadis]
  * Added missing documents for GetText::Tools::XGetText.

### Thanks

  * Takahiro Kambe
  * Michael Grosser
  * Fotos Georgiadis
adc51c5
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
pettai 1.1.4
  - Fix X-HKP-Results-Count so that limit=0 returns no results, but include
    the header, to let a client poll for how many results exist, without
    retrieving any. See:
    http://lists.nongnu.org/archive/html/sks-devel/2010-11/msg00015.html
  - Add UPGRADING document to explain upgrading Berkeley DB without
    rebuilding. System bdb versions often change with new SKS releases
    for .deb and .rpm distros.
  - Cleanup build errors for bdb/bdb_stubs.c. Patch from Mike Doty
  - Update cryptokit from version 1.0 to 1.5 without requiring OASIS
    build system or other additional dependencies
  - build, fastbuild, & pbuild fixed to ignore signals USR1 and USR2
  - common.ml and reconSC.ml were using different values for minumimum
    compatible version. This has been fixed.
  - Added new server mime-types, and trying another default document (Issue 6)
    In addition to the new MIME types added in 1.1.[23], the server now
    looks over a list and and serves the first index file that it finds
    Current list: index.html, index.htm, index.xhtml, index.xhtm, index.xml.
  - options=mr now works on get as well as (v)index operations. This is
    described in http://tools.ietf.org/html/draft-shaw-openpgp-hkp-00
    sections 3.2.1.1. and 5.1.
  - Updated copyright notices in source files
  - Added sksclient tool, similar to old pksclient
  - Add no-cache instructions to HTTP response (in order for reverse proxies
    not to cache the output from SKS)
  - Use unique timestamps for keydb to reduce occurrances of Ptree corruption.
  - Added Interface specifications (.mli files) for modules that were missing
    them
  - Yaron pruned some no longer needed source files from the tree.
  - Improved the HTTP status and HTTP error codes returned for various
    situations and added checks for more error conditions.
  - Add a suffix to version (+) indicating non-release or development builds
  - Add an option to specify the contact details of the server administrator
    that shows in the status page of the server. The information is in the
    form of an OpenPGP KeyID and set by server_contact: in sksconf
  - Add a `sks version` command to provide information on the setup.
  - Added configuration settings for the remaining database table files. If
    no pagesize settings are in sksconf, SKS will use 2048 bytes for key
    and 512 for ptree. The remainining files' pagesize will be set by BDB
    based on the filesystem settings, typically this is 4096 bytes.
    See sampleConfig/sksconf.typical for settings recommended by db_tuner.
  - Makefile: Added distclean target. Dropped autogenerated file from VCS.
  - Allow tuning BDB environment before creation in [fast]build and pbuild.
    If DB_CONFIG exists in basedir, copy it to DB dir before DB creation.
    Preference is given to DB_CONFIG.KDB and DB_CONFIG.PTree over DB_CONFIG.
  - Add support for Elliptic Curve Public keys (ECDSA, ECDH)
  - Add check if an upload is a revocation certificate, and if it is,
    produce an error message tailored for this.

1.1.3
  - Makefile fix for 'make dep' if .depend does not exist. Issue #4
  - Makefile fix: sks and sks_add_mail fail to link w/o '-ccopt -pg'
    Issue #23
  - Added -disable_mailsync and -disable_log_diffs to sks.pod
  - Added file extensions .css, .jpeg, .htm, .es, .js, .xml, .shtml, .xhtm,
    .xhtml and associated MIME types to server code. Part of Issue #6
  - Added sample configuration files in sampleConfig directory
  - Added sample web page files in sampleWeb directory. Issues #7, 9, 19
  - Allow requests for non-official options hget, hash, status, & clean to
    be preceded by '-x'. Closes issues #10, 11, 13, & 14.
  - Allow &search with long subkey ID (16 digit) and subkey fingerprint
    subkey lookup was failing with other than a short key ID. However,
    public key lookup was working with short and long key ID and fingerprints.
    This patch makes subkey lookup behave the same as full key lookup.
    http://lists.gnupg.org/pipermail/gnupg-users/2012-January/043495.html
  - Patch recon script so that POST includes HTTP version number.
6e92962
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
wen Update to 0.46
Upstream changes:
0.46 Tue Oct  2 13:23:00 EDT 2012
  - with() enables argument matching on mocked methods
  - raises() makes mocked methods raise exceptions
    Contributed by Kjell-Magne .ierud (issue #12)

0.45 Mon May  7 10:08:13 EDT 2012
  - Add support for TAP version 13.
    Contributed by Michael G. Schwern (issue #11)

0.44 Mon Apr 30 11:04:00 CST 2012
  - Allow shared_examples_for to be defined in any context.

0.43 Sat Apr 14 16:22:00 EST 2012
  - Fixed runtests() to honor its contract to run only the examples specified
    in its @patterns parameter or SPEC environment variable.

0.42 Mon Mar 05 21:18:00 CST 2012
  - Added context() and xcontext() aliases for describe/xdescribe
    (reported by intrigeri)

0.41 Sat Mar 03 19:04:00 EST 2012
  - Added license info to Makefile.PL (RT #75400)
  - Fixed test suite problems on Windows

0.40 Mon Jan 30 18:38:00 EST 2012
  - Fixed problem that caused Test::Spec usage errors (e.g. 'describe "foo";'
    without a subroutine argument) to be reported from inside the library,
    instead of the caller's perspective where the actual error is.

0.39 Wed Aug 31 00:52:00 EST 2011
  - Added xit/xthey/xdescribe to mark TODO tests, inspired by the
    Jasmine JavaScript framework.
    Contributed by Marian Schubert (issue #10).

0.38 Sat Jul 09 23:16:00 EST 2011
  - Added share() function to facilitate spec refactoring.
d62c5a5
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
wen Update to 0.95
Upstream changes:
0.95  Sat Dec  8 15:11:09 2012
    - U::C::Locale newly supports locales: bs_Cyrl, ee.
    - updated to CLDR 21: uk.
    - updated to CLDR 22: th, to.
    - added loc_bscy.t, loc_ee.t in t.
    - modified tests: loc_th.t, loc_to.t, loc_uk.t in t.

0.94  Fri Nov 23 18:45:53 2012
    - U::C::Locale newly supports locale: zh__zhuyin.
    - added Unicode::Collate::CJK::Zhuyin for zh__zhuyin.
    - doc: added CAVEAT to CJK/Stroke.pm
    - modified tests: loc_cjk.t, loc_cjkc.t in t.
    - added cjk_zy.t, loc_zhzy.t in t.

0.93  Sun Nov 18 18:13:42 2012
    - DUCET is updated (for Unicode 6.2.0) as Collate/allkeys.txt.
    ! Please notice that allkeys.txt will be overwritten if you have had
      other allkeys.txt already.
    - The default UCA_Version is 26.
    - Locale/*.pl (except fr.pl) and CJK/Korean.pm are updated.
    - modified tests: loc_es.t, loc_estr.t, version.t in t.

0.92  Wed Nov 14 20:58:19 2012
    - fix: index() etc. with preprocess/normalization should be always croaked.
    - doc: referred to the latest UTS #10 and updated its section numbers.
    - supported the identical level (see 'identical' in POD).
    - Now UCA_Version 26 (for Unicode 6.2.0) is supported.
      * But the default UCA_Version is still 24.
    - added ident.t in t.
    - modified tests: cjkrange.t, compatui.t, hangtype.t, index.t,
      overcjk0.t, overcjk1.t, test.t, view.t in t.

0.91  Sun Nov  4 17:00:20 2012
    - XSUB: use PERL_NO_GET_CONTEXT (see perlguts)
      (see [rt.cpan.org #80313])

0.90  Sun Sep 23 10:42:26 2012
    - perl 5.11.0 or later: Install to 'site' instead of 'perl'
      (see [rt.cpan.org #79800])
e5cbae2
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
obache Update ruby-ole to 1.2.11.5.
== 1.2.11.5 / 2012-11-06

- Fix breakage of IO.parse_mode on Rubinius (issue #10).
- Make tests pass on rubinius (issue #11).
- Improve RangesIO test coverage.
- Don't warn when mbat_start is AVAIL instead of EOC (github #9).
b053608
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
taca Update ruby-diff-lcs to 1.2.1.
== 1.2.1 / 2013-02-09

* Bugs Fixed:
  * As seen in rspec/rspec-expectations#200, the
    release of Diff::LCS 1.2 introduced an unnecessary public API change to
    Diff::LCS::Hunk (see the change at
    rspec/rspec-expectations@3d6fc82 for details).
    The new method name (and behaviour) is more correct, but I should not have
    renamed the function or should have at least provided an alias. This
    release restores Diff::LCS::Hunk#unshift as an alias to
    #merge. Note that the old #unshift behaviour was incorrect and will not be
    restored.

== 1.2.0 / 2013-01-21
* Minor Enhancements:
  * Added special case handling for Diff::LCS.patch so that it handles patches
    that are empty or contain no changes.
  * Added two new methods (#patch\_me and #unpatch\_me) to the includable
    module.
* Bugs Fixed:
  * Fixed issue #1 patch direction detection.
    halostatue/diff-lcs#1
  * Resolved issue #2 by handling string[string.size, 1] properly (it returns
    "" not nil). halostatue/diff-lcs#2
  * Michael Granger (ged) fixed an implementation error in Diff::LCS::Change
    and added specs in pull request #8. Thanks!
    halostatue/diff-lcs#8
  * Made the code auto-testable.
  * Vít Ondruch (voxik) provided the latest version of the GPL2 license file in
    pull request #10. Thanks! halostatue/diff-lcs#10
  * Fixed a documentation issue with the includable versions of #patch! and
    #unpatch! where they implied that they would replace the original value.
    Given that Diff::LCS.patch always returns a copy, the documentation was
    incorrect and has been corrected. To provide the behaviour that was
    originally documented, two new methods were added to provide this
    behaviour. Found by scooter-dangle in issue #12. Thanks!
    halostatue/diff-lcs#12
* Code Style Changes:
  * Removed trailing spaces.
  * Calling class methods using '.' instead of '::'.
  * Vít Ondruch (voxik) removed unnecessary shebangs in pull request #9.
    Thanks! halostatue/diff-lcs#9
  * Kenichi Kamiya (kachick) removed some warnings of an unused variable in
    lucky pull request #13. halostatue/diff-lcs#13
    Thanks!
  * Embarked on a major refactoring to make the files a little more manageable
    and understand the code on a deeper level.
  * Adding to http://travis-ci.org.
235b6e1
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
wiz Update to 0.7.7. Simplify. Set LICENSE. Allow python-3.x.
-----
0.7.7
-----

* Distribute #375: Repair AttributeError created in last release (redo).
* Issue #30: Added test for get_cache_path.

-----
0.7.6
-----

* Distribute #375: Repair AttributeError created in last release.

-----
0.7.5
-----

* Issue #21: Restore Python 2.4 compatibility in ``test_easy_install``.
* Distribute #375: Merged additional warning from Distribute 0.6.46.
* Now honor the environment variable
  ``SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT`` in addition to the now
  deprecated ``DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT``.

-----
0.7.4
-----

* Issue #20: Fix comparison of parsed SVN version on Python 3.

-----
0.7.3
-----

* Issue #1: Disable installation of Windows-specific files on non-Windows systems.
* Use new sysconfig module with Python 2.7 or >=3.2.

-----
0.7.2
-----

* Issue #14: Use markerlib when the `parser` module is not available.
* Issue #10: ``ez_setup.py`` now uses HTTPS to download setuptools from PyPI.

-----
0.7.1
-----

* Fix NameError (Issue #3) again - broken in bad merge.

---
0.7
---

* Merged Setuptools and Distribute. See docs/merge.txt for details.

Added several features that were slated for setuptools 0.6c12:

* Index URL now defaults to HTTPS.
* Added experimental environment marker support. Now clients may designate a
  PEP-426 environment marker for "extra" dependencies. Setuptools uses this
  feature in ``setup.py`` for optional SSL and certificate validation support
  on older platforms. Based on Distutils-SIG discussions, the syntax is
  somewhat tentative. There should probably be a PEP with a firmer spec before
  the feature should be considered suitable for use.
* Added support for SSL certificate validation when installing packages from
  an HTTPS service.

-----
0.7b4
-----

* Issue #3: Fixed NameError in SSL support.
b8cc242
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
wen Update to 0.18
Upstream changes:
0.18  2013-08-17
  - fix tests for pre-Test-More-0.88 (Paul Howarth, #10)

0.17  2013-08-16
  - work around [rt.perl #119311] which was causing incorrect error messages in
    some cases during global destruction (Graham Knop, #9)

0.16  2013-07-10
  - remove accidental Sub::Name test dep

0.15  2013-07-08
  - optionally use Sub::Name to name the try/catch/finally blocks, if available
    (Mark Fowler)

0.14  2013-07-05
  - also throw an exception for catch/finally in scalar context (RT#81070)

0.13  2013-07-04
  - fix tests failing on 5.6.x due to differing DESTROY semantics
  - excise superfluous local($@) call - 7% speedup
  - fix (fsvo) broken URLs (RT#55659)
  - proper exception on erroneous usage of bare catch/finally (RT#81070)
  - proper exception on erroneous use of multiple catch{} blocks
  - clarify exception occuring on unterminated try block (RT#75712)
  - fix the prototypes shown in docs to match code (RT#79590; thanks, Pushtaev
    Vadim)
  - warn loudly on exceptions in finally() blocks
  - dzilify
8ba97bd
@jperkin jperkin pushed a commit that referenced this issue Dec 9, 2013
wiz Update to 3.3.2:
Summary of changes between libmikmod 3.2.0 and libmikmod 3.3.2 ():
==========================================================================

libmikmod 3.3.2 was released on 05-Oct-2013.

This is a serious bug fix release after the previous 3.2.0 series, with
some additional new features. All who are using libmikmod-3.2.0 (or the
interim 3.3.1-beta) must upgrade to the new libmikmod-3.3.2 version.

THANKS

- Paul Spark <sparkynz74@gmail.com> for Microsoft Visual C 6.0 fixes.
- Ozkan Sezer: many changes.

NEW FEATURES

- New CMake build system.
- Updated configury, support for cross-compilation, support for building
  in a separate directory, support latest autotools.
- New SDL driver - works both with SDL-1.2.x and with SDL2, supports
  floating point output if compiled against SDL2.
- New OpenAL driver, originally suggested by 'kervala', with fixes and
  updates and with floating point output support.
- The multi-platform SDL and OpenAL drivers, if they are compiled, have
  priority over OS-specific hw drivers for MikMod_RegisterAllDrivers().
- New windows xaudio2 driver, originally suggested by 'honza.c', with
  updates, xaudio2.8 support and with floating point output support.
- ALSA driver now supports only the contemporary ALSA 1.0.x versions.
  All of the ancient ALSA 0.3.x-0.4.x code were removed.
- Floating point output mode support for ALSA, OSS, Direct Sound, WinMM
  drivers and for WAV file writer.
- The pipe and stdout drivers are now configurable
- Raw file-writer now has the lowest priority among the file-writers.
- GCC elf and macho symbol visibility attributes now supported.
- Windows: dllexport/dllimport attributes work properly for MinGW[-w64],
  as well as windows compilers. Static builds using MSVC, LCC, etc are
  now named mikmod_static.lib. When compiling against static libmikmod,
  MIKMOD_STATIC should be defined so that dllimport wouldn't be assumed.

BUGFIXES

- ALSA fixes from Fedora.
- ALSA fixes for "Write error: File descriptor in bad state" crashes,
  e.g. RedHat bug #915121. Now works stable.
- ESD (esound) updates from Fedora. Add esd back to configury which was
  removed in 3.2.0b3, now requiring >= 0.2.18.
- Minor OSS fixes.
- The NAS driver now actually compiles.
- 64 bit detection fixes.
- Fix BOOL type use all over the source.
- Several const correctness fixes.
- Fixes for CVE-2007-6720 and CVE-2009-0179.
- mmio: memreader fixes and updates.
- Fixes for access violations introduced in 3.2.0b3.
- Fixes for broken memory allocation wrappers introduced in 3.2.0b3.
- Fix MikMod_strerror() might read beyond end of a static array.
- Fix looping volume in Player_SetVolume(), based on an old patch by
  Yi-Huang Han.
- XM loader now reads songlength amount of orders from the file and
  then seeks to mh->headersize+60 (sf.net bug #10.)
- Fix "unclick" code to consider loop lengths shorter than 16: fixes
  crashes seen with several xm files (sf.net bug #12, mpd bug #3425.)
- Mac OS X: new standalone makefile with cross-compilation support.
- DJGPP build fixes.
- Windows: fixes/updates, win64 fully supported. MinGW[-w64] fully
  supported along with MSVC and LCC. new standalone MinGW makefile with
  cross-compilation support.
- SIMD (AltiVec and SSE2) option is now disabled by default. Can be
  enabled by --enable-simd configury option, similarly with cmake. (the
  standalone makefiles or project files are added instructions on how to
  enable the feature if required.)
- Many compiler warning fixes, other small cleanups.
0d572c7
@jperkin jperkin pushed a commit that referenced this issue Jan 21, 2014
wiz Update to 0.7.7. Simplify. Set LICENSE. Allow python-3.x.
-----
0.7.7
-----

* Distribute #375: Repair AttributeError created in last release (redo).
* Issue #30: Added test for get_cache_path.

-----
0.7.6
-----

* Distribute #375: Repair AttributeError created in last release.

-----
0.7.5
-----

* Issue #21: Restore Python 2.4 compatibility in ``test_easy_install``.
* Distribute #375: Merged additional warning from Distribute 0.6.46.
* Now honor the environment variable
  ``SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT`` in addition to the now
  deprecated ``DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT``.

-----
0.7.4
-----

* Issue #20: Fix comparison of parsed SVN version on Python 3.

-----
0.7.3
-----

* Issue #1: Disable installation of Windows-specific files on non-Windows systems.
* Use new sysconfig module with Python 2.7 or >=3.2.

-----
0.7.2
-----

* Issue #14: Use markerlib when the `parser` module is not available.
* Issue #10: ``ez_setup.py`` now uses HTTPS to download setuptools from PyPI.

-----
0.7.1
-----

* Fix NameError (Issue #3) again - broken in bad merge.

---
0.7
---

* Merged Setuptools and Distribute. See docs/merge.txt for details.

Added several features that were slated for setuptools 0.6c12:

* Index URL now defaults to HTTPS.
* Added experimental environment marker support. Now clients may designate a
  PEP-426 environment marker for "extra" dependencies. Setuptools uses this
  feature in ``setup.py`` for optional SSL and certificate validation support
  on older platforms. Based on Distutils-SIG discussions, the syntax is
  somewhat tentative. There should probably be a PEP with a firmer spec before
  the feature should be considered suitable for use.
* Added support for SSL certificate validation when installing packages from
  an HTTPS service.

-----
0.7b4
-----

* Issue #3: Fixed NameError in SSL support.
932a926
@jperkin jperkin pushed a commit that referenced this issue Jan 21, 2014
wen Update to 0.18
Upstream changes:
0.18  2013-08-17
  - fix tests for pre-Test-More-0.88 (Paul Howarth, #10)

0.17  2013-08-16
  - work around [rt.perl #119311] which was causing incorrect error messages in
    some cases during global destruction (Graham Knop, #9)

0.16  2013-07-10
  - remove accidental Sub::Name test dep

0.15  2013-07-08
  - optionally use Sub::Name to name the try/catch/finally blocks, if available
    (Mark Fowler)

0.14  2013-07-05
  - also throw an exception for catch/finally in scalar context (RT#81070)

0.13  2013-07-04
  - fix tests failing on 5.6.x due to differing DESTROY semantics
  - excise superfluous local($@) call - 7% speedup
  - fix (fsvo) broken URLs (RT#55659)
  - proper exception on erroneous usage of bare catch/finally (RT#81070)
  - proper exception on erroneous use of multiple catch{} blocks
  - clarify exception occuring on unterminated try block (RT#75712)
  - fix the prototypes shown in docs to match code (RT#79590; thanks, Pushtaev
    Vadim)
  - warn loudly on exceptions in finally() blocks
  - dzilify
d62caaf
@jperkin jperkin pushed a commit that referenced this issue Jan 21, 2014
wiz Update to 3.3.2:
Summary of changes between libmikmod 3.2.0 and libmikmod 3.3.2 ():
==========================================================================

libmikmod 3.3.2 was released on 05-Oct-2013.

This is a serious bug fix release after the previous 3.2.0 series, with
some additional new features. All who are using libmikmod-3.2.0 (or the
interim 3.3.1-beta) must upgrade to the new libmikmod-3.3.2 version.

THANKS

- Paul Spark <sparkynz74@gmail.com> for Microsoft Visual C 6.0 fixes.
- Ozkan Sezer: many changes.

NEW FEATURES

- New CMake build system.
- Updated configury, support for cross-compilation, support for building
  in a separate directory, support latest autotools.
- New SDL driver - works both with SDL-1.2.x and with SDL2, supports
  floating point output if compiled against SDL2.
- New OpenAL driver, originally suggested by 'kervala', with fixes and
  updates and with floating point output support.
- The multi-platform SDL and OpenAL drivers, if they are compiled, have
  priority over OS-specific hw drivers for MikMod_RegisterAllDrivers().
- New windows xaudio2 driver, originally suggested by 'honza.c', with
  updates, xaudio2.8 support and with floating point output support.
- ALSA driver now supports only the contemporary ALSA 1.0.x versions.
  All of the ancient ALSA 0.3.x-0.4.x code were removed.
- Floating point output mode support for ALSA, OSS, Direct Sound, WinMM
  drivers and for WAV file writer.
- The pipe and stdout drivers are now configurable
- Raw file-writer now has the lowest priority among the file-writers.
- GCC elf and macho symbol visibility attributes now supported.
- Windows: dllexport/dllimport attributes work properly for MinGW[-w64],
  as well as windows compilers. Static builds using MSVC, LCC, etc are
  now named mikmod_static.lib. When compiling against static libmikmod,
  MIKMOD_STATIC should be defined so that dllimport wouldn't be assumed.

BUGFIXES

- ALSA fixes from Fedora.
- ALSA fixes for "Write error: File descriptor in bad state" crashes,
  e.g. RedHat bug #915121. Now works stable.
- ESD (esound) updates from Fedora. Add esd back to configury which was
  removed in 3.2.0b3, now requiring >= 0.2.18.
- Minor OSS fixes.
- The NAS driver now actually compiles.
- 64 bit detection fixes.
- Fix BOOL type use all over the source.
- Several const correctness fixes.
- Fixes for CVE-2007-6720 and CVE-2009-0179.
- mmio: memreader fixes and updates.
- Fixes for access violations introduced in 3.2.0b3.
- Fixes for broken memory allocation wrappers introduced in 3.2.0b3.
- Fix MikMod_strerror() might read beyond end of a static array.
- Fix looping volume in Player_SetVolume(), based on an old patch by
  Yi-Huang Han.
- XM loader now reads songlength amount of orders from the file and
  then seeks to mh->headersize+60 (sf.net bug #10.)
- Fix "unclick" code to consider loop lengths shorter than 16: fixes
  crashes seen with several xm files (sf.net bug #12, mpd bug #3425.)
- Mac OS X: new standalone makefile with cross-compilation support.
- DJGPP build fixes.
- Windows: fixes/updates, win64 fully supported. MinGW[-w64] fully
  supported along with MSVC and LCC. new standalone MinGW makefile with
  cross-compilation support.
- SIMD (AltiVec and SSE2) option is now disabled by default. Can be
  enabled by --enable-simd configury option, similarly with cmake. (the
  standalone makefiles or project files are added instructions on how to
  enable the feature if required.)
- Many compiler warning fixes, other small cleanups.
3147d1e
@jperkin jperkin pushed a commit that referenced this issue Jan 21, 2014
wiz Update to 2.3.0:
Release 2.3.0
=============

New Features
------------

:mod:`rpy2.rinterface`:

- C-level API, allowing other C-level modules to make use of utilities
  without going through the Python level. The exact definition of
  the API is not yet fixed. For now there is
  PyRinteractive_IsInitialized() to assess whether R was initialized
  (through :mod:`rpy2.rinterface` or not).

- C-module _rpy_device, allowing one to implement R graphical devices
  in Python [(very) experimental]

- Tracking of R objects kept protected from garbage collection by rpy2
  is now possible.

- New method :meth:`Sexp.rid` to return the identifier of the R object
  represented by a Python/rpy2 object

:mod:`rpy2.rinteractive`:

- Dynamic build of Python docstrings out of the R manual pages

:mod:`rpy2.robjects.help`:

- Build dynamic help

:mod:`rpy2.robjects.packages:

- Build anonymous R packages from strings

- When using :func:`importr`, the datasets are added as an attribute
  :attr:`data`, itself an instance of a new class :class:`PackageData`.
  It no longer possible to access datasets are regular objects from
  a code package (because of changes in R), and the new system is
  more robust against quirks.

Changes
-------

:mod:`rpy2.rinterface`:

- :attr:`SexpClosure.env` to replace the method `closureenv`.


Release 2.2.6
=============

Bugs fixed
----------

- Newest R-2.15 and ggplot2 0.9 broke the ggplot2 interaface
  in :mod:`rpy2.robjects.lib.ggplot2`


Release 2.2.5
=============

Bugs fixed
----------

- install process: Library location for some of the R installations

- should compile on win32 (thanks to a patch from Evgeny Cherkashin),
   a work to a limited extend


Release 2.2.4
=============

Bugs fixed
----------

- Memory leak when creating R vectors from Python (issue #82)

Release 2.2.3
=============

Bugs fixed
----------

- Dynamic construction of S4 classes was looking for R help as 'class.<class>'
  rather than '<class>-class'

- The cleanup of temporary directories created by R was not happening if
  the Python process terminated without calline :func:`rpy2.rinterface.endr()`
  (issue #68, and proof-of-principle fix by chrish42)


Release 2.2.2
=============

Bugs fixed
----------

- With the robjects layer, repr() on a list containing non-vector elements
  was failing

Release 2.2.1
=============

Bugs fixed
----------

- MANIFEST.in was missing from MANIFEST.in, required with Python 3


Release 2.2.0
=============

New Features
------------

- Support for Python 3, and for some of its features ported to Python 2.7

:mod:`rpy2.robjects`:

- :meth:`Environment.keys` to list the keys

- classes :class:`robjects.vectors.POSIXlt` and
  :class:`robjects.vectors.POSIXlt` to represent vectors of R
  dates/time

- :func:`packages.get_packagepath` to get the path to an R package

- module :mod:`rpy2.robjects.help` to expose the R help system to Python

- Metaclass utilities in :mod:`rpy2.robjects.methods`, allowing to reflect
  automatically R S4 classes as Python classes.

- :meth:`rpy2.robjects.vectors.FactorVector.iter_labels` to iterate over the labels

- :class:`rpy2.robjects.vectors.ListVector` to represent R lists.

- Constructor for :class:`rpy2.robjects.vectors.ListVector` and
  :class:`rpy2.robjects.vectors.DataFrame` accept any iterable at the condition
  that the elements iterated through also valid subscripts for it (e.g., given
  an iterable v, the following is valid:

  .. code-block:: python

     x[k] for x in v


:mod:`rpy2.rinterface`:

- :data:`NA_Complex` and :class:`NAComplexType` for missing complex values.

- :class:`SexpExtPtr` to represent R objects of type EXTPTR (external pointers).

- :func:`rpy2.rinterface.parse` to parse a string a R code

- :func:`rpy2.rinterface.rternalise` to wrap Python function as :class:`SexpClosure` that can
  be called by R just as it was a function of its own.

- :class:`rpy2.rinterface.RNULLType` for R's C-level NULL value and
  :class:`rpy2.rinterface.UnboundValueType` for R's C-level R_UnboundValue
  (both singletons).

- :meth:`rinterface.SexpVector.index`, of similar behaviour to :meth:`list.index`.

- :meth:`rpy2.rinterface.Sexp.list_attrs` to list the names of all R attributes
  for a given object.

- :class:`rpy2.rinterface.ByteSexpVector` to represent R 'raw' vectors.

- constant `R_LEN_T_MAX` to store what is the maximum length for a vector in R.

- tuple `R_VERSION_BUILD` to store the version of R rpy2 was built against

- getter :attr:`Sexp.rclass` to return the R class associated with an object

:mod:`rpy2.rlike`:

- :class:`container.OrdDict` get proper methods :meth:`keys` and `get`

:mod:`rpy2.interactive`:

- A new sub-package to provide utilities for interactive work, either for
  handling R interactive events or use Python for interactive programming
  (as often done with the R console)

Changes
-------

:mod:`rpy2.robjects`:

- NA_bool, NA_real, NA_integer, NA_character and NA_complex are now
  deprecated (and removed).
  NA_Logical, NA_Real, NA_Integer, NA_Character, NA_Complex should be used.

- :class:`rpy2.robjects.packages.Package` now inherits from :class:`types.ModuleType`

- classes representing R vector also inherit their type-specific
  rinterface-level counterpart.

- Importing the :class:`rpy2.robjects.numpy2ri` is no longer sufficient
  to active the conversion. Explicit activation is now needed; the function
  `activate` can do that.


:mod:`rpy2.rinterface`:

- :class:`IntSexpVector`, :class:`FloatSexpVector`,
  :class:`StrSexpVector`, :class:`BoolSexpVector`, :class:`ComplexSexpVector`
  are now defined at the C level, improving performances
  and memory footprint whenever a lot of instances are created.

Bugs fixed
----------

- Better and more explicit detection system for needed libraries when
  compiling rpy2 (ported to release 2.1.6)

- Long-standing issue with readline fixed (issue #10)


Release 2.1.9
=============

Bugs fixed
----------

- The R class in rpy2.robjects is now truly a singleton

- When using numpy 1.5 and Python >= 2.7, the exposed buffer for R numerical (double)
  vectors or arrays was wrong.


Release 2.1.8
=============

Bugs fixed
----------

- Fixed issue with R arrays with more than 2 dimensions and numpy arrays
  (issue #47 - backported from the branch 2.2.x).


Release 2.1.7
=============

Bugs fixed
----------

- More fixes for the automated detection of include and libraries at build time.


Release 2.1.6
=============

Bugs fixed
----------

- Further fixes in the automatic detection of includes and libraries
  needed to compile rpy2 against R. The detection code has
  been refactored (backport from the 2.2.x branch)


Release 2.1.5
=============

Bugs fixed
----------

- fixes the automatic detection of R_HOME/lib during building/compiling
  when R_HOME/lib is not in lib/ (issue #54)


Release 2.1.4
=============

New features
------------

- :mod:`rpy2.robjects.lib.ggplot2` now has the functions :func:`limits`,
  :func:`xlim`, :func:`ylim` exposed (patch contributed anonymously)

Bugs fixed
----------

- Install script when the BLAS library used by R is specified as a library
  file (patch by Michael Kuhn)
e8b0cf0
@jperkin jperkin pushed a commit that referenced this issue Feb 10, 2014
obache Update cutter to 1.2.3.
== [release-1-2-3] 1.2.3: 2014-02-09

As long time has passed since Cutter 1.2.2 release,
there are some improvements and fixed bugs.

After Cutter 1.2.2 release, you can install Cutter from
Fedora's official yum repository. No need to register Cutter yum repository on Fedora anymore.

=== Cutter

==== Improvements

  * [doc] Removed a needless period from installation link.
    [GitHub #6] [Patch by Masafumi Yokoyama]
  * Supported lcov 1.10. [cutter-users-ja:92] [Reported by Siganai SE]
  * [doc] Updated download URL on SF.net. [cutter-users-ja:91] [Reported by Siganai SE]
  * [doc] Updated XML report format. [cutter-users-ja:91] [Reported by Siganai SE]
  * Added more trace logs for loader. It helps you to investigate the case when no tests are loaded.
  * [doc] Updated Cygwin's setup.exe URL.
  * Added --log-level option. The value of default log level is "critical|error|warning|message".

==== Fixes

  * [loader] Fixed a bug that ELF loader can't collect symbol because of wrong comparison.
  * Fixed memory leaks on loading all modules.
  * Fixed a warning from GCC 4.8.1 on Ubuntu 13.10
    [GitHub #9] [Reported by Kazuhiro Yamato]

=== CppCutter

==== Improvements

  * Supported cppcut_assert_equal(const type_info &, const type_info &)
    [GitHub #4] [Patch by Kazuhiro Yamato]
  * Supported to catch unhandled C++ exception in test case.
    This change avoids to crash when unexpected exception is thrown.
    [GitHub #8] [Suggested by Kazuhiro Yamato] [Patch by Kazuhiro Yamato]
  * Supported to call destructors of objects on a stack even when an assertion is failed.
    [GitHub #10] [Patch by Kazuhiro Yamato]

==== Fixes

  * [Clang] Fixed a compile error which is caused by missing std::type_info forward declaration.
  * Fixed an invalid memory access when an exception is thrown in cutter's
    assertion function.
    [GitHub #11] [Patch by Kazuhiro Yamato]

=== GCutter

==== Fixes

  * [doc] Fixed a signal name typo about gcut-egg example.

=== Thanks

  * Kazuhiro Yamato
  * Masafumi Yokoyama
  * Siganai SE
185f6f5
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
wen Update to 0.95
Upstream changes:
0.95  Sat Dec  8 15:11:09 2012
    - U::C::Locale newly supports locales: bs_Cyrl, ee.
    - updated to CLDR 21: uk.
    - updated to CLDR 22: th, to.
    - added loc_bscy.t, loc_ee.t in t.
    - modified tests: loc_th.t, loc_to.t, loc_uk.t in t.

0.94  Fri Nov 23 18:45:53 2012
    - U::C::Locale newly supports locale: zh__zhuyin.
    - added Unicode::Collate::CJK::Zhuyin for zh__zhuyin.
    - doc: added CAVEAT to CJK/Stroke.pm
    - modified tests: loc_cjk.t, loc_cjkc.t in t.
    - added cjk_zy.t, loc_zhzy.t in t.

0.93  Sun Nov 18 18:13:42 2012
    - DUCET is updated (for Unicode 6.2.0) as Collate/allkeys.txt.
    ! Please notice that allkeys.txt will be overwritten if you have had
      other allkeys.txt already.
    - The default UCA_Version is 26.
    - Locale/*.pl (except fr.pl) and CJK/Korean.pm are updated.
    - modified tests: loc_es.t, loc_estr.t, version.t in t.

0.92  Wed Nov 14 20:58:19 2012
    - fix: index() etc. with preprocess/normalization should be always croaked.
    - doc: referred to the latest UTS #10 and updated its section numbers.
    - supported the identical level (see 'identical' in POD).
    - Now UCA_Version 26 (for Unicode 6.2.0) is supported.
      * But the default UCA_Version is still 24.
    - added ident.t in t.
    - modified tests: cjkrange.t, compatui.t, hangtype.t, index.t,
      overcjk0.t, overcjk1.t, test.t, view.t in t.

0.91  Sun Nov  4 17:00:20 2012
    - XSUB: use PERL_NO_GET_CONTEXT (see perlguts)
      (see [rt.cpan.org #80313])

0.90  Sun Sep 23 10:42:26 2012
    - perl 5.11.0 or later: Install to 'site' instead of 'perl'
      (see [rt.cpan.org #79800])
ff2d184
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
obache Update ruby-ole to 1.2.11.5.
== 1.2.11.5 / 2012-11-06

- Fix breakage of IO.parse_mode on Rubinius (issue #10).
- Make tests pass on rubinius (issue #11).
- Improve RangesIO test coverage.
- Don't warn when mbat_start is AVAIL instead of EOC (github #9).
05c0bc6
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
taca Update ruby-diff-lcs to 1.2.1.
== 1.2.1 / 2013-02-09

* Bugs Fixed:
  * As seen in rspec/rspec-expectations#200, the
    release of Diff::LCS 1.2 introduced an unnecessary public API change to
    Diff::LCS::Hunk (see the change at
    rspec/rspec-expectations@3d6fc82 for details).
    The new method name (and behaviour) is more correct, but I should not have
    renamed the function or should have at least provided an alias. This
    release restores Diff::LCS::Hunk#unshift as an alias to
    #merge. Note that the old #unshift behaviour was incorrect and will not be
    restored.

== 1.2.0 / 2013-01-21
* Minor Enhancements:
  * Added special case handling for Diff::LCS.patch so that it handles patches
    that are empty or contain no changes.
  * Added two new methods (#patch\_me and #unpatch\_me) to the includable
    module.
* Bugs Fixed:
  * Fixed issue #1 patch direction detection.
    halostatue/diff-lcs#1
  * Resolved issue #2 by handling string[string.size, 1] properly (it returns
    "" not nil). halostatue/diff-lcs#2
  * Michael Granger (ged) fixed an implementation error in Diff::LCS::Change
    and added specs in pull request #8. Thanks!
    halostatue/diff-lcs#8
  * Made the code auto-testable.
  * Vít Ondruch (voxik) provided the latest version of the GPL2 license file in
    pull request #10. Thanks! halostatue/diff-lcs#10
  * Fixed a documentation issue with the includable versions of #patch! and
    #unpatch! where they implied that they would replace the original value.
    Given that Diff::LCS.patch always returns a copy, the documentation was
    incorrect and has been corrected. To provide the behaviour that was
    originally documented, two new methods were added to provide this
    behaviour. Found by scooter-dangle in issue #12. Thanks!
    halostatue/diff-lcs#12
* Code Style Changes:
  * Removed trailing spaces.
  * Calling class methods using '.' instead of '::'.
  * Vít Ondruch (voxik) removed unnecessary shebangs in pull request #9.
    Thanks! halostatue/diff-lcs#9
  * Kenichi Kamiya (kachick) removed some warnings of an unused variable in
    lucky pull request #13. halostatue/diff-lcs#13
    Thanks!
  * Embarked on a major refactoring to make the files a little more manageable
    and understand the code on a deeper level.
  * Adding to http://travis-ci.org.
d5c805b
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
wiz Update to 0.7.7. Simplify. Set LICENSE. Allow python-3.x.
-----
0.7.7
-----

* Distribute #375: Repair AttributeError created in last release (redo).
* Issue #30: Added test for get_cache_path.

-----
0.7.6
-----

* Distribute #375: Repair AttributeError created in last release.

-----
0.7.5
-----

* Issue #21: Restore Python 2.4 compatibility in ``test_easy_install``.
* Distribute #375: Merged additional warning from Distribute 0.6.46.
* Now honor the environment variable
  ``SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT`` in addition to the now
  deprecated ``DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT``.

-----
0.7.4
-----

* Issue #20: Fix comparison of parsed SVN version on Python 3.

-----
0.7.3
-----

* Issue #1: Disable installation of Windows-specific files on non-Windows systems.
* Use new sysconfig module with Python 2.7 or >=3.2.

-----
0.7.2
-----

* Issue #14: Use markerlib when the `parser` module is not available.
* Issue #10: ``ez_setup.py`` now uses HTTPS to download setuptools from PyPI.

-----
0.7.1
-----

* Fix NameError (Issue #3) again - broken in bad merge.

---
0.7
---

* Merged Setuptools and Distribute. See docs/merge.txt for details.

Added several features that were slated for setuptools 0.6c12:

* Index URL now defaults to HTTPS.
* Added experimental environment marker support. Now clients may designate a
  PEP-426 environment marker for "extra" dependencies. Setuptools uses this
  feature in ``setup.py`` for optional SSL and certificate validation support
  on older platforms. Based on Distutils-SIG discussions, the syntax is
  somewhat tentative. There should probably be a PEP with a firmer spec before
  the feature should be considered suitable for use.
* Added support for SSL certificate validation when installing packages from
  an HTTPS service.

-----
0.7b4
-----

* Issue #3: Fixed NameError in SSL support.
1a41616
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
wen Update to 0.18
Upstream changes:
0.18  2013-08-17
  - fix tests for pre-Test-More-0.88 (Paul Howarth, #10)

0.17  2013-08-16
  - work around [rt.perl #119311] which was causing incorrect error messages in
    some cases during global destruction (Graham Knop, #9)

0.16  2013-07-10
  - remove accidental Sub::Name test dep

0.15  2013-07-08
  - optionally use Sub::Name to name the try/catch/finally blocks, if available
    (Mark Fowler)

0.14  2013-07-05
  - also throw an exception for catch/finally in scalar context (RT#81070)

0.13  2013-07-04
  - fix tests failing on 5.6.x due to differing DESTROY semantics
  - excise superfluous local($@) call - 7% speedup
  - fix (fsvo) broken URLs (RT#55659)
  - proper exception on erroneous usage of bare catch/finally (RT#81070)
  - proper exception on erroneous use of multiple catch{} blocks
  - clarify exception occuring on unterminated try block (RT#75712)
  - fix the prototypes shown in docs to match code (RT#79590; thanks, Pushtaev
    Vadim)
  - warn loudly on exceptions in finally() blocks
  - dzilify
179629b
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
wiz Update to 3.3.2:
Summary of changes between libmikmod 3.2.0 and libmikmod 3.3.2 ():
==========================================================================

libmikmod 3.3.2 was released on 05-Oct-2013.

This is a serious bug fix release after the previous 3.2.0 series, with
some additional new features. All who are using libmikmod-3.2.0 (or the
interim 3.3.1-beta) must upgrade to the new libmikmod-3.3.2 version.

THANKS

- Paul Spark <sparkynz74@gmail.com> for Microsoft Visual C 6.0 fixes.
- Ozkan Sezer: many changes.

NEW FEATURES

- New CMake build system.
- Updated configury, support for cross-compilation, support for building
  in a separate directory, support latest autotools.
- New SDL driver - works both with SDL-1.2.x and with SDL2, supports
  floating point output if compiled against SDL2.
- New OpenAL driver, originally suggested by 'kervala', with fixes and
  updates and with floating point output support.
- The multi-platform SDL and OpenAL drivers, if they are compiled, have
  priority over OS-specific hw drivers for MikMod_RegisterAllDrivers().
- New windows xaudio2 driver, originally suggested by 'honza.c', with
  updates, xaudio2.8 support and with floating point output support.
- ALSA driver now supports only the contemporary ALSA 1.0.x versions.
  All of the ancient ALSA 0.3.x-0.4.x code were removed.
- Floating point output mode support for ALSA, OSS, Direct Sound, WinMM
  drivers and for WAV file writer.
- The pipe and stdout drivers are now configurable
- Raw file-writer now has the lowest priority among the file-writers.
- GCC elf and macho symbol visibility attributes now supported.
- Windows: dllexport/dllimport attributes work properly for MinGW[-w64],
  as well as windows compilers. Static builds using MSVC, LCC, etc are
  now named mikmod_static.lib. When compiling against static libmikmod,
  MIKMOD_STATIC should be defined so that dllimport wouldn't be assumed.

BUGFIXES

- ALSA fixes from Fedora.
- ALSA fixes for "Write error: File descriptor in bad state" crashes,
  e.g. RedHat bug #915121. Now works stable.
- ESD (esound) updates from Fedora. Add esd back to configury which was
  removed in 3.2.0b3, now requiring >= 0.2.18.
- Minor OSS fixes.
- The NAS driver now actually compiles.
- 64 bit detection fixes.
- Fix BOOL type use all over the source.
- Several const correctness fixes.
- Fixes for CVE-2007-6720 and CVE-2009-0179.
- mmio: memreader fixes and updates.
- Fixes for access violations introduced in 3.2.0b3.
- Fixes for broken memory allocation wrappers introduced in 3.2.0b3.
- Fix MikMod_strerror() might read beyond end of a static array.
- Fix looping volume in Player_SetVolume(), based on an old patch by
  Yi-Huang Han.
- XM loader now reads songlength amount of orders from the file and
  then seeks to mh->headersize+60 (sf.net bug #10.)
- Fix "unclick" code to consider loop lengths shorter than 16: fixes
  crashes seen with several xm files (sf.net bug #12, mpd bug #3425.)
- Mac OS X: new standalone makefile with cross-compilation support.
- DJGPP build fixes.
- Windows: fixes/updates, win64 fully supported. MinGW[-w64] fully
  supported along with MSVC and LCC. new standalone MinGW makefile with
  cross-compilation support.
- SIMD (AltiVec and SSE2) option is now disabled by default. Can be
  enabled by --enable-simd configury option, similarly with cmake. (the
  standalone makefiles or project files are added instructions on how to
  enable the feature if required.)
- Many compiler warning fixes, other small cleanups.
b3485ea
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
wiz Update to 2.3.0:
Release 2.3.0
=============

New Features
------------

:mod:`rpy2.rinterface`:

- C-level API, allowing other C-level modules to make use of utilities
  without going through the Python level. The exact definition of
  the API is not yet fixed. For now there is
  PyRinteractive_IsInitialized() to assess whether R was initialized
  (through :mod:`rpy2.rinterface` or not).

- C-module _rpy_device, allowing one to implement R graphical devices
  in Python [(very) experimental]

- Tracking of R objects kept protected from garbage collection by rpy2
  is now possible.

- New method :meth:`Sexp.rid` to return the identifier of the R object
  represented by a Python/rpy2 object

:mod:`rpy2.rinteractive`:

- Dynamic build of Python docstrings out of the R manual pages

:mod:`rpy2.robjects.help`:

- Build dynamic help

:mod:`rpy2.robjects.packages:

- Build anonymous R packages from strings

- When using :func:`importr`, the datasets are added as an attribute
  :attr:`data`, itself an instance of a new class :class:`PackageData`.
  It no longer possible to access datasets are regular objects from
  a code package (because of changes in R), and the new system is
  more robust against quirks.

Changes
-------

:mod:`rpy2.rinterface`:

- :attr:`SexpClosure.env` to replace the method `closureenv`.


Release 2.2.6
=============

Bugs fixed
----------

- Newest R-2.15 and ggplot2 0.9 broke the ggplot2 interaface
  in :mod:`rpy2.robjects.lib.ggplot2`


Release 2.2.5
=============

Bugs fixed
----------

- install process: Library location for some of the R installations

- should compile on win32 (thanks to a patch from Evgeny Cherkashin),
   a work to a limited extend


Release 2.2.4
=============

Bugs fixed
----------

- Memory leak when creating R vectors from Python (issue #82)

Release 2.2.3
=============

Bugs fixed
----------

- Dynamic construction of S4 classes was looking for R help as 'class.<class>'
  rather than '<class>-class'

- The cleanup of temporary directories created by R was not happening if
  the Python process terminated without calline :func:`rpy2.rinterface.endr()`
  (issue #68, and proof-of-principle fix by chrish42)


Release 2.2.2
=============

Bugs fixed
----------

- With the robjects layer, repr() on a list containing non-vector elements
  was failing

Release 2.2.1
=============

Bugs fixed
----------

- MANIFEST.in was missing from MANIFEST.in, required with Python 3


Release 2.2.0
=============

New Features
------------

- Support for Python 3, and for some of its features ported to Python 2.7

:mod:`rpy2.robjects`:

- :meth:`Environment.keys` to list the keys

- classes :class:`robjects.vectors.POSIXlt` and
  :class:`robjects.vectors.POSIXlt` to represent vectors of R
  dates/time

- :func:`packages.get_packagepath` to get the path to an R package

- module :mod:`rpy2.robjects.help` to expose the R help system to Python

- Metaclass utilities in :mod:`rpy2.robjects.methods`, allowing to reflect
  automatically R S4 classes as Python classes.

- :meth:`rpy2.robjects.vectors.FactorVector.iter_labels` to iterate over the labels

- :class:`rpy2.robjects.vectors.ListVector` to represent R lists.

- Constructor for :class:`rpy2.robjects.vectors.ListVector` and
  :class:`rpy2.robjects.vectors.DataFrame` accept any iterable at the condition
  that the elements iterated through also valid subscripts for it (e.g., given
  an iterable v, the following is valid:

  .. code-block:: python

     x[k] for x in v


:mod:`rpy2.rinterface`:

- :data:`NA_Complex` and :class:`NAComplexType` for missing complex values.

- :class:`SexpExtPtr` to represent R objects of type EXTPTR (external pointers).

- :func:`rpy2.rinterface.parse` to parse a string a R code

- :func:`rpy2.rinterface.rternalise` to wrap Python function as :class:`SexpClosure` that can
  be called by R just as it was a function of its own.

- :class:`rpy2.rinterface.RNULLType` for R's C-level NULL value and
  :class:`rpy2.rinterface.UnboundValueType` for R's C-level R_UnboundValue
  (both singletons).

- :meth:`rinterface.SexpVector.index`, of similar behaviour to :meth:`list.index`.

- :meth:`rpy2.rinterface.Sexp.list_attrs` to list the names of all R attributes
  for a given object.

- :class:`rpy2.rinterface.ByteSexpVector` to represent R 'raw' vectors.

- constant `R_LEN_T_MAX` to store what is the maximum length for a vector in R.

- tuple `R_VERSION_BUILD` to store the version of R rpy2 was built against

- getter :attr:`Sexp.rclass` to return the R class associated with an object

:mod:`rpy2.rlike`:

- :class:`container.OrdDict` get proper methods :meth:`keys` and `get`

:mod:`rpy2.interactive`:

- A new sub-package to provide utilities for interactive work, either for
  handling R interactive events or use Python for interactive programming
  (as often done with the R console)

Changes
-------

:mod:`rpy2.robjects`:

- NA_bool, NA_real, NA_integer, NA_character and NA_complex are now
  deprecated (and removed).
  NA_Logical, NA_Real, NA_Integer, NA_Character, NA_Complex should be used.

- :class:`rpy2.robjects.packages.Package` now inherits from :class:`types.ModuleType`

- classes representing R vector also inherit their type-specific
  rinterface-level counterpart.

- Importing the :class:`rpy2.robjects.numpy2ri` is no longer sufficient
  to active the conversion. Explicit activation is now needed; the function
  `activate` can do that.


:mod:`rpy2.rinterface`:

- :class:`IntSexpVector`, :class:`FloatSexpVector`,
  :class:`StrSexpVector`, :class:`BoolSexpVector`, :class:`ComplexSexpVector`
  are now defined at the C level, improving performances
  and memory footprint whenever a lot of instances are created.

Bugs fixed
----------

- Better and more explicit detection system for needed libraries when
  compiling rpy2 (ported to release 2.1.6)

- Long-standing issue with readline fixed (issue #10)


Release 2.1.9
=============

Bugs fixed
----------

- The R class in rpy2.robjects is now truly a singleton

- When using numpy 1.5 and Python >= 2.7, the exposed buffer for R numerical (double)
  vectors or arrays was wrong.


Release 2.1.8
=============

Bugs fixed
----------

- Fixed issue with R arrays with more than 2 dimensions and numpy arrays
  (issue #47 - backported from the branch 2.2.x).


Release 2.1.7
=============

Bugs fixed
----------

- More fixes for the automated detection of include and libraries at build time.


Release 2.1.6
=============

Bugs fixed
----------

- Further fixes in the automatic detection of includes and libraries
  needed to compile rpy2 against R. The detection code has
  been refactored (backport from the 2.2.x branch)


Release 2.1.5
=============

Bugs fixed
----------

- fixes the automatic detection of R_HOME/lib during building/compiling
  when R_HOME/lib is not in lib/ (issue #54)


Release 2.1.4
=============

New features
------------

- :mod:`rpy2.robjects.lib.ggplot2` now has the functions :func:`limits`,
  :func:`xlim`, :func:`ylim` exposed (patch contributed anonymously)

Bugs fixed
----------

- Install script when the BLAS library used by R is specified as a library
  file (patch by Michael Kuhn)
01acaee
@jperkin jperkin pushed a commit that referenced this issue Mar 14, 2014
obache Update cutter to 1.2.3.
== [release-1-2-3] 1.2.3: 2014-02-09

As long time has passed since Cutter 1.2.2 release,
there are some improvements and fixed bugs.

After Cutter 1.2.2 release, you can install Cutter from
Fedora's official yum repository. No need to register Cutter yum repository on Fedora anymore.

=== Cutter

==== Improvements

  * [doc] Removed a needless period from installation link.
    [GitHub #6] [Patch by Masafumi Yokoyama]
  * Supported lcov 1.10. [cutter-users-ja:92] [Reported by Siganai SE]
  * [doc] Updated download URL on SF.net. [cutter-users-ja:91] [Reported by Siganai SE]
  * [doc] Updated XML report format. [cutter-users-ja:91] [Reported by Siganai SE]
  * Added more trace logs for loader. It helps you to investigate the case when no tests are loaded.
  * [doc] Updated Cygwin's setup.exe URL.
  * Added --log-level option. The value of default log level is "critical|error|warning|message".

==== Fixes

  * [loader] Fixed a bug that ELF loader can't collect symbol because of wrong comparison.
  * Fixed memory leaks on loading all modules.
  * Fixed a warning from GCC 4.8.1 on Ubuntu 13.10
    [GitHub #9] [Reported by Kazuhiro Yamato]

=== CppCutter

==== Improvements

  * Supported cppcut_assert_equal(const type_info &, const type_info &)
    [GitHub #4] [Patch by Kazuhiro Yamato]
  * Supported to catch unhandled C++ exception in test case.
    This change avoids to crash when unexpected exception is thrown.
    [GitHub #8] [Suggested by Kazuhiro Yamato] [Patch by Kazuhiro Yamato]
  * Supported to call destructors of objects on a stack even when an assertion is failed.
    [GitHub #10] [Patch by Kazuhiro Yamato]

==== Fixes

  * [Clang] Fixed a compile error which is caused by missing std::type_info forward declaration.
  * Fixed an invalid memory access when an exception is thrown in cutter's
    assertion function.
    [GitHub #11] [Patch by Kazuhiro Yamato]

=== GCutter

==== Fixes

  * [doc] Fixed a signal name typo about gcut-egg example.

=== Thanks

  * Kazuhiro Yamato
  * Masafumi Yokoyama
  * Siganai SE
b5d6ecf
@jperkin jperkin pushed a commit that referenced this issue Mar 17, 2014
taca Update heel 3.1.3.
## Version 3.1.3 - 2013-11-26
* URL encode the links to files [#14](copiousfreetime/heel#14)
* Fix pid file cleanup on ruby 2.0 [#15](copiousfreetime/heel#15)

## Version 3.1.2 - 2013-10-16
* Fix usage of Mime::Types [#12](copiousfreetime/heel#12) [#13](copiousfreetime/heel#13)

## Version 3.1.1 - 2013-09-29
* Fix request logging [#10](copiousfreetime/heel#10)
2d9bf19
@jperkin jperkin pushed a commit that referenced this issue Mar 18, 2014
taca Update heel 3.1.3.
## Version 3.1.3 - 2013-11-26
* URL encode the links to files [#14](copiousfreetime/heel#14)
* Fix pid file cleanup on ruby 2.0 [#15](copiousfreetime/heel#15)

## Version 3.1.2 - 2013-10-16
* Fix usage of Mime::Types [#12](copiousfreetime/heel#12) [#13](copiousfreetime/heel#13)

## Version 3.1.1 - 2013-09-29
* Fix request logging [#10](copiousfreetime/heel#10)
d9933eb
@jperkin jperkin pushed a commit that referenced this issue Apr 1, 2014
wiz Update to 3.7:
---
3.7
---

* Gnome keyring no longer relies on the GNOME_KEYRING_CONTROL environment
  variable.
* Issue #140: Restore compatibility for older versions of PyWin32.

---
3.6
---

* `Pull Request #1 (github) <jaraco/keyring#1:
  Add support for packages that wish to bundle keyring by using relative
  imports throughout.

---
3.5
---

* Issue #49: Give the backend priorities a 1.5 multiplier bump when an
  XDG_CURRENT_DESKTOP environment variable matches the keyring's target
  environment.
* Issue #99: Clarified documentation on location of config and data files.
  Prepared the code base to treat the two differently on Unix-based systems.
  For now, the behavior is unchanged.

---
3.4
---

* Extracted FileBacked and Encrypted base classes.
* Add a pyinstaller hook to expose backend modules. Ref #124
* Pull request #41: Use errno module instead of hardcoding error codes.
* SecretService backend: correctly handle cases when user dismissed
  the collection creation or unlock prompt.

---
3.3
---

* Pull request #40: KWallet backend will now honor the ``KDE_FULL_SESSION``
  environment variable as found on openSUSE.

-----
3.2.1
-----

* SecretService backend: use a different function to check that the
  backend is functional. The default collection may not exist, but
  the collection will remain usable in that case.

  Also, make the error message more verbose.

  Resolves https://bugs.launchpad.net/bugs/1242412.

---
3.2
---

* Issue #120: Invoke KeyringBackend.priority during load_keyring to ensure
  that any keyring loaded is actually viable (or raises an informative
  exception).

* File keyring:

   - Issue #123: fix removing items.
   - Correctly escape item name when removing.
   - Use with statement when working with files.

* Add a test for removing one item in group.

* Issue #81: Added experimental support for third-party backends. See
  `keyring.core._load_library_extensions` for information on supplying
  a third-party backend.

---
3.1
---

* All code now runs natively on both Python 2 and Python 3, no 2to3 conversion
  is required.
* Testsuite: clean up, and make more use of unittest2 methods.

-----
3.0.5
-----

* Issue #114: Fix logic in pyfs detection.

-----
3.0.4
-----

* Issue #114: Fix detection of pyfs under Mercurial Demand Import.

-----
3.0.3
-----

* Simplified the implementation of ``keyring.core.load_keyring``. It now uses
  ``__import__`` instead of loading modules explicitly. The ``keyring_path``
  parameter to ``load_keyring`` is now deprecated. Callers should instead
  ensure their module is available on ``sys.path`` before calling
  ``load_keyring``. Keyring still honors ``keyring-path``. This change fixes
  Issue #113 in which the explicit module loading of keyring modules was
  breaking package-relative imports.

-----
3.0.2
-----

* Renamed ``keyring.util.platform`` to ``keyring.util.platform_``. As reported
  in Issue #112 and `mercurial_keyring #31
  <https://bitbucket.org/Mekk/mercurial_keyring/issue/31>`_ and in `Mercurial
  itself <http://bz.selenic.com/show_bug.cgi?id=4029>`_, Mercurial's Demand
  Import does not honor ``absolute_import`` directives, so it's not possible
  to have a module with the same name as another top-level module. A patch is
  in place to fix this issue upstream, but to support older Mercurial
  versions, this patch will remain for some time.

-----
3.0.1
-----

* Ensure that modules are actually imported even in Mercurial's Demand Import
  environment.

---
3.0
---

* Removed support for Python 2.5.
* Removed names in ``keyring.backend`` moved in 1.1 and previously retained
  for compatibilty.

-----
2.1.1
-----

* Restored Python 2.5 compatibility (lost in 2.0).

---
2.1
---

*  Issue #10: Added a 'store' attribute to the OS X Keyring, enabling custom
   instances of the KeyringBackend to use another store, such as the
   'internet' store. For example::

       keys = keyring.backends.OS_X.Keyring()
       keys.store = 'internet'
       keys.set_password(system, user, password)
       keys.get_password(system, user)

   The default for all instances can be set in the class::

       keyring.backends.OS_X.Keyring.store = 'internet'

*  GnomeKeyring: fix availability checks, and make sure the warning
   message from pygobject is not printed.

*  Fixes to GnomeKeyring and SecretService tests.

-----
2.0.3
-----

*  Issue #112: Backend viability/priority checks now are more aggressive about
   module presence checking, requesting ``__name__`` from imported modules to
   force the demand importer to actually attempt the import.

-----
2.0.2
-----

*  Issue #111: Windows backend isn't viable on non-Windows platforms.

-----
2.0.1
-----

*  Issue #110: Fix issues with ``Windows.RegistryKeyring``.

---
2.0
---

*  Issue #80: Prioritized backend support. The primary interface for Keyring
   backend classes has been refactored to now emit a 'priority' based on the
   current environment (operating system, libraries available, etc). These
   priorities provide an indication of the applicability of that backend for
   the current environment. Users are still welcome to specify a particular
   backend in configuration, but the default behavior should now be to select
   the most appropriate backend by default.

-----
1.6.1
-----

* Only include pytest-runner in 'setup requirements' when ptr invocation is
  indicated in the command-line (Issue #105).

---
1.6
---

*  GNOME Keyring backend:

   - Use the same attributes (``username`` / ``service``) as the SecretService
     backend uses, allow searching for old ones for compatibility.
   - Also set ``application`` attribute.
   - Correctly handle all types of errors, not only ``CANCELLED`` and ``NO_MATCH``.
   - Avoid printing warnings to stderr when GnomeKeyring is not available.

* Secret Service backend:

   - Use a better label for passwords, the same as GNOME Keyring backend uses.

---
1.5
---

*  SecretService: allow deleting items created using previous python-keyring
   versions.

   Before the switch to secretstorage, python-keyring didn't set "application"
   attribute. Now in addition to supporting searching for items without that
   attribute, python-keyring also supports deleting them.

*  Use ``secretstorage.get_default_collection`` if it's available.

   On secretstorage 1.0 or later, python-keyring now tries to create the
   default collection if it doesn't exist, instead of just raising the error.

*  Improvements for tests, including fix for Issue #102.

---
1.4
---

* Switch GnomeKeyring backend to use native libgnome-keyring via
  GObject Introspection, not the obsolete python-gnomekeyring module.

---
1.3
---

* Use the `SecretStorage library <https://pypi.python.org/pypi/SecretStorage>`_
  to implement the Secret Service backend (instead of using dbus directly).
  Now the keyring supports prompting for and deleting passwords. Fixes #69,
  #77, and #93.
* Catch `gnomekeyring.IOError` per the issue `reported in Nova client
  <https://bugs.launchpad.net/python-novaclient/+bug/1116302>`_.
* Issue #92 Added support for delete_password on Mac OS X Keychain.

-----
1.2.3
-----

* Fix for Encrypted File backend on Python 3.
* Issue #97 Improved support for PyPy.

-----
1.2.2
-----

* Fixed handling situations when user cancels kwallet dialog or denies access
  for the app.

-----
1.2.1
-----

* Fix for kwallet delete.
* Fix for OS X backend on Python 3.
* Issue #84: Fix for Google backend on Python 3 (use of raw_input not caught
  by 2to3).

---
1.2
---

* Implemented delete_password on most keyrings. Keyring 2.0 will require
  delete_password to implement a Keyring. Fixes #79.

-----
1.1.2
-----

* Issue #78: pyfilesystem backend now works on Windows.

-----
1.1.1
-----

* Fixed MANIFEST.in so .rst files are included.

---
1.1
---

This is the last build that will support installation in a pure-distutils
mode. Subsequent releases will require setuptools/distribute to install.
Python 3 installs have always had this requirement (for 2to3 install support),
but starting with the next minor release (1.2+), setuptools will be required.

Additionally, this release has made some substantial refactoring in an
attempt to modularize the backends. An attempt has been made to maintain 100%
backward-compatibility, although if your library does anything fancy with
module structure or clasess, some tweaking may be necessary. The
backward-compatible references will be removed in 2.0, so the 1.1+ releases
represent a transitional implementation which should work with both legacy
and updated module structure.

* Added a console-script 'keyring' invoking the command-line interface.
* Deprecated _ExtensionKeyring.
* Moved PasswordSetError and InitError to an `errors` module (references kept
  for backward-compatibility).
* Moved concrete backend implementations into their own modules (references
  kept for backward compatibility):

  - OSXKeychain -> backends.OS_X.Keyring
  - GnomeKeyring -> backends.Gnome.Keyring
  - SecretServiceKeyring -> backends.SecretService.Keyring
  - KDEKWallet -> backends.kwallet.Keyring
  - BasicFileKeyring -> backends.file.BaseKeyring
  - CryptedFileKeyring -> backends.file.EncryptedKeyring
  - UncryptedFileKeyring -> backends.file.PlaintextKeyring
  - Win32CryptoKeyring -> backends.Windows.EncryptedKeyring
  - WinVaultKeyring -> backends.Windows.WinVaultKeyring
  - Win32CryptoRegistry -> backends.Windows.RegistryKeyring
  - select_windows_backend -> backends.Windows.select_windows_backend
  - GoogleDocsKeyring -> backends.Google.DocsKeyring
  - Credential -> keyring.credentials.Credential
  - BaseCredential -> keyring.credentials.SimpleCredential
  - EnvironCredential -> keyring.credentials.EnvironCredential
  - GoogleEnvironCredential -> backends.Google.EnvironCredential
  - BaseKeyczarCrypter -> backends.keyczar.BaseCrypter
  - KeyczarCrypter -> backends.keyczar.Crypter
  - EnvironKeyczarCrypter -> backends.keyczar.EnvironCrypter
  - EnvironGoogleDocsKeyring -> backends.Google.KeyczarDocsKeyring
  - BasicPyfilesystemKeyring -> backends.pyfs.BasicKeyring
  - UnencryptedPyfilesystemKeyring -> backends.pyfs.PlaintextKeyring
  - EncryptedPyfilesystemKeyring -> backends.pyfs.EncryptedKeyring
  - EnvironEncryptedPyfilesystemKeyring -> backends.pyfs.KeyczarKeyring
  - MultipartKeyringWrapper -> backends.multi.MultipartKeyringWrapper

* Officially require Python 2.5 or greater (although unofficially, this
  requirement has been in place since 0.10).

---
1.0
---

This backward-incompatible release attempts to remove some cruft from the
codebase that's accumulated over the versions.

* Removed legacy file relocation support. `keyring` no longer supports loading
  configuration or file-based backends from ~. If upgrading from 0.8 or later,
  the files should already have been migrated to their new proper locations.
  If upgrading from 0.7.x or earlier, the files will have to be migrated
  manually.
* Removed CryptedFileKeyring migration support. To maintain an existing
  CryptedFileKeyring, one must first upgrade to 0.9.2 or later and access the
  keyring before upgrading to 1.0 to retain the existing keyring.
* File System backends now create files without group and world permissions.
  Fixes #67.

------
0.10.1
------

* Merged 0.9.3 to include fix for #75.

----
0.10
----

* Add support for using `Keyczar <http://www.keyczar.org/>`_ to encrypt
  keyrings. Keyczar is "an open source cryptographic toolkit designed to make
  it easier and safer for developers to use cryptography in their
  applications."
* Added support for storing keyrings on Google Docs or any other filesystem
  supported by pyfilesystem.
* Fixed issue in Gnome Keyring when unicode is passed as the service name,
  username, or password.
* Tweaked SecretService code to pass unicode to DBus, as unicode is the
  preferred format.
* Issue #71 - Fixed logic in CryptedFileKeyring.
* Unencrypted keyring file will be saved with user read/write (and not group
  or world read/write).

-----
0.9.3
-----

* Ensure migration is run when get_password is called. Fixes #75. Thanks to
  Marc Deslauriers for reporting the bug and supplying the patch.

-----
0.9.2
-----

* Keyring 0.9.1 introduced a whole different storage format for the
  CryptedFileKeyring, but this introduced some potential compatibility issues.
  This release incorporates the security updates but reverts to the INI file
  format for storage, only encrypting the passwords and leaving the service
  and usernames in plaintext. Subsequent releases may incorporate a new
  keyring to implement a whole-file encrypted version. Fixes #64.
* The CryptedFileKeyring now requires simplejson for Python 2.5 clients.

-----
0.9.1
-----

* Fix for issue where SecretServiceBackend.set_password would raise a
  UnicodeError on Python 3 or when a unicode password was provided on Python
  2.
* CryptedFileKeyring now uses PBKDF2 to derive the key from the user's
  password and a random hash. The IV is chosen randomly as well. All the
  stored passwords are encrypted at once. Any keyrings using the old format
  will be automatically converted to the new format (but will no longer be
  compatible with 0.9 and earlier). The user's password is no longer limited
  to 32 characters. PyCrypto 2.5 or greater is now required for this keyring.

---
0.9
---

* Add support for GTK 3 and secret service D-Bus. Fixes #52.
* Issue #60 - Use correct method for decoding.

-----
0.8.1
-----

* Fix regression in keyring lib on Windows XP where the LOCALAPPDATA
  environment variable is not present.

---
0.8
---

* Mac OS X keyring backend now uses subprocess calls to the `security`
  command instead of calling the API, which with the latest updates, no
  longer allows Python to invoke from a virtualenv. Fixes issue #13.
* When using file-based storage, the keyring files are no longer stored
  in the user's home directory, but are instead stored in platform-friendly
  locations (`%localappdata%\Python Keyring` on Windows and according to
  the freedesktop.org Base Dir Specification
  (`$XDG_DATA_HOME/python_keyring` or `$HOME/.local/share/python_keyring`)
  on other operating systems). This fixes #21.

*Backward Compatibility Notice*

Due to the new storage location for file-based keyrings, keyring 0.8
supports backward compatibility by automatically moving the password
files to the updated location. In general, users can upgrade to 0.8 and
continue to operate normally. Any applications that customize the storage
location or make assumptions about the storage location will need to take
this change into consideration. Additionally, after upgrading to 0.8,
it is not possible to downgrade to 0.7 without manually moving
configuration files. In 1.0, the backward compatibilty
will be removed.

-----
0.7.1
-----

* Removed non-ASCII characters from README and CHANGES docs (required by
  distutils if we're to include them in the long_description). Fixes #55.

---
0.7
---

* Python 3 is now supported. All tests now pass under Python 3.2 on
  Windows and Linux (although Linux backend support is limited). Fixes #28.
* Extension modules on Mac and Windows replaced by pure-Python ctypes
  implementations. Thanks to Jerome Laheurte.
* WinVaultKeyring now supports multiple passwords for the same service. Fixes
  #47.
* Most of the tests don't require user interaction anymore.
* Entries stored in Gnome Keyring appears now with a meaningful name if you try
  to browser your keyring (for ex. with Seahorse)
* Tests from Gnome Keyring no longer pollute the user own keyring.
* `keyring.util.escape` now accepts only unicode strings. Don't try to encode
  strings passed to it.

-----
0.6.2
-----

* fix compiling on OSX with XCode 4.0

-----
0.6.1
-----

* Gnome keyring should not be used if there is no DISPLAY or if the dbus is
  not around (https://bugs.launchpad.net/launchpadlib/+bug/752282).

---
0.6
---

* Added `keyring.http` for facilitating HTTP Auth using keyring.

* Add a utility to access the keyring from the command line.
c4cd1bc
@jperkin jperkin pushed a commit that referenced this issue Apr 15, 2014
wiz Update to 3.7:
---
3.7
---

* Gnome keyring no longer relies on the GNOME_KEYRING_CONTROL environment
  variable.
* Issue #140: Restore compatibility for older versions of PyWin32.

---
3.6
---

* `Pull Request #1 (github) <jaraco/keyring#1:
  Add support for packages that wish to bundle keyring by using relative
  imports throughout.

---
3.5
---

* Issue #49: Give the backend priorities a 1.5 multiplier bump when an
  XDG_CURRENT_DESKTOP environment variable matches the keyring's target
  environment.
* Issue #99: Clarified documentation on location of config and data files.
  Prepared the code base to treat the two differently on Unix-based systems.
  For now, the behavior is unchanged.

---
3.4
---

* Extracted FileBacked and Encrypted base classes.
* Add a pyinstaller hook to expose backend modules. Ref #124
* Pull request #41: Use errno module instead of hardcoding error codes.
* SecretService backend: correctly handle cases when user dismissed
  the collection creation or unlock prompt.

---
3.3
---

* Pull request #40: KWallet backend will now honor the ``KDE_FULL_SESSION``
  environment variable as found on openSUSE.

-----
3.2.1
-----

* SecretService backend: use a different function to check that the
  backend is functional. The default collection may not exist, but
  the collection will remain usable in that case.

  Also, make the error message more verbose.

  Resolves https://bugs.launchpad.net/bugs/1242412.

---
3.2
---

* Issue #120: Invoke KeyringBackend.priority during load_keyring to ensure
  that any keyring loaded is actually viable (or raises an informative
  exception).

* File keyring:

   - Issue #123: fix removing items.
   - Correctly escape item name when removing.
   - Use with statement when working with files.

* Add a test for removing one item in group.

* Issue #81: Added experimental support for third-party backends. See
  `keyring.core._load_library_extensions` for information on supplying
  a third-party backend.

---
3.1
---

* All code now runs natively on both Python 2 and Python 3, no 2to3 conversion
  is required.
* Testsuite: clean up, and make more use of unittest2 methods.

-----
3.0.5
-----

* Issue #114: Fix logic in pyfs detection.

-----
3.0.4
-----

* Issue #114: Fix detection of pyfs under Mercurial Demand Import.

-----
3.0.3
-----

* Simplified the implementation of ``keyring.core.load_keyring``. It now uses
  ``__import__`` instead of loading modules explicitly. The ``keyring_path``
  parameter to ``load_keyring`` is now deprecated. Callers should instead
  ensure their module is available on ``sys.path`` before calling
  ``load_keyring``. Keyring still honors ``keyring-path``. This change fixes
  Issue #113 in which the explicit module loading of keyring modules was
  breaking package-relative imports.

-----
3.0.2
-----

* Renamed ``keyring.util.platform`` to ``keyring.util.platform_``. As reported
  in Issue #112 and `mercurial_keyring #31
  <https://bitbucket.org/Mekk/mercurial_keyring/issue/31>`_ and in `Mercurial
  itself <http://bz.selenic.com/show_bug.cgi?id=4029>`_, Mercurial's Demand
  Import does not honor ``absolute_import`` directives, so it's not possible
  to have a module with the same name as another top-level module. A patch is
  in place to fix this issue upstream, but to support older Mercurial
  versions, this patch will remain for some time.

-----
3.0.1
-----

* Ensure that modules are actually imported even in Mercurial's Demand Import
  environment.

---
3.0
---

* Removed support for Python 2.5.
* Removed names in ``keyring.backend`` moved in 1.1 and previously retained
  for compatibilty.

-----
2.1.1
-----

* Restored Python 2.5 compatibility (lost in 2.0).

---
2.1
---

*  Issue #10: Added a 'store' attribute to the OS X Keyring, enabling custom
   instances of the KeyringBackend to use another store, such as the
   'internet' store. For example::

       keys = keyring.backends.OS_X.Keyring()
       keys.store = 'internet'
       keys.set_password(system, user, password)
       keys.get_password(system, user)

   The default for all instances can be set in the class::

       keyring.backends.OS_X.Keyring.store = 'internet'

*  GnomeKeyring: fix availability checks, and make sure the warning
   message from pygobject is not printed.

*  Fixes to GnomeKeyring and SecretService tests.

-----
2.0.3
-----

*  Issue #112: Backend viability/priority checks now are more aggressive about
   module presence checking, requesting ``__name__`` from imported modules to
   force the demand importer to actually attempt the import.

-----
2.0.2
-----

*  Issue #111: Windows backend isn't viable on non-Windows platforms.

-----
2.0.1
-----

*  Issue #110: Fix issues with ``Windows.RegistryKeyring``.

---
2.0
---

*  Issue #80: Prioritized backend support. The primary interface for Keyring
   backend classes has been refactored to now emit a 'priority' based on the
   current environment (operating system, libraries available, etc). These
   priorities provide an indication of the applicability of that backend for
   the current environment. Users are still welcome to specify a particular
   backend in configuration, but the default behavior should now be to select
   the most appropriate backend by default.

-----
1.6.1
-----

* Only include pytest-runner in 'setup requirements' when ptr invocation is
  indicated in the command-line (Issue #105).

---
1.6
---

*  GNOME Keyring backend:

   - Use the same attributes (``username`` / ``service``) as the SecretService
     backend uses, allow searching for old ones for compatibility.
   - Also set ``application`` attribute.
   - Correctly handle all types of errors, not only ``CANCELLED`` and ``NO_MATCH``.
   - Avoid printing warnings to stderr when GnomeKeyring is not available.

* Secret Service backend:

   - Use a better label for passwords, the same as GNOME Keyring backend uses.

---
1.5
---

*  SecretService: allow deleting items created using previous python-keyring
   versions.

   Before the switch to secretstorage, python-keyring didn't set "application"
   attribute. Now in addition to supporting searching for items without that
   attribute, python-keyring also supports deleting them.

*  Use ``secretstorage.get_default_collection`` if it's available.

   On secretstorage 1.0 or later, python-keyring now tries to create the
   default collection if it doesn't exist, instead of just raising the error.

*  Improvements for tests, including fix for Issue #102.

---
1.4
---

* Switch GnomeKeyring backend to use native libgnome-keyring via
  GObject Introspection, not the obsolete python-gnomekeyring module.

---
1.3
---

* Use the `SecretStorage library <https://pypi.python.org/pypi/SecretStorage>`_
  to implement the Secret Service backend (instead of using dbus directly).
  Now the keyring supports prompting for and deleting passwords. Fixes #69,
  #77, and #93.
* Catch `gnomekeyring.IOError` per the issue `reported in Nova client
  <https://bugs.launchpad.net/python-novaclient/+bug/1116302>`_.
* Issue #92 Added support for delete_password on Mac OS X Keychain.

-----
1.2.3
-----

* Fix for Encrypted File backend on Python 3.
* Issue #97 Improved support for PyPy.

-----
1.2.2
-----

* Fixed handling situations when user cancels kwallet dialog or denies access
  for the app.

-----
1.2.1
-----

* Fix for kwallet delete.
* Fix for OS X backend on Python 3.
* Issue #84: Fix for Google backend on Python 3 (use of raw_input not caught
  by 2to3).

---
1.2
---

* Implemented delete_password on most keyrings. Keyring 2.0 will require
  delete_password to implement a Keyring. Fixes #79.

-----
1.1.2
-----

* Issue #78: pyfilesystem backend now works on Windows.

-----
1.1.1
-----

* Fixed MANIFEST.in so .rst files are included.

---
1.1
---

This is the last build that will support installation in a pure-distutils
mode. Subsequent releases will require setuptools/distribute to install.
Python 3 installs have always had this requirement (for 2to3 install support),
but starting with the next minor release (1.2+), setuptools will be required.

Additionally, this release has made some substantial refactoring in an
attempt to modularize the backends. An attempt has been made to maintain 100%
backward-compatibility, although if your library does anything fancy with
module structure or clasess, some tweaking may be necessary. The
backward-compatible references will be removed in 2.0, so the 1.1+ releases
represent a transitional implementation which should work with both legacy
and updated module structure.

* Added a console-script 'keyring' invoking the command-line interface.
* Deprecated _ExtensionKeyring.
* Moved PasswordSetError and InitError to an `errors` module (references kept
  for backward-compatibility).
* Moved concrete backend implementations into their own modules (references
  kept for backward compatibility):

  - OSXKeychain -> backends.OS_X.Keyring
  - GnomeKeyring -> backends.Gnome.Keyring
  - SecretServiceKeyring -> backends.SecretService.Keyring
  - KDEKWallet -> backends.kwallet.Keyring
  - BasicFileKeyring -> backends.file.BaseKeyring
  - CryptedFileKeyring -> backends.file.EncryptedKeyring
  - UncryptedFileKeyring -> backends.file.PlaintextKeyring
  - Win32CryptoKeyring -> backends.Windows.EncryptedKeyring
  - WinVaultKeyring -> backends.Windows.WinVaultKeyring
  - Win32CryptoRegistry -> backends.Windows.RegistryKeyring
  - select_windows_backend -> backends.Windows.select_windows_backend
  - GoogleDocsKeyring -> backends.Google.DocsKeyring
  - Credential -> keyring.credentials.Credential
  - BaseCredential -> keyring.credentials.SimpleCredential
  - EnvironCredential -> keyring.credentials.EnvironCredential
  - GoogleEnvironCredential -> backends.Google.EnvironCredential
  - BaseKeyczarCrypter -> backends.keyczar.BaseCrypter
  - KeyczarCrypter -> backends.keyczar.Crypter
  - EnvironKeyczarCrypter -> backends.keyczar.EnvironCrypter
  - EnvironGoogleDocsKeyring -> backends.Google.KeyczarDocsKeyring
  - BasicPyfilesystemKeyring -> backends.pyfs.BasicKeyring
  - UnencryptedPyfilesystemKeyring -> backends.pyfs.PlaintextKeyring
  - EncryptedPyfilesystemKeyring -> backends.pyfs.EncryptedKeyring
  - EnvironEncryptedPyfilesystemKeyring -> backends.pyfs.KeyczarKeyring
  - MultipartKeyringWrapper -> backends.multi.MultipartKeyringWrapper

* Officially require Python 2.5 or greater (although unofficially, this
  requirement has been in place since 0.10).

---
1.0
---

This backward-incompatible release attempts to remove some cruft from the
codebase that's accumulated over the versions.

* Removed legacy file relocation support. `keyring` no longer supports loading
  configuration or file-based backends from ~. If upgrading from 0.8 or later,
  the files should already have been migrated to their new proper locations.
  If upgrading from 0.7.x or earlier, the files will have to be migrated
  manually.
* Removed CryptedFileKeyring migration support. To maintain an existing
  CryptedFileKeyring, one must first upgrade to 0.9.2 or later and access the
  keyring before upgrading to 1.0 to retain the existing keyring.
* File System backends now create files without group and world permissions.
  Fixes #67.

------
0.10.1
------

* Merged 0.9.3 to include fix for #75.

----
0.10
----

* Add support for using `Keyczar <http://www.keyczar.org/>`_ to encrypt
  keyrings. Keyczar is "an open source cryptographic toolkit designed to make
  it easier and safer for developers to use cryptography in their
  applications."
* Added support for storing keyrings on Google Docs or any other filesystem
  supported by pyfilesystem.
* Fixed issue in Gnome Keyring when unicode is passed as the service name,
  username, or password.
* Tweaked SecretService code to pass unicode to DBus, as unicode is the
  preferred format.
* Issue #71 - Fixed logic in CryptedFileKeyring.
* Unencrypted keyring file will be saved with user read/write (and not group
  or world read/write).

-----
0.9.3
-----

* Ensure migration is run when get_password is called. Fixes #75. Thanks to
  Marc Deslauriers for reporting the bug and supplying the patch.

-----
0.9.2
-----

* Keyring 0.9.1 introduced a whole different storage format for the
  CryptedFileKeyring, but this introduced some potential compatibility issues.
  This release incorporates the security updates but reverts to the INI file
  format for storage, only encrypting the passwords and leaving the service
  and usernames in plaintext. Subsequent releases may incorporate a new
  keyring to implement a whole-file encrypted version. Fixes #64.
* The CryptedFileKeyring now requires simplejson for Python 2.5 clients.

-----
0.9.1
-----

* Fix for issue where SecretServiceBackend.set_password would raise a
  UnicodeError on Python 3 or when a unicode password was provided on Python
  2.
* CryptedFileKeyring now uses PBKDF2 to derive the key from the user's
  password and a random hash. The IV is chosen randomly as well. All the
  stored passwords are encrypted at once. Any keyrings using the old format
  will be automatically converted to the new format (but will no longer be
  compatible with 0.9 and earlier). The user's password is no longer limited
  to 32 characters. PyCrypto 2.5 or greater is now required for this keyring.

---
0.9
---

* Add support for GTK 3 and secret service D-Bus. Fixes #52.
* Issue #60 - Use correct method for decoding.

-----
0.8.1
-----

* Fix regression in keyring lib on Windows XP where the LOCALAPPDATA
  environment variable is not present.

---
0.8
---

* Mac OS X keyring backend now uses subprocess calls to the `security`
  command instead of calling the API, which with the latest updates, no
  longer allows Python to invoke from a virtualenv. Fixes issue #13.
* When using file-based storage, the keyring files are no longer stored
  in the user's home directory, but are instead stored in platform-friendly
  locations (`%localappdata%\Python Keyring` on Windows and according to
  the freedesktop.org Base Dir Specification
  (`$XDG_DATA_HOME/python_keyring` or `$HOME/.local/share/python_keyring`)
  on other operating systems). This fixes #21.

*Backward Compatibility Notice*

Due to the new storage location for file-based keyrings, keyring 0.8
supports backward compatibility by automatically moving the password
files to the updated location. In general, users can upgrade to 0.8 and
continue to operate normally. Any applications that customize the storage
location or make assumptions about the storage location will need to take
this change into consideration. Additionally, after upgrading to 0.8,
it is not possible to downgrade to 0.7 without manually moving
configuration files. In 1.0, the backward compatibilty
will be removed.

-----
0.7.1
-----

* Removed non-ASCII characters from README and CHANGES docs (required by
  distutils if we're to include them in the long_description). Fixes #55.

---
0.7
---

* Python 3 is now supported. All tests now pass under Python 3.2 on
  Windows and Linux (although Linux backend support is limited). Fixes #28.
* Extension modules on Mac and Windows replaced by pure-Python ctypes
  implementations. Thanks to Jerome Laheurte.
* WinVaultKeyring now supports multiple passwords for the same service. Fixes
  #47.
* Most of the tests don't require user interaction anymore.
* Entries stored in Gnome Keyring appears now with a meaningful name if you try
  to browser your keyring (for ex. with Seahorse)
* Tests from Gnome Keyring no longer pollute the user own keyring.
* `keyring.util.escape` now accepts only unicode strings. Don't try to encode
  strings passed to it.

-----
0.6.2
-----

* fix compiling on OSX with XCode 4.0

-----
0.6.1
-----

* Gnome keyring should not be used if there is no DISPLAY or if the dbus is
  not around (https://bugs.launchpad.net/launchpadlib/+bug/752282).

---
0.6
---

* Added `keyring.http` for facilitating HTTP Auth using keyring.

* Add a utility to access the keyring from the command line.
84ef075
@jperkin jperkin pushed a commit that referenced this issue Apr 15, 2014
imil Updated irclib to version 8.5.4
8.5.4

    Issue #32: Add logging around large DCC messages to facilitate
    troubleshooting.
    Issue #31: Fix error in connection wrapper for SSL example.

8.5.3

    Issue #28: Fix TypeError in version calculation in irc.bot CTCP version.

8.5.2

    Updated DCC send and receive scripts (Issue #27).

8.5.1

    Fix timestamp support in schedule.DelayedCommand construction.

8.5

    irc.client.NickMask is now a Unicode object on Python 2. Fixes issue
    reported in pull request #19.
    Issue #24: Added DCCConnection.send_bytes for transmitting binary data.
    privmsg remains to support transmitting text.

8.4

    Code base now runs natively on Python 2 and Python 3, but requires six to
    be installed.
    Issue #25: Rate-limiting has been updated to be finer grained (preventing
    bursts exceeding the limit following idle periods).

8.3.2

    Issue #22: Catch error in bot.py on NAMREPLY when nick is not in any visible
    channel.

8.3.1

    Fixed encoding errors in server on Python 3.

8.3

    Added a set_keepalive method to the ServerConnection. Sends a periodic PING
    message every indicated interval.

8.2

    Added support for throttling send_raw messages via the ServerConnection
    object. For example, on any connection object:

        connection.set_rate_limit(30)

    That would set the rate limit to 30 Hz (30 per second). Thanks to Jason Kendall for the suggestion and bug fixes.

8.1.2

    Fix typo in client.NickMask.

8.1.1

    Fix typo in bot.py.

8.1

    Issue #15: Added client support for ISUPPORT directives on server connections. Now, each ServerConnection has a features attribute which reflects the features supported by the server. See the docs for irc.features for details about the implementation.

8.0.1

    Issue #14: Fix errors when handlers of the same priority are added under Python 3. This also fixes the unintended behavior of allowing handlers of the same priority to compare as unequal.

8.0

This release brings several backward-incompatible changes to the scheduled commands.

    Refactored implementation of schedule classes. No longer do they override the datetime constructor, but now only provide suitable classmethods for construction in various forms.
    Removed backward-compatible references from irc.client.
    Remove 'arguments' parameter from scheduled commands.

Clients that reference the schedule classes from irc.client or that construct them from the basic constructor will need to update to use the new class methods:

- DelayedCommand -> DelayedCommand.after
- PeriodicCommand -> PeriodicCommand.after

Arguments may no longer be passed to the 'function' callback, but one is encouraged instead to use functools.partial to attach parameters to the callback. For example:

DelayedCommand.after(3, func, ('a', 10))

becomes:

func = functools.partial(func, 'a', 10)
DelayedCommand.after(3, func)

This mode puts less constraints on the both the handler and the caller. For example, a caller can now pass keyword arguments instead:

func = functools.partial(func, name='a', quantity=10)
DelayedCommand.after(3, func)

Readability, maintainability, and usability go up.
7.1.2

    Issue #13: TypeError on Python 3 when constructing PeriodicCommand (and thus execute_every).

7.1.1

    Fixed regression created in 7.0 where PeriodicCommandFixedDelay would only cause the first command to be scheduled, but not subsequent ones.

7.1

    Moved scheduled command classes to irc.schedule module. Kept references for backwards-compatibility.

7.0

    PeriodicCommand now raises a ValueError if it's created with a negative or zero delay (meaning all subsequent commands are immediately due). This fixes #12.

    Renamed the parameters to the IRC object. If you use a custom event loop and your code constructs the IRC object with keyword parameters, you will need to update your code to use the new names, so:

    IRC(fn_to_add_socket=adder, fn_to_remove_socket=remover, fn_to_add_timeout=timeout)

    becomes:

    IRC(on_connect=adder, on_disconnect=remover, on_schedule=timeout)

    If you don't use a custom event loop or you pass the parameters positionally, no change is necessary.

6.0.1

    Fixed some unhandled exceptions in server client connections when the client would disconnect in response to messages sent after select was called.

6.0

    Moved LineBuffer and DecodingLineBuffer from client to buffer module. Backward-compatible references have been kept for now.
    Removed daemon mode and log-to-file options for server.
    Miscellaneous bugfixes in server.

5.1.1

    Fix error in 2to3 conversion on irc/server.py (issue #11).

5.1

The IRC library is now licensed under the MIT license.

    Added irc/server.py, based on hircd by Ferry Boender.
    Added support for CAP command (pull request #10), thanks to Danneh Oaks.

5.0

Another backward-incompatible change. In irc 5.0, many of the unnecessary getter functions have been removed and replaced with simple attributes. This change addresses issue #2. In particular:

        Connection._get_socket() -> Connection.socket (including subclasses)
        Event.eventtype() -> Event.type
        Event.source() -> Event.source
        Event.target() -> Event.target
        Event.arguments() -> Event.arguments

The nm_to_* functions were removed. Instead, use the NickMask class attributes.

These deprecated function aliases were removed from irc.client:

- parse_nick_modes -> modes.parse_nick_modes
- parse_channel_modes -> modes.parse_channel_modes
- generated_events -> events.generated
- protocol_events -> events.protocol
- numeric_events -> events.numeric
- all_events -> events.all
- irc_lower -> strings.lower

Also, the parameter name when constructing an event was renamed from eventtype to simply type.
4.0

    Removed deprecated arguments to ServerConnection.connect. See notes on the 3.3 release on how to use the connect_factory parameter if your application requires ssl, ipv6, or other connection customization.

3.6.1

    Filter out disconnected sockets when processing input.

3.6

    Created two new exceptions in irc.client: MessageTooLong and InvalidCharacters.
    Use explicit exceptions instead of ValueError when sending data.

3.5

    SingleServerIRCBot now accepts keyword arguments which are passed through to the ServerConnection.connect method. One can use this to use SSL for connections:

    factory = irc.connection.Factory(wrapper=ssl.wrap_socket)
    bot = irc.bot.SingleServerIRCBot(..., connect_factory = factory)
1ee66e1
@jperkin jperkin pushed a commit that referenced this issue May 19, 2014
sborrill Update to fping 3.10.
Changes:
2014-05-03  David Schweikert  <david@schweikert.ch>
  * Version 3.10
  * Fix confusing error message with -g and IPv6 addresses (#58, reported by
  * Axel Beckert)
  * Allow option '-f' also for non-root (since setuid privileges are
  * dropped)
  * Do not retry twice DNS lookup on DNS lookup problem
  * Remove support for NIS groups
  * Better document -B backoff-factor and when it can be used (#33, Oleksiy
  * Zagorskyi)
  * More tests added

2014-03-08  David Schweikert  <david@schweikert.ch>
  * Version 3.9
  * Fix random output on socket error (reported by Aleksandrs Saveljevs,
  * #56)
  * Support ppc64le architecture by including alpha libtool version
    (reported by Amit Kumar Gupta and Aravinda B Thunug)
  * Fix compilation problem on FreeBSD (#57)
  * Initial test suite and continous intergration (with travis-ci.org /
  * coveralls.io)
  * Don't output usage information on error

2013-11-08  David Schweikert  <david@schweikert.ch>
  * Version 3.8
  * Fix segmentation fault introduced in version 3.7 with loop mode
  * (reported
    by Vlad Glagolev, #55)

2013-11-04  David Schweikert  <david@schweikert.ch>
  * Version 3.7
  * Allow running as non-root on Mac OS X by using non-privileged ICMP (#7)
  * Remove unnecessary IPv6 socket options
  * Fix again compatibility issue with FreeBSD (Shawn Chu)
  * Fix fping hanging forever on permanent sendto failure (Shawn Chu)
  * Fix duplicate echo reply packets causing early stop in count mode
    (reported by Ramon Schwammberger, #53)

2013-10-10  David Schweikert  <david@schweikert.ch>
  * Version 3.6
  * Fix loop issue after 65536 pings (reported by Peter Folk and GBert, #12)
  * Minimum ping data size is now 0
  * Removed setsockopt IPV6_CHECKSUM, which shouldn't be set and breaks
    compiling on Solaris (reported by Juergen Arndt)
  * Fix wrong min RTT value with -Q option (reported by Alexander Ivanov,
  * #51)

2013-05-22  David Schweikert  <david@schweikert.ch>
  * Version 3.5
  * Fix sprint_tm buffer size crash (reported by Japheth Cleaver)
  * Addded -D flag to print timestamps (Toke H�iland-J�rgensen)
  * Fix fping6 build on OS X 10.8 (unknown contributor)
  * Fix compatibility issue with FreeBSD (Alexandre Raynaud, Jason Harris,
  * #39)
  * Fping.spec: fix setuid permissions and provides fping6 (Marcus Vinicius
  * Ferreira)
  * Re-create configure script with autoconf 2.69 for aarch64 support (Chuck
  * Anderson, #45)

2012-09-04  David Schweikert  <david@schweikert.ch>
  * Version 3.4
  * Revert "Output statistics to stdout instead of stderr", because it
  * breaks
    tools assuming the output goes to stderr

2012-08-19  David Schweikert  <david@schweikert.ch>
  * Version 3.3
  * Do not output icmp errors with -q (#1)
  * Add --enable-ipv4 and --enable-ipv6 options to configure (Niclas
  * Zeising)
  * Fix removing of unreachable hosts when doing loop (Thomas Liske, #13
  * #23)
  * Fix -A for fping6 (reported by Matt LaPlante, #14)
  * Fix "options inet6" breaking IPv4 name resolution (reported by Matt
  * LaPlante, #17)
  * Output statistics to stdout instead of stderr (suggested by Simon
  * Leinen, #9)
  * Set default data size to 56 bytes on all architectures (#18)
  * Added contrib/fping.spec (Stephen Schaefer, #24)
  * Convert man-page source to POD for easier maintenance
  * Fix error message on DNS error for IPv6 hosts (#27)
  * Fix -n flag in fping6 (#28)
  * Man-page fix: TOS option typo (Thomas Liske, #23)
  * Man-page fix: inconsistency in regards to numeric arguments (Robert
  * Henney)
  * Man-page fix: better description of option -q (#15)

2012-05-29  David Schweikert  <david@schweikert.ch>
  * Version 3.2
  * Improve documentation for -g option (G.W. Haywood)
  * Performance optimization for big select timeouts (#10, Andrey
  * Bondarenko)
  * Fix restart of select call after interrupt signal (#8, Boian Bonev)
  * Fix infinite loop caused by linked list corruption (#11, Boian Bonev)

2012-04-26  David Schweikert  <david@schweikert.ch>
  * Version 3.1
  * -g option (generate): exclude network and broadcast address for cidr
    ranges (idea by Eric Brander)
  * do not explicitely check if running as root, to make it possible to
    install fping with linux capabilities instead of making it setuid
    (setcap cap_net_raw+ep fping)
  * ANSI C (C89) compiler now a requirement
  * Portability fixes
  * Reorganized source directory
  * Bugfix: fix timeout issue on Solaris (Sandor Geller)
  * Man-page fixes (Axel Beckert)
  * Added -H option to specify number of hops (Paul Duda)
  * Output usage information to stdout when called with -h (Paul Duda)

2011-12-28  David Schweikert  <david@schweikert.ch>
  * Version 3.0
  * rewritten main loop for improved performance
  * -T parameter (select timeout) now obsolete
  * Maintenance taken over from unresponsive previous maintainer
    (anybody please step up, if you disagree)
  * New homepage: www.fping.org

2009-12-21  Tobi Oetiker  <tobi@oetiker.ch>
  * Version v2.4b2-to3-ipv6
  * added -On option to set the TOS octet
  * Removed unused variables from code
  * updated to current autoconf standards
  * Merged Debian changes (see below)

----------------------------------------------------------------------

fping (2.4b2-to-ipv6-16.1) unstable; urgency=low

  * NMU during Moenchengladbach BSP
  * Fixes FTBFS on kfreebsd (Closes: #555398)
  * Fixes typo "Paramter" in binary

 -- Axel Beckert <abe@deuxchevaux.org>  Sat, 23 Jan 2010 16:22:02 +0100

fping (2.4b2-to-ipv6-16) unstable; urgency=low

  * Fix the following bugs
    - Network byte order sensitivity was missing completely.
      Added hopefully all missing calls.
    - The sequence numbering scheme used led to packet drops.
      Changed it to a more senseful numbering scheme.
    - Some minor C programming mistakes ('=' instead of '==').
    Patch by Stephan Fuhrmann; closes: #502569
  * Add support for command line select timeout setting
    Patch by Marton Balint; closes: #502575
  * Remove symlinks in /usr/sbin; closes: #377732
  * Standards-Version is 3.8.0

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sat, 18 Oct 2008 12:04:52
 -- +1100

fping (2.4b2-to-ipv6-15) unstable; urgency=low

  * Added interface binding (-I) for fping
    Patch by Peter Naulls <peter@mushroomnetworks.com>
    Closes: #439014
  * Fixed a couple of typos in fping.8. Closes: #423180
  * Added homepage control header
  * Bumped Standards-Version to 3.7.3
  * Fixed the following lintian issue:
    - debian-rules-sets-DH_COMPAT

 -- Anibal Monsalve Salazar <anibal@debian.org>  Mon, 03 Mar 2008 17:46:17
 -- +1100

fping (2.4b2-to-ipv6-13) unstable; urgency=low

  * Fixed stdout flush problem, closes: #340146.
    Patch by Bart Martens <bart.martens@advalvas.be>.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Fri, 30 Dec 2005 08:30:09
 -- +1100

fping (2.4b2-to-ipv6-12) unstable; urgency=low

  * Fixed "problem with option -r (retry limit)", closes: #318402.
    Patch by Qingning Huo <qingningh@lanware.co.uk>.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sat, 08 Oct 2005 21:26:35
 -- +1000

fping (2.4b2-to-ipv6-11) unstable; urgency=low

  * Fixed "would be useful to specify 'source address' like ping for multi
    homed machines", closes: #198486.
    Patch by Marc Haber <mh+debian-bugs@zugschlus.de>.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Thu, 02 Jun 2005 08:14:54
 -- +1000

fping (2.4b2-to-ipv6-10) unstable; urgency=low

  * Fixed "unnecessary delay with the -c option after the last packet"
    (Closes: #293856). Patch by Niko Tyni <ntyni@iki.fi>

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sun, 06 Feb 2005 23:25:57
 -- +1100

fping (2.4b2-to-ipv6-9) unstable; urgency=low

  * Fixed "fping6 always does reverse lookup" (Closes: #273647).
    Patch by Jeroen Massar and forwarded by Bernhard Schmidt
<berni@birkenwald.de>

 -- Anibal Monsalve Salazar <A.Monsalve.Salazar@IEEE.org>  Mon, 10 Jan 2005
 -- 00:01:32 +1100

fping (2.4b2-to-ipv6-7) unstable; urgency=low

  * Build fping in build/ipv[46] instead of build and build-ipv6.
  * Made DNS errors non-fatal for IPv6 (closes: #198056).

 -- Herbert Xu <herbert@debian.org>  Fri, 20 Jun 2003 21:36:30 +1000

fping (2.4b2-to-ipv6-6) unstable; urgency=low

  * Do not use incorrect linux.h file (closes: #85468).

 -- Herbert Xu <herbert@debian.org>  Sat, 17 May 2003 14:13:11 +1000

fping (2.4b2-to-ipv6-5) unstable; urgency=low

  * Fixed yet another divide by zero bug (closes: #148445).

 -- Herbert Xu <herbert@debian.org>  Tue,  4 Jun 2002 12:18:03 +1000

fping (2.4b2-to-ipv6-4) unstable; urgency=low

  * Made fping6 setuid (closes: #136386).
  * Moved fping back into bin.
  * Partially applied IPv6 patch to fix IPv6 checksums (closes: #136479).

 -- Herbert Xu <herbert@debian.org>  Sun,  7 Apr 2002 20:36:56 +1000

fping (2.4b2-to-ipv6-3) unstable; urgency=low

  * Added compatibility symlink for fping (closes: #135203).

 -- Herbert Xu <herbert@debian.org>  Sat, 23 Feb 2002 08:34:11 +1100

fping (2.4b2-to-ipv6-2) unstable; urgency=low

  * Fixed another divide by zero error (closes: #132370).

 -- Herbert Xu <herbert@debian.org>  Thu,  7 Feb 2002 20:10:48 +1100

fping (2.4b2-to-ipv6-1) unstable; urgency=low

  * New upstream release.
  * Install fping into sbin as done by upstream.
32f31e7
@jperkin jperkin pushed a commit that referenced this issue Jun 2, 2014
sborrill Update to fping 3.10.
Changes:
2014-05-03  David Schweikert  <david@schweikert.ch>
  * Version 3.10
  * Fix confusing error message with -g and IPv6 addresses (#58, reported by
  * Axel Beckert)
  * Allow option '-f' also for non-root (since setuid privileges are
  * dropped)
  * Do not retry twice DNS lookup on DNS lookup problem
  * Remove support for NIS groups
  * Better document -B backoff-factor and when it can be used (#33, Oleksiy
  * Zagorskyi)
  * More tests added

2014-03-08  David Schweikert  <david@schweikert.ch>
  * Version 3.9
  * Fix random output on socket error (reported by Aleksandrs Saveljevs,
  * #56)
  * Support ppc64le architecture by including alpha libtool version
    (reported by Amit Kumar Gupta and Aravinda B Thunug)
  * Fix compilation problem on FreeBSD (#57)
  * Initial test suite and continous intergration (with travis-ci.org /
  * coveralls.io)
  * Don't output usage information on error

2013-11-08  David Schweikert  <david@schweikert.ch>
  * Version 3.8
  * Fix segmentation fault introduced in version 3.7 with loop mode
  * (reported
    by Vlad Glagolev, #55)

2013-11-04  David Schweikert  <david@schweikert.ch>
  * Version 3.7
  * Allow running as non-root on Mac OS X by using non-privileged ICMP (#7)
  * Remove unnecessary IPv6 socket options
  * Fix again compatibility issue with FreeBSD (Shawn Chu)
  * Fix fping hanging forever on permanent sendto failure (Shawn Chu)
  * Fix duplicate echo reply packets causing early stop in count mode
    (reported by Ramon Schwammberger, #53)

2013-10-10  David Schweikert  <david@schweikert.ch>
  * Version 3.6
  * Fix loop issue after 65536 pings (reported by Peter Folk and GBert, #12)
  * Minimum ping data size is now 0
  * Removed setsockopt IPV6_CHECKSUM, which shouldn't be set and breaks
    compiling on Solaris (reported by Juergen Arndt)
  * Fix wrong min RTT value with -Q option (reported by Alexander Ivanov,
  * #51)

2013-05-22  David Schweikert  <david@schweikert.ch>
  * Version 3.5
  * Fix sprint_tm buffer size crash (reported by Japheth Cleaver)
  * Addded -D flag to print timestamps (Toke H�iland-J�rgensen)
  * Fix fping6 build on OS X 10.8 (unknown contributor)
  * Fix compatibility issue with FreeBSD (Alexandre Raynaud, Jason Harris,
  * #39)
  * Fping.spec: fix setuid permissions and provides fping6 (Marcus Vinicius
  * Ferreira)
  * Re-create configure script with autoconf 2.69 for aarch64 support (Chuck
  * Anderson, #45)

2012-09-04  David Schweikert  <david@schweikert.ch>
  * Version 3.4
  * Revert "Output statistics to stdout instead of stderr", because it
  * breaks
    tools assuming the output goes to stderr

2012-08-19  David Schweikert  <david@schweikert.ch>
  * Version 3.3
  * Do not output icmp errors with -q (#1)
  * Add --enable-ipv4 and --enable-ipv6 options to configure (Niclas
  * Zeising)
  * Fix removing of unreachable hosts when doing loop (Thomas Liske, #13
  * #23)
  * Fix -A for fping6 (reported by Matt LaPlante, #14)
  * Fix "options inet6" breaking IPv4 name resolution (reported by Matt
  * LaPlante, #17)
  * Output statistics to stdout instead of stderr (suggested by Simon
  * Leinen, #9)
  * Set default data size to 56 bytes on all architectures (#18)
  * Added contrib/fping.spec (Stephen Schaefer, #24)
  * Convert man-page source to POD for easier maintenance
  * Fix error message on DNS error for IPv6 hosts (#27)
  * Fix -n flag in fping6 (#28)
  * Man-page fix: TOS option typo (Thomas Liske, #23)
  * Man-page fix: inconsistency in regards to numeric arguments (Robert
  * Henney)
  * Man-page fix: better description of option -q (#15)

2012-05-29  David Schweikert  <david@schweikert.ch>
  * Version 3.2
  * Improve documentation for -g option (G.W. Haywood)
  * Performance optimization for big select timeouts (#10, Andrey
  * Bondarenko)
  * Fix restart of select call after interrupt signal (#8, Boian Bonev)
  * Fix infinite loop caused by linked list corruption (#11, Boian Bonev)

2012-04-26  David Schweikert  <david@schweikert.ch>
  * Version 3.1
  * -g option (generate): exclude network and broadcast address for cidr
    ranges (idea by Eric Brander)
  * do not explicitely check if running as root, to make it possible to
    install fping with linux capabilities instead of making it setuid
    (setcap cap_net_raw+ep fping)
  * ANSI C (C89) compiler now a requirement
  * Portability fixes
  * Reorganized source directory
  * Bugfix: fix timeout issue on Solaris (Sandor Geller)
  * Man-page fixes (Axel Beckert)
  * Added -H option to specify number of hops (Paul Duda)
  * Output usage information to stdout when called with -h (Paul Duda)

2011-12-28  David Schweikert  <david@schweikert.ch>
  * Version 3.0
  * rewritten main loop for improved performance
  * -T parameter (select timeout) now obsolete
  * Maintenance taken over from unresponsive previous maintainer
    (anybody please step up, if you disagree)
  * New homepage: www.fping.org

2009-12-21  Tobi Oetiker  <tobi@oetiker.ch>
  * Version v2.4b2-to3-ipv6
  * added -On option to set the TOS octet
  * Removed unused variables from code
  * updated to current autoconf standards
  * Merged Debian changes (see below)

----------------------------------------------------------------------

fping (2.4b2-to-ipv6-16.1) unstable; urgency=low

  * NMU during Moenchengladbach BSP
  * Fixes FTBFS on kfreebsd (Closes: #555398)
  * Fixes typo "Paramter" in binary

 -- Axel Beckert <abe@deuxchevaux.org>  Sat, 23 Jan 2010 16:22:02 +0100

fping (2.4b2-to-ipv6-16) unstable; urgency=low

  * Fix the following bugs
    - Network byte order sensitivity was missing completely.
      Added hopefully all missing calls.
    - The sequence numbering scheme used led to packet drops.
      Changed it to a more senseful numbering scheme.
    - Some minor C programming mistakes ('=' instead of '==').
    Patch by Stephan Fuhrmann; closes: #502569
  * Add support for command line select timeout setting
    Patch by Marton Balint; closes: #502575
  * Remove symlinks in /usr/sbin; closes: #377732
  * Standards-Version is 3.8.0

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sat, 18 Oct 2008 12:04:52
 -- +1100

fping (2.4b2-to-ipv6-15) unstable; urgency=low

  * Added interface binding (-I) for fping
    Patch by Peter Naulls <peter@mushroomnetworks.com>
    Closes: #439014
  * Fixed a couple of typos in fping.8. Closes: #423180
  * Added homepage control header
  * Bumped Standards-Version to 3.7.3
  * Fixed the following lintian issue:
    - debian-rules-sets-DH_COMPAT

 -- Anibal Monsalve Salazar <anibal@debian.org>  Mon, 03 Mar 2008 17:46:17
 -- +1100

fping (2.4b2-to-ipv6-13) unstable; urgency=low

  * Fixed stdout flush problem, closes: #340146.
    Patch by Bart Martens <bart.martens@advalvas.be>.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Fri, 30 Dec 2005 08:30:09
 -- +1100

fping (2.4b2-to-ipv6-12) unstable; urgency=low

  * Fixed "problem with option -r (retry limit)", closes: #318402.
    Patch by Qingning Huo <qingningh@lanware.co.uk>.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sat, 08 Oct 2005 21:26:35
 -- +1000

fping (2.4b2-to-ipv6-11) unstable; urgency=low

  * Fixed "would be useful to specify 'source address' like ping for multi
    homed machines", closes: #198486.
    Patch by Marc Haber <mh+debian-bugs@zugschlus.de>.

 -- Anibal Monsalve Salazar <anibal@debian.org>  Thu, 02 Jun 2005 08:14:54
 -- +1000

fping (2.4b2-to-ipv6-10) unstable; urgency=low

  * Fixed "unnecessary delay with the -c option after the last packet"
    (Closes: #293856). Patch by Niko Tyni <ntyni@iki.fi>

 -- Anibal Monsalve Salazar <anibal@debian.org>  Sun, 06 Feb 2005 23:25:57
 -- +1100

fping (2.4b2-to-ipv6-9) unstable; urgency=low

  * Fixed "fping6 always does reverse lookup" (Closes: #273647).
    Patch by Jeroen Massar and forwarded by Bernhard Schmidt
<berni@birkenwald.de>

 -- Anibal Monsalve Salazar <A.Monsalve.Salazar@IEEE.org>  Mon, 10 Jan 2005
 -- 00:01:32 +1100

fping (2.4b2-to-ipv6-7) unstable; urgency=low

  * Build fping in build/ipv[46] instead of build and build-ipv6.
  * Made DNS errors non-fatal for IPv6 (closes: #198056).

 -- Herbert Xu <herbert@debian.org>  Fri, 20 Jun 2003 21:36:30 +1000

fping (2.4b2-to-ipv6-6) unstable; urgency=low

  * Do not use incorrect linux.h file (closes: #85468).

 -- Herbert Xu <herbert@debian.org>  Sat, 17 May 2003 14:13:11 +1000

fping (2.4b2-to-ipv6-5) unstable; urgency=low

  * Fixed yet another divide by zero bug (closes: #148445).

 -- Herbert Xu <herbert@debian.org>  Tue,  4 Jun 2002 12:18:03 +1000

fping (2.4b2-to-ipv6-4) unstable; urgency=low

  * Made fping6 setuid (closes: #136386).
  * Moved fping back into bin.
  * Partially applied IPv6 patch to fix IPv6 checksums (closes: #136479).

 -- Herbert Xu <herbert@debian.org>  Sun,  7 Apr 2002 20:36:56 +1000

fping (2.4b2-to-ipv6-3) unstable; urgency=low

  * Added compatibility symlink for fping (closes: #135203).

 -- Herbert Xu <herbert@debian.org>  Sat, 23 Feb 2002 08:34:11 +1100

fping (2.4b2-to-ipv6-2) unstable; urgency=low

  * Fixed another divide by zero error (closes: #132370).

 -- Herbert Xu <herbert@debian.org>  Thu,  7 Feb 2002 20:10:48 +1100

fping (2.4b2-to-ipv6-1) unstable; urgency=low

  * New upstream release.
  * Install fping into sbin as done by upstream.
49915f0
@jperkin jperkin pushed a commit that referenced this issue Jul 23, 2014
schmonz Update to 3.24. From the changelog:
* Remove SvREFCNT_dec_NN until it can be implemented
  properly.
  (Thanks to bulk88 for reporting GH #10)
* Fix GH #11 - compiler warning under clang
  (Thanks to jhi for reporting it)
* Fix GH #12 - compiler warnings
  (Thanks to jhi for reporting it)
* Add support for HeUTF8
* Add GetFileContents() to retrieve the contents of the
  ppport.h file
* Update MAX_VER to be 5.20
* Update issue tracker to GitHub
* Add support for the following API
    SvREFCNT_dec_NN
    mg_findext
    sv_unmagicext
* Update META
    Move bug tracker to github
    Provide link to repository
* Avoid syntax disallowed by C++11
  (Thanks to Tony C for the patch)
* Fix cpan #87870: Merge core perl commit 90b0dc0e2e
  (Thanks to Father Chrysostomos for the original patch and
   to Steve Hay for forwarding it)
* Fix cpan #86975: Deterministically order API elements in POD
  (Thanks to Karl Williamson for providing a patch.)
* Fix cpan #81796: my $_ is deprecated
  (Thanks to Nicholas Clark for providing a patch)
* Fix cpan #81484: fix isASCII and isCNTRL for inputs > 255
  (Thanks to Karl Williamson for providing a patch)
* Fix cpan #80314: make use of PERL_NO_GET_CONTEXT the default
* Fix cpan #79814: Install to 'site' for perl 5.11+
  (Thanks to Robert Sedlacek for providing a patch)
* Fix cpan #78271: Need SvPV_nomg_nolen
* Adapt buildperl.pl for newer Perl releases
* Update masked_versions regex for 5.005 thread builds
* Some tweaks needed to support 5.003 on 64-bit platforms
0b67515
@jperkin jperkin pushed a commit that referenced this issue Aug 12, 2014
szptvlfn Update to 0.10.9
CHANGES:
0.10.9
    #10, fix versionArgs (broken in 0.10.8)
0.10.8
    Avoid compilation warnings on GHC 7.8
    #9, add --numeric-version flag
    Update the copyright year
    Change GetOpt.usageInfo to be more like GetOpt
c00c629
@jperkin jperkin pushed a commit that referenced this issue Sep 3, 2014
wiz Update to 1.2:
Version 1.2 -- August 26, 2014
==============================

 - Fixed compilation with neither libswresample nor libavresample (#11)
 - Fixed compilation with static libav (#10)
 - Functions chromaprint_encode_fingerprint and chromaprint_decode_fingerprint
   are changed to accept const pointer as input
 - Added support for using the Kiss FFT library (should make Android port easier)
 - Removed obsolete dev tools from the package
 - More compatible DEBUG() macro
758de3b
@jperkin jperkin pushed a commit that referenced this issue Dec 1, 2014
wiz Update to 0.8.1. Add comment to patch.
Sigil 0.8.1 2014.10.12
- Set minimum OS X version to 10.9.0 in Info.plist so users trying to
  run on older versions of OS X will receive an error dialog instead of
  a crash dialog.
- Set minimum Windows version to Vista in Installer so installation will
  error when trying to install on XP (which is not supported and Sigil
  binary packages won't run on).
- Fix issue #21: Use Hunspell WORDCHARS to help in tokenization of words.
- Pull request #19: Moving plugin description to ToolTips.
- Pull request #20: Preserve current file name for future save as actions
  if appropriate.
- Fix bug where save after using input plugin would fail.

Sigil 0.8.0 2014.09.27
- Plugin framework.
- Add the svg image tag as an svg inline element (not a block element) and
  add it as an empty element (TidyEmptyTags).
- Allow user defined list of entities to preserve.
- Pull request #16: Hardcode menu Plugins in UI, move it before menu Help.
- Pull request #10: Add ability to move entries in TOC up and down.
- Pull request #8: Allow pasting HTML as HTML or plain text in BookView.
d704993
@jperkin jperkin pushed a commit that referenced this issue Apr 28, 2015
mef Update 0.9.3 to 0.9.7
---------------------
Version 0.9.7 - for a detailed log and changed files visit GitHub
----------------------------
- Reviewed and updated README
- Huge POD rewrite
- Adding a small script that generates HTML from POD and applies CSS from
  CPAN. Useful for reviewing the POD before release.
- Added a test for POD validation
- Added an example file that can test GitHub Issues #8, #9, #10
- GitHub [Issue #9] [Issue #10] Fixed cell_props applied to a different
  row when 'Repeat Headers' is enabled
- Introduced column_numbers variable to avoid using $record in a broader
  scope. Further improvement needed.
- Header row height is copied to each new page when 'Repeat Headers' is
  enabled
- Fixed messing up row height when repeat headers is enabled due to
  access by array index vs shift/unshift
- Fixed row height for rows with text blocks
- Headers_props variable has been wrongly initialised with 0 causing a
  copy of the first data row even when header props are not passed as
  parameter
- Added initialisation of header props justify param so that column and
  cell properties are not affecting the default value.
- Fixed an issue with messing up row properties when repeating the header
  row on each page.
- Examples have been formatted.
- One new example added (header.pl) for demonstrating how header row can
  be added to multiple pages.
- No need to export variables. Added one more test.
- Removed pad_w and pad_h local variable as useless
- Fixed typo causing a bug with row_height param.  Added example file for
  row_height. To be used for writing a test.
- Added POD for row_height param
- Row counting should not be skipped if it is first row.
- Added one more test(duplicates existing) but only to have base.
- Extracted PDF::API2 Mock as a separate package.  Created New test with
  the very basics.  Create a new package that will hold predefined data
  for tests so it can be reused.
- Fixed a variable that masks earlier declaration.
- Fixed Issue #4 - Row height is calculated correctly depending on font
  size.  Some variables are renamed to more meaningful.  Row counting is
  done in a new way with single counter that is used for column and cell
  props retrieval.
- Row height is now calculated for each row based on maximum font size
  from all cells.  Refactored some variable names and unified row
  counting during column size calculation phase.
- Fixed doc details in POD
- Cosmetic changes
- Decreased indent and reduced if body.  For easier review, diff with
  whitespace changes disabled.
- Added github url in readme

Version 0.9.6
----------------------------
- Fixed typo in POD. Closes #71816 Thanks to Gregor Herrmann
- Small code refactoring.
- Added patch for infinite loop fix. Closes #77376 Thanks to John Bazik
- Added patch for header justification. Closes #77566 Thanks to James
   Lance
- Added horizontal_borders, vertical_borders params to table(). Closes
  #79883 Thanks to Eric Johnson

Version 0.9.5 - 18.Oct.2011
----------------------------
- MANIFEST was missing sample pdf file.
- Accidently left alternative code for infinite loop fix commented out.
  Fixed.  Added a test for that.

Version 0.9.4 - 17.Oct.2011
----------------------------
- Don't bump row count when row spans a page.  Closes #67401.
- Fixed bug: don't call text_block if record width is exactly cell width.
- Fixed bug in text_block: bottom is (top - height), not (baseline - height).
- Example script typo fixed.  Closes #55133.
- Don't set up strokes when border is 0.  Apparently breaks Acrobat.
  Closes #40705 and #55137.
- Changed print warnings to carp.  Closes #38007.
- Added center justification for columns and cells.  Tests, too.  Closes
  #37924.
- Fixed infinite loop caused by uninitialized $2.  Thanks to Petri
  Kaurinkoski.  Closes #34017.
- Fixed perl warning if $col_prop->{min_w} is undef.  Thanks to Matthias
  Pitzl (NEPOS).  Closes #30720.
- Fixed default header background color bug, closes #28542.
- Added mock PDF::API2 packages to test script and added tests.
- Improve column width calculations so wider content gets wider columns.
  Added column width test.  Thanks to Barrie Slaymaker (RBS).  Closes
  #26158.
ff9f192
@jperkin jperkin pushed a commit that referenced this issue May 21, 2015
mef Update 0.20 to 0.23
-------------------
0.23
  - fix test error on Windows due to the use of
    unescaped paths in regex patterns (by nanis) #11 #13
0.22
  - fix regression in 0.21 (use of here-doc within `<?= ?>` causes syntax error) #12
  - add support for `prepend` property for prepending code (by LoonyPandora) #3

0.21
 - fix the strange rule for multi-line expression #10
764c43f
@jperkin jperkin pushed a commit that referenced this issue Aug 24, 2015
leot Update devel/libusb1 to libusb1-1.0.19.
ok wiz@.

pkgsrc changes:
* Delete a patch that is now imported upstream
* Add test target support

Changes:
2014-05-30: v1.0.19
* Add support for USB bulk streams on Linux and Mac OS X (#11)
* Windows: Add AMD and Intel USB-3.0 root hub support
* Windows: Fix USB 3.0 speed detection on Windows 8 or later (#10)
* Added Russian translation for libusb_strerror strings
* All: Various small fixes and cleanups
The (#xx) numbers are libusb issue numbers, see ie:
libusb/libusb#11

2014-01-25: v1.0.18
* Fix multiple memory leaks
* Fix a crash when HID transfers return no data on Windows
* Ensure all pending events are consumed
* Improve Android and ucLinux support
* Multiple Windows improvements (error logging, VS2013, VIA xHCI support)
* Multiple OS X improvements (broken compilation, SIGFPE, 64bit support)

2013-09-06: v1.0.17
* Hotplug callbacks now always get passed a libusb_context, even if it is
  the default context. Previously NULL would be passed for the default context,
  but since the first context created is the default context, and most apps
  use only 1 context, this meant that apps explicitly creating a context would
  still get passed NULL
* Android: Add .mk files to build with the Android NDK
* Darwin: Add Xcode project
* Darwin: Fix crash on unplug (#121)
* Linux: Fix hang (deadlock) on libusb_exit
* Linux: Fix libusb build failure with --disable-udev (#124)
* Linux: Fix libusb_get_device_list() hang with --disable-udev (#130)
* OpenBSD: Update OpenBSD backend with support for control transfers to
  non-ugen(4) devices and make get_configuration() no longer generate I/O.
  Note that using this libusb version on OpenBSD requires using
  OpenBSD 5.3-current or later. Users of older OpenBSD versions are advised
  to stay with the libusb shipped with OpenBSD (mpi)
* Windows: fix libusb_dll_2010.vcxproj link errors (#129)
* Various other bug fixes and improvements

2013-07-11: v1.0.16
* Add hotplug support for Darwin and Linux (#9)
* Add superspeed endpoint companion descriptor support (#15)
* Add BOS descriptor support (#15)
* Make descriptor parsing code more robust
* New libusb_get_port_numbers API, this is libusb_get_port_path without
  the unnecessary context parameter, libusb_get_port_path is now deprecated
* New libusb_strerror API (#14)
* New libusb_set_auto_detach_kernel_driver API (#17)
* Improve topology API docs (#95)
* Logging now use a single write call per log-message, avoiding log-message
  "interlacing" when using multiple threads.
* Android: use Android logging when building on Android (#101)
* Darwin: make libusb_reset reenumerate device on descriptors change (#89)
* Darwin: add support for the LIBUSB_TRANSFER_ADD_ZERO_PACKET flag (#91)
* Darwin: add a device cache (#112, #114)
* Examples: Add sam3u_benchmark isochronous example by Harald Welte (#109)
* Many other bug fixes and improvements
The (#xx) numbers are libusbx issue numbers, see ie:
https://github.com/libusbx/libusbx/issues/9

2013-04-15: v1.0.15
* Improve transfer cancellation and avoid short read failures on broken descriptors
* Filter out 8-bit characters in libusb_get_string_descriptor_ascii()
* Add WinCE support
* Add library stress tests
* Add Cypress FX3 firmware upload support for fxload sample
* Add HID and kernel driver detach support capabilities detection
* Add SuperSpeed detection on OS X
* Fix bInterval value interpretation on OS X
* Fix issues with autoclaim, composite HID devices, interface autoclaim and
  early abort in libusb_close() on Windows. Also add VS2012 solution files.
* Improve fd event handling on Linux
* Other bug fixes and improvements

2012-09-26: v1.0.14
* Reverts the previous API change with regards to bMaxPower.
  If this doesn't matter to you, you are encouraged to keep using v1.0.13,
  as it will use the same attribute as v2.0, to be released soon.
* Note that LIBUSB_API_VERSION is *decreased* to 0x010000FF and the previous
  guidelines with regards to concurrent use of MaxPower/bMaxPower still apply.

2012-09-20: v1.0.13
* [MAJOR] Fix a typo in the API with struct libusb_config_descriptor where
  MaxPower was used instead of bMaxPower, as defined in the specs. If your
  application was accessing the MaxPower attribute, and you need to maintain
  compatibility with libusb or older versions, see APPENDIX A below.
* Fix broken support for the 0.1 -> 1.0 libusb-compat layer
* Fix unwanted cancellation of pending timeouts as well as major timeout related bugs
* Fix handling of HID and composite devices on Windows
* Introduce LIBUSB_API_VERSION macro
* Add Cypress FX/FX2 firmware upload sample, based on fxload from
  http://linux-hotplug.sourceforge.net
* Add libusb0 (libusb-win32) and libusbK driver support on Windows. Note that while
  the drivers allow it, isochronous transfers are not supported yet in libusb. Also
  not supported yet is the use of libusb-win32 filter drivers on composite interfaces
* Add support for the new get_capabilities ioctl on Linux and avoid unnecessary
  splitting of bulk transfers
* Improve support for newer Intel and Renesas USB 3.0 controllers on Windows
* Harmonize the device number for root hubs across platforms
* Other bug fixes and improvements

2012-06-15: v1.0.12
* Fix a potential major regression with pthread on Linux
* Fix missing thread ID from debug log output on cygwin
* Fix possible crash when using longjmp and MinGW's gcc 4.6
* Add topology calls: libusb_get_port_number(), libusb_get_parent() & libusb_get_port_path()
* Add toggleable debug, using libusb_set_debug() or the LIBUSB_DEBUG environment variable
* Define log levels in libusb.h and set timestamp origin to first libusb_init() call
* All logging is now sent to to stderr (info was sent to stdout previously)
* Update log messages severity and avoid polluting log output on OS-X
* Add HID driver support on Windows
* Enable interchangeability of MSVC and MinGW DLLs
* Additional bug fixes and improvements

2012-05-08: v1.0.11
* Revert removal of critical Windows event handling that was introduced in 1.0.10
* Fix a possible deadlock in Windows when submitting transfers
* Add timestamped logging
* Add NetBSD support (experimental) and BSD libusb_get_device_speed() data
* Add bootstrap.sh alongside autogen.sh (bootstrap.sh doesn't invoke configure)
* Search for device nodes in /dev for Android support
* Other bug fixes

2012-04-17: v1.0.10
* Public release
* Add libusb_get_version
* Add Visual Studio 2010 project files
* Some Windows code cleanup
* Fix xusb sample warnings

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
APPENDIX A - How to maintain code compatibility with versions of libusb and
libusb that use MaxPower:

If you must to maintain compatibility with versions of the library that aren't
using the bMaxPower attribute in struct libusb_config_descriptor, the
recommended way is to use the new LIBUSB_API_VERSION macro with an #ifdef.
For instance, if your code was written as follows:

  if (dev->config[0].MaxPower < 250)

Then you should modify it to have:

#if defined(LIBUSB_API_VERSION) && (LIBUSB_API_VERSION >= 0x01000100)
  if (dev->config[0].bMaxPower < 250)
#else
  if (dev->config[0].MaxPower < 250)
#endif
2d7bff2
@jperkin jperkin pushed a commit that referenced this issue Sep 3, 2015
mef Update 2.46 to 2.49
-------------------
2.49     2015-08-21
- The Screen output now enables autoflush on the handle it uses to send output
  to STDOUT or STDERR every time it sends a message. This does not affect the
  global STDOUT or STDERR, as the Screen module makes its own handle for
  output. This fixes a bug reported by Karen Etheridge that caused this module
  to not play nicely with Capture::Tiny in some cases. RT #106605.

2.48     2015-08-07
- Fixed (I hope) tests that were added in the last release that fail on
  Windows.

2.47     2015-08-06
- Really, really make per-thread locking work. Depending on when threads and
  threads::shared were loaded, you might get an error like 'Type of arg 1 to
  threads::shared::share must be one of $@% at .../Log/Dispatch/Syslog.pm line
  67, near "$thread_lock)"'. Reported by David Schweikert.

- Added support for auth-related parameters and replyto to
  Log::Dispatch::Email::MailSender. Implemented by Rohan Carly. Based on
  GitHub #10.

- Added a utf8 flag for Log::Dispatch::Screen. If this is true, then it sets
  the ":encoding(UTF-8)" flag on the handle it uses for output (without
  affecting STDOUT or STDERR elsewhere). Suggested by Ivan Baidakou.
977a67c
@jperkin jperkin pushed a commit that referenced this issue Sep 6, 2015
leot Update www/liferea to liferea-1.10.16.
pkgsrc changes:
 * Now liferea depends on www/webkit24-gtk3 (and x11/gtk3)
 * Update DESCR, MASTER_SITES, HOMEPAGE

Changes:
2015-06-19  Lars Windolf <lars.windolf@gmx.de>
	Version 1.10.16
	* Fixes Github #180: Removing item from (v)folder marks all read
	  (reported by GreenLunar)
	* Fixes Github #140, #158: Vertical pane placement is forgotten.
	  (patch by foresto)
	* Fixes Github #182: Missing config.h include in date.c
	  (reported by Paul Gevers)

2015-04-20  Lars Windolf <lars.windolf@gmx.de>
	Version 1.10.15
	* Fixes launching URLs in Firefox 36+
	  (reported by Geoffrey Leach)
	* Fixes Github #30: Segfault after updating from 1.8 to 1.10
	  (reported by vakuum)
	* Improves Github #36, #113: UI lock up during refresh
	  (suggested by mozbugbox)
	* Fixes typo in Italian translation.

2015-02-26   Lars Windolf <lars.windolf@gmx.de>
	Version 1.10.14
	* Fixes Github #154: Crashes while starting (on corrupt icon)
	  (reported by jcamposz)
	* Fixes Github #134: Broken default news feed.
	  (reported by pvdl)
	* Fixes Github #122: Crashes at launch, "segmentation fault"
	  (reported by geoffm)
	* Fixes some memory leaks
	  (patch by Rich Coe)
	* Fixes Github #145: Wrong method triggered on 'Launch External'
	  (patch by mozbugbox)
	* Fixes Github #149: Fixes a random crash on startup
	  (patch by mozbugbox)
	* Fixes all issues reported by Coverity scan

2015-01-07   Lars Windolf <lars.windolf@gmx.de>
	Version 1.10.13
	* Fixes Github #112: Wrapping issue in folder display
	  (reported by Jeff Fortin)
	* Fixes Github #114: Avoid termination on UTF-8 validation error
	* Fixes Github #132: Broken link in documentation
	  (reported by kallus)

2014-10-14   Lars Windolf <lars.windolf@gmx.de>
	Version 1.10.12
	* Fixes Github #86: Support HTTP content negotiation
	  (suggested by DanMan)
	* Fixes Github #98:  Stop calling Atom person constructs w/ URI invalid
	  (patch by Aristotle Pagaltzis)
	* Fixes Github #100: Problems with dark Adwaita theme in GTK 3.14
	  (reported by majutsushi)

2014-08-24   Lars Windolf <lars.windolf@gmx.de>
	Version 1.10.11
	* Fixes Github #53: Doesn't automatically update feed name and favicon
	  for new feed (reported by asl97)
	* Fixes Github #67: Missing dist files for documentation
	  (patch by Mikel Olasagasti)
	* Fixes Javascript links not opening in new browser tabs
	* Updated French translation (Guillaume Bernard)
	* Updated Hebrew translation (Genghis Khan)

2014-07-20   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.10
	* Fixes Github #26: RTL comments appear incorrectly
	  (reported by yaronf)
	* Fixes Github #21: No notifications for Tiny Tiny RSS feeds
	  (reported by simontunnat)

2014-04-21   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.9
	* Fixes Github #19: non void function should return value
	  (reported by kwm81)
	* Fixes SF #1141: Liferea does not update feeds with TinyTinyRSS
	  (reported by Dominik Grafenhofer, denk_mal, Fabian Henze)
	* Fixes SF #1150: subscription prop/source: not all fields and
	  buttons visible (reported by David Smith)

2014-03-26   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.8
	* Fixes Github #13: Parsing errors not visible with dark themes
	  (reported by Steve Kelly)
	* Fixes SF #1137, #1142: startup race with LifereaHtmlView
	  (reported by Yanko Kaneti)

2014-03-17   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.7
	* Make Liferea use ETags and send If-None-Match
	  (patch by Chris Siebenmann)

2014-02-24   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.6
	* Fixes SF #1135: liferea-add-feed doesn't process feed:https//
	  (patch by Kevin Walke)
	* Fixes SF #1137: crash on startup in enclosure_list_view_load
	  (reported in Redhat #1048499, Fedora #214888)

2014-01-15   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.5
	* Fixes #1056, #1089, #1098: Honor preferences when opening links
	  (patch by Daniel Seither)
	* Fixes SF #1096: missing installation of liferea.convert file
	  (reported by stqn)
	* Fixes Redhat #947358: popup notification only for new items
	  (patch by Fabrice Bellet)

2014-01-13   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.4
	* Fixes SF #1123: Mistakenly claims "TinyTinyRSS source is not self-updating"
	  (reported by Dominik Grafenhoher)
	* Fixes SF #1119: Crash on font resize at startup.
	  (reported by David Smith)
	* Fixes #1117: Selecting last unread item in reduced feed list jumps to next feed
	  (reported by Bruce Guenter)
	* Updated Arabic translation (Khaled Hosny)

2013-10-08   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.3
	* Asking for credentials again if TinyTinyRSS login fails
	* Asking for TinyTinyRSS credentials only 3 times
	* Checking wether TinyTinyRSS base URL is lost
	* Added warning on TinyTinyRSS login when source is not self-updating
	* "--debug-net --debug-verbose" now traces POST data
	* Patch #230 Add GNOME AppData XML (Mikel Olasagasti)
	* Updated Italian translation (Gianvito Cavasoli)
	* Updated Italian localized feed list (Gianvito Cavasoli)

2013-09-05   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.2
	* Patch SF #222: Make media player seekable
	  (Simon Kågedal Reimer)
	* Fixes SF #1102: Spelling error in man page
	  (David Smith)
	* Fixes SF #1104: liferea.desktop missing keywords
	  (David Smith)
	* Fixes SF #1105: Start Minimized to Tray Does Not Work
	  (reported by bitlord)
	* Fixes SF #1114: Crashes opening browser on item without link via popup
	  (reported by Rich Coe, David Smith)
	* Improved handling of broken Atom author information.
	  (Lars Windolf)
	* Removed dead Google Reader code to avoid doing requests to Google.
	  Replaced with dummy source that even allows normal feed updates.
	  (Lars Windolf)
	* Added hint to FAQ on how to workaround broken Flash support
	  (Lars Windolf)
	* Dumping feedlist.opml with indentation for readability.
	  (suggested by Christoph Temmel and Simon Kågedal Reimer)

2013-07-28   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.1a
	* Fixes SF #1102: Liferea does not show a window
	  (reported by genodeftest)

2013-07-28   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.1
	* Fixes SF #1059: Liferea crashes with system proxy enabled
	  (reported by genodeftest)
	* Fixes SF #1095: Theme color detection bug / white fonts.
	  (reported by David Smith and others)
	* Fixes SF #1097: Default feed refresh interval cannot be set to 0
	  (reported by stqn)
	* Fixes SF #1100: --debug-gui crashes with segmentation fault
	  (reported by genodeftest)
	* Fixes SF #1101: Outdated manpage
	  (reported by genodeftest)
	* Patch SF #225: Make media player work with GStreamer 1.0
	  (Simon Kågedal Reimer)
	* Patch SF #226: Add trailing semi-colon to MimeType so that the desktop
	  file validates (Yanko Kaneti)
	* Patch SF #227: Remove letfover square bracket configure.ac
	  (Yanko Kaneti)
	* Patch SF #228: Add net.sf.liferea.gschema.xml to AC_CONFIG_FILES
	  (Yanko Kaneti)

2013-07-10   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10.0
	* Added experimental sync support for TheOldReader
	  (Lars Windolf)
	* Removed 'Update' link in comments display as it is pretty useless
	  (Lars Windolf)
	* Removed 'No Comments' display as it is rather useless
	  (Lars Windolf)
	* Prevent re-rendering item display on setting item flagged
	  (Lars Windolf)
	* Changed unread number rendering to be right bound and non-ellipsized
	  (Lars Windolf)
	* Fixes g_strstr_len assertions caused by search folder item matching
	  (Rich Coe)
	* Updated documentation to reflect Google Reader, TheOldReader changes
	  (Lars Windolf)
	* Removed welcome text, restoring last feed/item selection instead
	  (Lars Windolf)
	* autogen.sh now reports errors on missing autoconf or intltool
	  (suggested by Scott Kostyshak)
	* Correctly check for gobject-introspection build dependency
	  (suggested by Scott Kostyshak)
	* Updated Basque translation (Mikel Olasagasti Uranga)
	* Updated Danish translation (Joe Hansen)
	* Updated Dutch translation (Erwin Poeze)
	* Updated Finnish translation (Jorma Karvonen)
	* Updated Russian translation (Leonid Selivanov)
	* Updated Ukrainian translation (Yuri Chornoivan)
	* Updated Vietnamese translation (Trần Ngọc Quân)
	* Updated German translation (Lars Windolf)

2013-05-22   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10-RC4
	* Added an option to convert Google Reader subscriptions
	  to local feeds (Lars Windolf)
	* Fixes SF #1080: segfault opening attachment due to incorrect g_free()
	  (reported by Adam Nielsen)
	* Fixes SF #1075: GLib warnings of "string != NULL" assertion failure
	  (reported by Simon Kågedal Reimer)
	* Fixes missing shading in 2-pane mode rendering
	  (reported by Zoho Vignochi)
	* Fixes search folders including comment items
	  (reported by David Willmore)

2013-05-22   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10-RC3
	* Fixes SF #1069: broken rendering in tt-rss feeds
	  (patch by Simon Kågedal Reimer)
	* Merged SF #219: View *.xml files along with *.opml files in file chooser
	  (patch by Simon Kågedal Reimer)
	* Merged SF #233: Show feed name in item view when in merged views.
	  (patch by Simon Kågedal Reimer)
	* Merged SF #193: Use GtkInfoBar for note in preferences window
	  (patch by Fred Morcos)
	* Require intltool >= 0.40.4 (Adrian Bunk)
	* Updated Catalan translation (Gil Forcada)
	* Updated Danish translation (Joe Hansen)
	* Updated Polish translation (Piotr Sokół)

2013-05-12   Lars Windolf <lars.lindner@gmail.com>
	Version 1.10-RC2
	* Extended user agent by "AppleWebKit (KHTML, like Gecko)"
	  to solve incorrect mobile redirect with zdf.de
	* Added social bookmarking support for Mister Wong
	* Added social bookmarking support for Google Bookmarks
	* Update of German FAQ
	* Update of English FAQ
	* Added MimeType to .desktop file (Craig Barnes)
	* Fixes SF #1063: Can't open preferences twice
	  (Emilio Pozuelo Monfort, reported by David Smith)
	* Fixes SF #1040: In feed entries, spaces are replaced with "+"
	  (reported by Emmanuel Seyman)
	* Fixes SF #1051: Issues in RTL GUI of Liferea
	  (reported by phixy)
	* Fixes SF #1038, #1074: Updates ttrss feeds over and over
	  (reported by many users)
	* Fix several memory leaks (Emilio Pozuelo Monfort)
	* Require glib >= 2.28 for GApplication (Adrian Bunk)
	* Use the GTK+ 3 version, not wrongly the GTK+ 2 version,
	  of the libindicate GTK+ bindings (Adrian Bunk)
	* Updated the default feedlists (Adrian Bunk)
	* Removed support for libnotify < 0.7 (Adrian Bunk)
	* Added Vietnamese translation (Trần Ngọc Quân)
	* Updated Albanian translation (Besnik Bleta)
	* Updated Asturian translation (Iñigo Varela)
	* Updated Basque translation (Mikel Olasagasti Uranga)
	* Updated Danish translation (Joe Hansen)
	* Updated Finnish translation (Jorma Karvonen)
	* Updated German translation (Christian Stadelmann)
	* Updated Hungarian translation (Gabor Kelemen)
	* Updated Japanese translation (Takeshi Hamasaki)
	* Updated Latvian translation (Rihards Priedītis)
	* Updated Ukrainian translation (Yuri Chornoivan)

2013-01-30  Lars Windolf <lars.lindner@gmail.com>
	Version 1.10-RC1
	Please note that due to the SourceForge upgrade bug ticket numbering
	did change. This might be confusing... Old numbers are 7 figures,
	newer ones only 4!
	* Patch SF #3407290: Migrate to GSettings
	  (by Mikel Olasagasti)
	* Patch SF #3579177: Change .desktop category to News;Feed;
	  (by Stanislav Brabec)
	* Fix for Debian #668197: x-www-browser preference not working
	  (David Smith)
	* Added slider and time display to media player plugin.
	* Added Google Plus to social bookmarking options.
	* Removing deprecated g_thread_init() call
	* Auto-enable plugins on migration
	* Added missing -a option to manpage
	* Updated manpage to reflect XDG path migration
	* Changing GSettings path from /apps/liferea to /org/gnome/liferea
	* Changes default download thread concurrency from 2 to 3
	* Fixes regression about using the GNOME default font
	* Improves all item/link launching menus to consistently provide
	  three options: Tab, Browser and External Browser
	* Fixes SF #1037: Incorrect notifications for Google Reader
	  (patch by David Smith)
	* Fixes SF #1048: Removed all feedvalidator.org references from FAQ
	  and XSLT as it was reported to host malware.
	  (reported by bkat)
	* Fixes SF #1041: Some GPLv2 license headers were outdated
	  (reported by Emmanuel Seyman)
	* Fixes SF #1044: tt-rss API changed (we now support only 1.6 API)
	  (patch by Sebastian Noel)
	* Fixes assertion when creating new tt-rss subscriptions
	* Fixes XHTML errors caused by extra <body> tags returned by tt-rss
	* Fixes missing item list update when browsing item URLs in Liferea

2012-10-28  Lars Windolf <lars.lindner@gmail.com>
	Version 1.9.7
	* Added new preference for default viewing mode.
	* Changing toolbar button order to prevent accidental clicks on
	  "Mark All Read" when clicking on more frequent buttons like
	  "Next Unread".
	* Added Google Chrome as a browser choice to preferences.
	* Roughly reordered browser choices after browser market share.
	* Removed shading behaviour for unread items in combined view
	  as it doesn't match GTK theming well
	* Removed auto-hide Javascript menu from combined view to simplify
	  rendering in 3-pane modes.
	* Fixes items not removed from search folder count when feed is removed.
	* Fixes search folder rebuilding (do not include comment items).
	* Fixes SELECT offset handling when rebuilding search folders.
	* Now gives feedback when rebuilding search folders in feed list.
	* Update of German translation

2012-10-09  Lars Windolf <lars.lindner@gmail.com>
	Version 1.9.6
	* Removed "pass URL" check box from MIME type dialog.
	* Removed "Save In" entry from "Download" tab in preferences.
	* Removed "curl" choice in download tool preferences.
	* Removed "wget" choice in download tool preferences.
	* Added "steadyflow" choice in download tool preferences.
	* Patch SF #3569056: Use symbolic close buttons and spacing on tabs like gedit
	  (Sebastian Keller)
	* Fixes reloading item when browsing the web inside the item view.
	* Fixes preferences dialog not opening up a second time.
	* Fixes padding/alignments in preferences dialog.
	* Fixes SF #1418701: Remote server pounded into dirt on auto-download
	  (reported by anonymous)
	* Fixes SF #3567827: Double border around webview
	  (reported by borschty)
	* Fixes SF #3572660: crash in google_source_remove_node
	  (reported by Yanko Kaneti)
	* Prevents adding folders/search folders/newsbins to Google Reader
	* Prevents sorting subscriptions in Google Reader
	* Updated Polish translation (Wojciech Myrda)

2012-09-14  Lars Windolf <lars.lindner@gmail.com>
	Version 1.9.5
	* GIR dependencies are now mandatory
	* Migration to XDG directory layout in $HOME
	* Migrate from X session manager to GtkApplication
	* Raising GTK dependency to 3.4 for GtkApplication
	* Storing last window state in GConf now instead in the session command
	* Added Instapaper.com to social bookmarking sites (SF #3564393)
	  (patch by prurigro)
	* Use hint label for manual browser command preference (SF #3129429)
	  (patch by Fred Morcos)
	* Fixes comments_deinit() never being called
	* Fixes search folder counter update on feed removal
	* Fixes SF #3567715: Crash on network online status changes
	  (patch by Yanko Kaneti)

2012-08-24  Lars Windolf <lars.lindner@gmail.com>
	Version 1.9.4
	* Changes (c) name "Lars Lindner" -> "Lars Windolf" due to marriage
	* Removed compilation support for GTK2
	* Added GIR plugin system with libpeas
	* Added GnomeKeyring plugin that stores password in a keyring
	  instead of in the exported OPML.
	* Added simple media player plugin to play audio and video enclosures.
	* Only present enclosures of audio and video MIME type
	* Raise libindicate minimum dependency to 0.6
	* Patch SF #3515882: Also support libindicate 0.7 (Chow Loong Jin)
	* Dropping SIGSEGV signal handler to allow distro crash report tools to
	  work (as found in Ubuntu)
	* Ensure node ids are in DB node relation on startup.
	* Adding AM_PROG_AR to configure.ac to work with automake 1.12
	* Moved tab close button from the URL bar to the right of the tab label.
	* Smarter browser toolbar: appears now also in the item view when
	  browsing external content.
	* Don't ask for Google Reader authentication more than three times
	  with auto-update to avoid annoying the user.
	* Fixes SF Trac #10: Crash on empty search folders within folders
	  (reported by phyxi)
	* Fixes SF Trac #19: Auto-load-link doesn't work with feeds with comments
	  (reported by wonk0)
	* Fixes SF #2855990: Crash when dragging Google Reader feeds outside
	  Google Reader. This is now prevented.
	  (reported by algnod)
	* Fixes SF #3515880: missing include when compiling with libindicate
	  (patch by Chow Loong Jin)
	* Fixes search folders being invisible in reduced mode.
	* Fixes ever growing temporary DB files.
	  (patch by Sven Hartge)
	* Fixes visibility of enclosure list view for Ubuntu.
	* Fixes crashes on enclosure list context menu.
	* Fixes SF #3557513: Fixes crash on empty links in auto-load-link mode.
	  (patch by msquared84)
	* Fixes unknown metadata types reported in trace when loading Google
	  Reader subscriptions from DB.

2012-03-30  Lars Lindner <lars.lindner@gmail.com>
	Version 1.9.3
	* Added a new item history feature that allows navigating
	  through recently viewed items.
	* Added new "Fullscreen" toggle menu option.
	* For GTK+3: request dark theme variant for better contrast
	  between GUI and content. (Jeff Fortin)
	* Change schema defaults for folder display. Now unread
	  items are loaded per-default when clicking a folder.
	* Patch SF #3473743: GTK2 dependency has to be 2.24 (bento)
	* Improve DB item counting statements.
	  (patch by Regis Floret)
	* Change OpenStreetMap rendering from osmarender to mapnik.
	  (patch by Mikel Olasagasti)
	* Patch SF #3127016: Automatic scrollbars on enclosure actions view
	  (patch by Fred Morcos)
	* SF Trac #7: Removing icon from "Cancel All" in update dialog
	  so that .gtkrc "gtk-button-images=0" does have correct effect.
	  (reported by phixy)
	* Fixes SF #3480238: crashes when double clicking find
	  (reported by joeserneem)
	* Fixes Debian #660602: Item pane may be reset during feed update
	  (reported by Ben Hutchings)
	* Reimplemented search folder rule for item with enclosures.
	* Reimplemented search folder rule for item categories.
	* Reimplemented feed title matching rule for search folders.
	  (patch by John Levon)
	* Updated Catalan translation (Gil Forcada)

2012-03-23  Lars Lindner <lars.lindner@gmail.com>
	Version 1.9.2
	* Fixes another migration issue left from 1.9.1
	* Increasing sqlite3 dependency to 3.7+ for WAL journaling.
	* Removed sqliteasync code in favour of WAL journaling.
	  This significantly improves performance for ext4.
	* Added indices for parent_item_id and parent_node_id
	  to avoid slow item removal. (suggested by Paulo Anes)

2012-03-18  Lars Lindner <lars.lindner@gmail.com>
	Version 1.9.1
	* Disabled migration to ~/.liferea_1.9
	* Revert ISO 8601 parsing using Glib due to Debian #653196
	  This fixes SF #3465106 (reported by Vincent Lefevre)
	* Fixes SF #3477582: welcome screen not using theme colors.
	  (reported by stqn)
	* Do not update DB node and subscription info on startup
	  for performance reasons.
	* Perform VACCUM only when page fragmentation ratio < 10%.
	  (suggested by adriatic)
	* Removed tooltip on the "Next Unread Item" button to avoid
	  having it flashing each time it is clicked when skimming
	  through items.

2011-12-23  Lars Lindner <lars.lindner@gmail.com>
	Version 1.9.0
	* Add configure switch to compile against GTK2 or GTK3.
	  (Emilio Pozuelo Monfort, Adrian Bunk)
	* Raise dependencies and updated code to compile against GTK3.
	  (Emilio Pozuelo Monfort, Adrian Bunk)
	* Fixes proxy preference not affecting the HTML widget.
	  (reported by Chris Siebenmann)
	* Fixes SF #3363481: Feeds fail to update properly when entries ordered
	  "wrong" (patch by Robert Trace)
	* Fixes writing subscriptions into DB when importing from OPML
	  (reported by Dennis Nezic)
086f0e2
@jperkin jperkin pushed a commit that referenced this issue Sep 7, 2015
mef Update 1.20140408 to 1.20150527
-------------------------------
1.20150527 2015-05-27 08:33:52-07:00 America/Los_Angeles
    - improved dependencies (build/run/requires), (Olivier Mengue, GH PR #10)
    - improved runtime loading (Olivier Mengue, GH PR #11)

1.20150521 2015-05-21 09:09:19-07:00 America/Los_Angeles
    - updated CGI dependency
    - improved README for GitHub (Rob Van Dam, GH PR #9)
0814442
@jperkin jperkin pushed a commit that referenced this issue Dec 4, 2015
taca Update ruby-pg to 0.18.4.
== v0.18.4 [2015-11-13] Michael Granger <ged@FaerieMUD.org>

Enhancements:
- Fixing compilation problems with Microsoft Visual Studio 2008. GH #10
- Avoid name clash with xcode and jemalloc. PR#22, PR#23

Bugfixes:
- Avoid segfault, when quote_ident or TextEncoder::Identifier
  is called with Array containing non-strings. #226
9231608
@jperkin jperkin pushed a commit that referenced this issue Jan 9, 2016
taca Update ruby-tzinfo to 1.2.2.
Version 1.2.2 - 8-Aug-2014
--------------------------

* Fix an error with duplicates being returned by Timezone#all_country_zones
  and Timezone#all_country_zone_identifiers when used with tzinfo-data
  v1.2014.6 or later.
* Use the zone1970.tab file for country timezone data if it is found in the
  zoneinfo directory (and fallback to zone.tab if not). zone1970.tab was added
  in tzdata 2014f. zone.tab is now deprecated.


Version 1.2.1 - 1-Jun-2014
--------------------------

* Support zoneinfo files generated with zic version 2014c and later.
* On platforms that only support positive 32-bit timestamps, ensure that
  conversions are accurate from the epoch instead of just from the first
  transition after the epoch.
* Minor documentation improvements.


Version 1.2.0 - 26-May-2014
---------------------------

* Raise the minimum supported Ruby version to 1.8.7.
* Support loading system zoneinfo data on FreeBSD, OpenBSD and Solaris.
  Resolves #15.
* Add canonical_identifier and canonical_zone methods to Timezone. Resolves #16.
* Add a link to a DataSourceNotFound help page in the TZInfo::DataSourceNotFound
  exception message.
* Load iso3166.tab and zone.tab files as UTF-8.
* Fix Timezone#local_to_utc returning local Time instances on systems using UTC
  as the local time zone. Resolves #13.
* Fix == methods raising an exception when passed an instance of a different
  class by making <=> return nil if passed a non-comparable argument.
* Eliminate "require 'rational'" warnings. Resolves #10.
* Eliminate "assigned but unused variable - info" warnings. Resolves #11.
* Switch to minitest v5 for unit tests. Resolves #18.


Version 1.1.0 - 25-Sep-2013
---------------------------

* TZInfo is now thread safe. ThreadSafe::Cache is now used instead of Hash
  to cache Timezone and Country instances returned by Timezone.get and
  Country.get. The tzinfo gem now depends on thread_safe ~> 0.1.
* Added a transitions_up_to method to Timezone that returns a list of the times
  where the UTC offset of the timezone changes.
* Added an offsets_up_to method to Timezone that returns the set of offsets
  that have been observed in a defined timezone.
* Fixed a "can't modify frozen String" error when loading a Timezone from a
  zoneinfo file using an identifier String that is both tainted and frozen.
  Resolves #3.
* Support TZif3 format zoneinfo files (now produced by zic from tzcode version
  2013e onwards).
* Support using YARD to generate documentation (added a .yardopts file).
* Ignore the +VERSION file included in the zoneinfo directory on Mac OS X.
* Added a note to the documentation concerning 32-bit zoneinfo files (as
  included with Mac OS X).


Version 1.0.1 - 22-Jun-2013
---------------------------

* Fix a test case failure when tests are run from a directory that contains a
  dot in the path (issue #29751).


Version 1.0.0 - 2-Jun-2013
--------------------------

* Allow TZInfo to be used with different data sources instead of just the
  built-in Ruby module data files.
* Include a data source that allows TZInfo to load data from the binary
  zoneinfo files produced by zic and included with many Linux and Unix-like
  distributions.
* Remove the definition and index Ruby modules from TZInfo and move them into
  a separate TZInfo::Data library (available as the tzinfo-data gem).
* Default to using the TZInfo::Data library as the data source if it is
  installed, otherwise use zoneinfo files instead.
* Preserve the nanoseconds of local timezone Time objects when performing
  conversions (issue #29705).
* Don't add the tzinfo lib directory to the search path when requiring 'tzinfo'.
  The tzinfo lib directory must now be in the search path before 'tzinfo' is
  required.
* Add utc_start_time, utc_end_time, local_start_time and local_end_time instance
  methods to TimezonePeriod. These return an identical value as the existing
  utc_start, utc_end, local_start and local_end methods, but return Time
  instances instead of DateTime.
* Make the start_transition, end_transition and offset properties of
  TimezonePeriod protected. To access properties of the period, callers should
  use other TimezonePeriod instance methods instead (issue #7655).
1c369bf
@jperkin jperkin pushed a commit that referenced this issue Jan 15, 2016
kleink Update py-pyphen to 0.9.3
Changes:
* Use package_data instead of data_files (fix #10)
66f4842
@jperkin jperkin pushed a commit that referenced this issue Jan 19, 2016
mef (pkgsrc)
 - Add following line for make test
	BUILD_DEPENDS+= p5-Test-Exception-[0-9]*:../../devel/p5-Test-Exception
(upstream)
Update to 0.25
--------------
0.25 2015-04-21T23:39:33Z
  Author: Yanick Champoux <yanick at babyl.dyndns.org>
     silence warnings
     ... as the arguments can be undefined
     Fixes #10
63e98dd
@jperkin jperkin pushed a commit that referenced this issue Jan 20, 2016
leot Update www/libproxy to 0.4.12.
pkgsrc changes:
 o Update MASTER_SITES and HOMEPAGE (libproxy migrated to GitHub)
 o Delete patches/patch-libproxy_modules_config__macosx.cpp, now present in the
   stable release.

Changes:
New in version 0.4.12
==============================
* Move development to github.com/libproxy/libproxy
* Fix fd leak in get_pac (Bug #185)
* Detect running MATE session (Bug #186, Part1).
* Fix linking of perl bindings to pthread (Bug #182)
* Correctly detect spidermonky (mozjs185) (Bug #188)
* Stop pxgsettings from segfaulting on exit (Bug #192)
* Fix test #10 (Bug #189)
* Fix build on Mac OS X (Bug #183)
* Add a generic KDE Config module (fix crashes of Qt5 based
  apps) (issue#4)
bd23183
@jperkin jperkin pushed a commit that referenced this issue Feb 4, 2016
jaapb Updated package to the newest version, 0.5.2. Changes include:
0.5.2 (2015-11-23)
=====
* Add OPENSSL_NO_SSL3 preprocessor flag to disable SSLv3 (thanks Jérémie
  Courrèges-Anglas).

0.5.1 (2015-05-27)
=====

* Fix META file for versions of OCaml older than 4.02.0 (thanks Anil
  Madhavapeddy, closes #20).

0.5.0 (2015-05-18)
=====
* Allow to honor server cipher preferences (thanks mfp, closes #18).
* Add functions for reading into/writing from bigarrays, avoiding copy (thanks
  mfp, closes #15).
* Support disabling SSL protocol versions (thanks Edwin Török, closes #13).
* Use Bytes instead of String for read and write, changes the ABI thus the
  version bump (thanks Vincent Bernardoff, closes #16, and mfp, closes #19).
* Make verbosity of client_verify_callback configurable (thanks Nicolas Trangez,
  closes #12).
* Fix build with old versions of SSL (thanks Edwin Török, closes #10).
17e72c7
@jperkin jperkin pushed a commit that referenced this issue Feb 11, 2016
jaapb Updated package to the newest version, 0.5.2. Changes include:
0.5.2 (2015-11-23)
=====
* Add OPENSSL_NO_SSL3 preprocessor flag to disable SSLv3 (thanks Jérémie
  Courrèges-Anglas).

0.5.1 (2015-05-27)
=====

* Fix META file for versions of OCaml older than 4.02.0 (thanks Anil
  Madhavapeddy, closes #20).

0.5.0 (2015-05-18)
=====
* Allow to honor server cipher preferences (thanks mfp, closes #18).
* Add functions for reading into/writing from bigarrays, avoiding copy (thanks
  mfp, closes #15).
* Support disabling SSL protocol versions (thanks Edwin Török, closes #13).
* Use Bytes instead of String for read and write, changes the ABI thus the
  version bump (thanks Vincent Bernardoff, closes #16, and mfp, closes #19).
* Make verbosity of client_verify_callback configurable (thanks Nicolas Trangez,
  closes #12).
* Fix build with old versions of SSL (thanks Edwin Török, closes #10).
c098d3d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.