João Martins jpemartins

Organizations

@cnplab
jpemartins created repository cnplab/xen-pgnt-net
@jpemartins
Cannot load xen-netback.ko - Wrong netmap version in xennet
jpemartins commented on issue cnplab/xennet#5
@jpemartins

Nice, Glad to hear that! I will still reopen this issue to let you know after giving support for more recent kernels. Cheers, Joao

jpemartins commented on issue cnplab/xennet#5
@jpemartins

I normally dont rely on using different packages source and headers package. I get my kernels built from git/tarballs (in kernel.org) and I build a…

jpemartins commented on issue cnplab/clickos#11
@jpemartins

One other thing: If ClickOS gets stucked here "Waiting for /local/domain/0/backend/vif/2/0/state change to connected" might be that's something is …

jpemartins commented on issue cnplab/clickos#11
@jpemartins

You seem to start two routers in each VM. You can either insert the click = 'vm0.click' entry in your vm1.cfg or do cosmos start vm1 vm1.click (sam…

jpemartins commented on issue cnplab/clickos#11
@jpemartins

Since you are using xennet, the standard tools that use the host stack won't work. Your options would be: 1) you either built your tools with netm…

jpemartins commented on issue cnplab/cosmos#23
@jpemartins

Are you using DOMLIB=xcl ? No. I am using DOMLIB=xl. Ah! I wasn't aware of this bug when using DOMLIB=xl. But whatever, it works now by using t…

jpemartins commented on issue cnplab/cosmos#23
@jpemartins

As a conclusion, I guess the code is not able to appropriate parse whether it's a name or a domain id. At this moment, we should use name for the…

jpemartins commented on issue cnplab/xennet#6
@jpemartins

Then backend is not being correctly compiled. Let me check if there are issues with 3.11.

jpemartins commented on issue cnplab/cosmos#22
@jpemartins

I will let you know once this is introduced in mini-os :) Cheers

@jpemartins
utilization of clickos's cpu is always 100% then cannot get access to console
jpemartins commented on issue cnplab/xennet#5
@jpemartins

All the versions supported in xennet were tested (at the time 3.13, 3.14 and 3.15 were the ones that I use). Since you might be using just the hea…

jpemartins commented on issue cnplab/xennet#6
@jpemartins

Could you paste xenstore-ls | grep feature-netmap ? If it doesn't print anything it means xen-netback is not patching correctly for 3.11.

jpemartins commented on issue cnplab/cosmos#22
@jpemartins

Hey, yeah we are aware of that issue. Right now netfront is implemented in poll mode, but will be introducing select-based netfront implementation …

jpemartins commented on issue cnplab/xennet#5
@jpemartins

Hi, xennet uses a specific commit in netmap-release. This is handled when you do git submodule update --init on top-level directory of xennet, so t…

jpemartins commented on issue cnplab/xennet#6
@jpemartins

You trying two different configurations when both of them have the same domain name, leading to this behaviour. Note that you first config worked w…

jpemartins commented on issue cnplab/cosmos#21
@jpemartins

I wish there exists a way to just install these headers. I thought the "libxen-dev" package might be help. > But after that I still have the same …

jpemartins commented on issue cnplab/cosmos#21
@jpemartins

Hi there! Perhaps you don't have the headers installed? Did you installed it from source or from (debian?) packages? The issue is that it can't find

jpemartins commented on pull request cnplab/cosmos#17
@jpemartins

Looks good! But I guess the PR wasn't updated correctly. You just need rebased it and delete the last 4 commits, to just have commit c4bbaaa in you…

@jpemartins
cosmos: command not found