Skip to content

v5.1.0

Latest
Compare
Choose a tag to compare
@tsaglam tsaglam released this 23 May 11:54
· 2 commits to main since this release
1646516

Fill out a quick (<5 min) survey to help us and give feedback: Take me to the survey 馃ぉ

Java Version

JDK 21

What's Changed

  • Improved error messages for multiple languages
  • Introduced dynamic progress bars in the CLI instead of the old wall of text
  • Output files for reports are no longer overridden (if you still want to, use --overwrite)
  • Bug fixes and enhancements
Click to show details...

Report Viewer Changes

  • Character precise matches: JPlag can now visualize where matches start and end in a single line
  • Table of related submissions in the cluster view
  • Some fixes and improvements
Click to show details...

Updated Dependencies

As always, we updated some dependencies.

Click to show details...
  • Dependency(deps): Bump org.codehaus.mojo:exec-maven-plugin from 1.3.2 to 3.1.1 by @dependabot in #1585
  • Dependency(deps): Bump org.scalameta:scalameta_2.13 from 4.8.15 to 4.9.0 by @dependabot in #1584
  • Dependency(deps-dev): Bump @types/node from 18.19.15 to 18.19.17 in /report-viewer by @dependabot in #1589
  • Dependency(deps-dev): Bump vitest from 1.2.2 to 1.3.1 in /report-viewer by @dependabot in #1588
  • Dependency(deps-dev): Bump vite from 5.1.1 to 5.1.4 in /report-viewer by @dependabot in #1599
  • Dependency(deps-dev): Bump @playwright/test from 1.41.2 to 1.42.0 in /report-viewer by @dependabot in #1623
  • Dependency(deps): Bump vue-router from 4.2.5 to 4.3.0 in /report-viewer by @dependabot in #1624
  • Dependency(deps-dev): Bump eslint from 8.56.0 to 8.57.0 in /report-viewer by @dependabot in #1626
  • Dependency(deps-dev): Bump eslint-plugin-vue from 9.21.1 to 9.22.0 in /report-viewer by @dependabot in #1627
  • Dependency(deps-dev): Bump @types/node from 18.19.17 to 18.19.19 in /report-viewer by @dependabot in #1625
  • Dependency(deps): Bump org.codehaus.mojo:exec-maven-plugin from 3.1.1 to 3.2.0 by @dependabot in #1618
  • Dependency(deps): Bump org.scala-lang:scala-library from 2.13.12 to 2.13.13 by @dependabot in #1622
  • Dependency(deps): Bump org.eclipse.emf:org.eclipse.emf.common from 2.29.0 to 2.30.0 by @dependabot in #1620
  • Dependency(deps): Bump org.eclipse.emf:org.eclipse.emf.ecore from 2.35.0 to 2.36.0 by @dependabot in #1621
  • Dependency(deps): Bump org.eclipse.emf:org.eclipse.emf.ecore.xmi from 2.36.0 to 2.37.0 by @dependabot in #1619
  • Dependency(deps): Bump chart.js from 4.4.1 to 4.4.2 in /report-viewer by @dependabot in #1635
  • Dependency(deps-dev): Bump @types/node from 18.19.19 to 18.19.21 in /report-viewer by @dependabot in #1634
  • Dependency(deps-dev): Bump @playwright/test from 1.42.0 to 1.42.1 in /report-viewer by @dependabot in #1633
  • Dependency(deps-dev): Bump autoprefixer from 10.4.17 to 10.4.18 in /report-viewer by @dependabot in #1637
  • Dependency(deps-dev): Bump vue-tsc from 1.8.27 to 2.0.5 in /report-viewer by @dependabot in #1636
  • Dependency(deps): Bump org.scalameta:scalameta_2.13 from 4.9.0 to 4.9.1 by @dependabot in #1639
  • Dependency(deps-dev): Bump org.mockito:mockito-core from 5.10.0 to 5.11.0 by @dependabot in #1638
  • Dependency(deps): Bump softprops/action-gh-release from 1 to 2 by @dependabot in #1658
  • Dependency(deps): Bump org.apache.maven.plugins:maven-gpg-plugin from 3.1.0 to 3.2.0 by @dependabot in #1654
  • Dependency(deps): Bump org.scalameta:scalameta_2.13 from 4.9.1 to 4.9.2 by @dependabot in #1655
  • Dependency(deps): Bump org.apache.maven.plugins:maven-assembly-plugin from 3.6.0 to 3.7.0 by @dependabot in #1656
  • Dependency(deps): Bump com.fasterxml.jackson.core:jackson-databind from 2.16.1 to 2.17.0 by @dependabot in #1657
  • Dependency(deps-dev): Bump @types/node from 18.19.21 to 18.19.23 in /report-viewer by @dependabot in #1649
  • Dependency(deps-dev): Bump vite from 5.1.4 to 5.1.6 in /report-viewer by @dependabot in #1653
  • Dependency(deps-dev): Bump prettier-plugin-tailwindcss from 0.5.11 to 0.5.12 in /report-viewer by @dependabot in #1652
  • Dependency(deps-dev): Bump @vue/eslint-config-typescript from 12.0.0 to 13.0.0 in /report-viewer by @dependabot in #1650
  • Dependency(deps-dev): Bump typescript from 5.3.3 to 5.4.2 in /report-viewer by @dependabot in #1651
  • Dependency(deps-dev): Bump @types/node from 18.19.23 to 18.19.26 in /report-viewer by @dependabot in #1665
  • Dependency(deps-dev): Bump @vue/test-utils from 2.4.4 to 2.4.5 in /report-viewer by @dependabot in #1666
  • Dependency(deps-dev): Bump vue-tsc from 2.0.5 to 2.0.6 in /report-viewer by @dependabot in #1664
  • Dependency(deps-dev): Bump @rushstack/eslint-patch from 1.7.2 to 1.8.0 in /report-viewer by @dependabot in #1663
  • Dependency(deps): Bump org.apache.maven.plugins:maven-gpg-plugin from 3.2.0 to 3.2.1 by @dependabot in #1660
  • Dependency(deps): Bump org.apache.maven.plugins:maven-assembly-plugin from 3.7.0 to 3.7.1 by @dependabot in #1661
  • Dependency(deps): Bump chartjs-chart-graph from 4.2.8 to 4.3.0 in /report-viewer by @dependabot in #1662
  • Dependency(deps): Bump me.tongfei:progressbar from 0.10.0 to 0.10.1 by @dependabot in #1678
  • Dependency(deps): Bump org.apache.maven.plugins:maven-gpg-plugin from 3.2.1 to 3.2.2 by @dependabot in #1677
  • Dependency(deps-dev): Bump typescript from 5.4.2 to 5.4.3 in /report-viewer by @dependabot in #1674
  • Dependency(deps-dev): Bump eslint-plugin-vue from 9.22.0 to 9.24.0 in /report-viewer by @dependabot in #1676
  • Dependency(deps): Bump vue from 3.4.15 to 3.4.21 in /report-viewer by @dependabot in #1675
  • Dependency(deps-dev): Bump vite from 5.1.6 to 5.2.6 in /report-viewer by @dependabot in #1672
  • Dependency(deps): Bump org.scalameta:scalameta_2.13 from 4.9.2 to 4.9.3 by @dependabot in #1686
  • Dependency(deps): Bump org.jacoco:jacoco-maven-plugin from 0.8.11 to 0.8.12 by @dependabot in #1687
  • Dependency(deps-dev): Bump vitest from 1.3.1 to 1.4.0 in /report-viewer by @dependabot in #1683
  • Dependency(deps-dev): Bump autoprefixer from 10.4.18 to 10.4.19 in /report-viewer by @dependabot in #1685
  • Dependency(deps-dev): Bump tailwindcss from 3.4.1 to 3.4.3 in /report-viewer by @dependabot in #1684
  • Dependency(deps-dev): Bump @types/node from 18.19.26 to 18.19.31 in /report-viewer by @dependabot in #1699
  • Dependency(deps-dev): Bump eslint-plugin-vue from 9.24.0 to 9.24.1 in /report-viewer by @dependabot in #1698
  • Dependency(deps): Bump org.apache.maven.plugins:maven-source-plugin from 3.3.0 to 3.3.1 by @dependabot in #1703
  • Dependency(deps-dev): Bump @playwright/test from 1.42.1 to 1.43.0 in /report-viewer by @dependabot in #1702
  • Dependency(deps-dev): Bump typescript from 5.4.3 to 5.4.4 in /report-viewer by @dependabot in #1701
  • Dependency(deps): Bump vue-chartjs from 5.3.0 to 5.3.1 in /report-viewer by @dependabot in #1700
  • Dependency(deps): Bump slf4j.version from 2.0.12 to 2.0.13 by @dependabot in #1715
  • Dependency(deps): Bump org.apache.maven.plugins:maven-jar-plugin from 3.3.0 to 3.4.0 by @dependabot in #1714
  • Dependency(deps): Bump com.ibm.icu:icu4j-charset from 74.2 to 75.1 by @dependabot in #1713
  • Dependency(deps-dev): Bump com.tngtech.archunit:archunit-junit5 from 1.2.1 to 1.3.0 by @dependabot in #1711
  • Dependency(deps-dev): Bump @playwright/test from 1.43.0 to 1.43.1 in /report-viewer by @dependabot in #1709
  • Dependency(deps-dev): Bump prettier-plugin-tailwindcss from 0.5.12 to 0.5.14 in /report-viewer by @dependabot in #1708
  • Dependency(deps-dev): Bump vitest from 1.4.0 to 1.5.0 in /report-viewer by @dependabot in #1706
  • Dependency(deps): Bump vue-router from 4.3.0 to 4.3.1 in /report-viewer by @dependabot in #1710
  • Dependency(deps-dev): Bump vite from 5.2.6 to 5.2.9 in /report-viewer by @dependabot in #1707
  • Dependency(deps): Bump org.apache.maven.plugins:maven-gpg-plugin from 3.2.2 to 3.2.3 by @dependabot in #1712
  • Dependency(deps-dev): Bump @rushstack/eslint-patch from 1.8.0 to 1.10.2 in /report-viewer by @dependabot in #1724
  • Dependency(deps-dev): Bump typescript from 5.4.4 to 5.4.5 in /report-viewer by @dependabot in #1726
  • Dependency(deps-dev): Bump vue-tsc from 2.0.6 to 2.0.14 in /report-viewer by @dependabot in #1727
  • Dependency(deps-dev): Bump vite from 5.2.9 to 5.2.10 in /report-viewer by @dependabot in #1728
  • Dependency(deps): Bump edu.stanford.nlp:stanford-corenlp from 4.5.6 to 4.5.7 by @dependabot in #1729
  • Dependency(deps): Bump org.apache.maven.plugins:maven-jar-plugin from 3.4.0 to 3.4.1 by @dependabot in #1730
  • Dependency(deps): Bump net.alchim31.maven:scala-maven-plugin from 4.8.1 to 4.9.0 by @dependabot in #1731
  • Dependency(deps): Bump org.apache.maven.plugins:maven-gpg-plugin from 3.2.3 to 3.2.4 by @dependabot in #1732
  • Dependency(deps): Bump vue from 3.4.21 to 3.4.25 in /report-viewer by @dependabot in #1733
  • Dependency(deps): Bump org.apache.maven.plugins:maven-deploy-plugin from 3.1.1 to 3.1.2 by @dependabot in #1738
  • Dependency(deps): Bump org.scala-lang:scala-library from 2.13.13 to 2.13.14 by @dependabot in #1737
  • Dependency(deps-dev): Bump eslint-plugin-vue from 9.24.1 to 9.25.0 in /report-viewer by @dependabot in #1743
  • Dependency(deps-dev): Bump vue-tsc from 2.0.14 to 2.0.16 in /report-viewer by @dependabot in #1740
  • Dependency(deps): Bump vue-router from 4.3.1 to 4.3.2 in /report-viewer by @dependabot in #1739
  • Dependency(deps-dev): Bump vitest from 1.5.0 to 1.5.3 in /report-viewer by @dependabot in #1741
  • Dependency(deps): Bump JamesIves/github-pages-deploy-action from 4.5.0 to 4.6.0 by @dependabot in #1723
  • Dependency(deps): Bump vue from 3.4.25 to 3.4.26 in /report-viewer by @dependabot in #1742
  • Dependency(deps-dev): Bump @vue/test-utils from 2.4.5 to 2.4.6 in /report-viewer by @dependabot in #1756
  • Dependency(deps-dev): Bump @playwright/test from 1.43.1 to 1.44.0 in /report-viewer by @dependabot in #1753
  • Dependency(deps-dev): Bump vitest from 1.5.3 to 1.6.0 in /report-viewer by @dependabot in #1752
  • Dependency(deps-dev): Bump @types/node from 18.19.31 to 18.19.33 in /report-viewer by @dependabot in #1759
  • Dependency(deps): Bump com.fasterxml.jackson.core:jackson-databind from 2.17.0 to 2.17.1 by @dependabot in #1757
  • Dependency(deps-dev): Bump vite from 5.2.10 to 5.2.11 in /report-viewer by @dependabot in #1755
  • Dependency(deps): Bump info.picocli:picocli from 4.7.5 to 4.7.6 by @dependabot in #1758
  • Dependency(deps-dev): Bump vue-tsc from 2.0.16 to 2.0.17 in /report-viewer by @dependabot in #1762
  • Dependency(deps-dev): Bump eslint-plugin-vue from 9.25.0 to 9.26.0 in /report-viewer by @dependabot in #1763
  • Dependency(deps-dev): Bump org.mockito:mockito-core from 5.11.0 to 5.12.0 by @dependabot in #1765
  • Dependency(deps): Bump vue from 3.4.26 to 3.4.27 in /report-viewer by @dependabot in #1761
  • Dependency(deps): Bump net.alchim31.maven:scala-maven-plugin from 4.9.0 to 4.9.1 by @dependabot in #1764
  • Dependency(deps): Bump org.scalameta:scalameta_2.13 from 4.9.3 to 4.9.4 by @dependabot in #1766
  • Dependency(deps): Bump JamesIves/github-pages-deploy-action from 4.6.0 to 4.6.1 by @dependabot in #1775
  • Dependency(deps): Bump org.codehaus.mojo:exec-maven-plugin from 3.2.0 to 3.3.0 by @dependabot in #1776
  • Dependency(deps): Bump org.scalameta:scalameta_2.13 from 4.9.4 to 4.9.5 by @dependabot in #1778
  • Dependency(deps): Bump org.codehaus.mojo:build-helper-maven-plugin from 3.5.0 to 3.6.0 by @dependabot in #1779

New Contributors

Full Changelog: v5.0.0...v5.1.0


Fill out a quick (<5 min) survey to help us and give feedback: Take me to the survey 馃ぉ