Permalink
Browse files

Make Ruby 1.8.7 compliant

  • Loading branch information...
1 parent 2088c3b commit 4d0556bfc13fc5da1b2036e2c8700cf425dd6a8d @kmayer kmayer committed Feb 2, 2013
Showing with 2 additions and 2 deletions.
  1. +2 −2 spec/heroku_san/api_spec.rb
@@ -11,7 +11,7 @@
it "reports Excon errors in a more human readable format" do
error_message = 'Name is already taken'
status_message = '000 Status'
- response = mock("Response", body: %Q[{"error":"#{error_message}"}], headers: {'Status' => status_message})
+ response = mock("Response", :body => %Q[{"error":"#{error_message}"}], :headers => {'Status' => status_message})
Heroku::API.any_instance.should_receive(:api_method).and_raise(Heroku::API::Errors::ErrorWithResponse.new("excon message", response))
$stderr.should_receive(:puts).with("\nHeroku API ERROR: #{status_message} (#{error_message})\n\n")
@@ -22,4 +22,4 @@
error.backtrace.should == []
}
end
-end
+end

0 comments on commit 4d0556b

Please sign in to comment.