Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Next version with Update jQuery UI 1.10 #133

Closed
gtraxx opened this Issue Jan 18, 2013 · 20 comments

Comments

Projects
None yet
3 participants
Owner

gtraxx commented Jan 18, 2013

@addyosmani

Hello everyone, I started updating jquery ui to 1.10.
For this new version, the documentation will be completely changed for highlighting demonstration.

Should set the version number for this update and also provide for the adaptation bootstrap 3.
I work on this new version and I will send soon :)
PS: Sorry for the delay ;)

Aurélien

@ghost ghost assigned gtraxx Jan 18, 2013

Owner

addyosmani commented Jan 18, 2013

Thanks for the update @gtraxx! I'm currently working on trying to get a few more people
involved in the project to help us get the next version out.

Maybe we should update the release list to include a list of what we now need to get done
for this and include a link to this issue too?

Owner

gtraxx commented Jan 18, 2013

We should have people working on version LESS and SASS.
And also to create new image for documentation (Image header): D

Owner

addyosmani commented Jan 18, 2013

I can do the header (need to remind myself to!) but do you think switching over to using
SASS would make sense for this release? The last time I looked into it it seemed like a
lot of work.

How long do you think it might take to get done?

Owner

gtraxx commented Jan 18, 2013

I do not know much SASS so I do not know for the moment but it is a good idea

Owner

addyosmani commented Jan 18, 2013

Maybe I'll try speaking to some designers and we can get a better idea about the time it might take.

Owner

addyosmani commented Jan 22, 2013

@gtraxx Do you think we could update the readme with the current state of the project? i.e what version of jQuery UI we support, maybe point people to our release thread so they know what the current state of the project is?

Owner

gtraxx commented Jan 22, 2013

Hi @addyosmani ,
I'm working on the new version + new documentation :)
But what version number should be added? (0.23 => 1.10)
I propose a version number that jQuery UI (Official) :)
Currently,
I work locally but I will send changes to my fork to not overwrite the current version.
I send changes tonight on my fork, to see the progress

Owner

addyosmani commented Jan 22, 2013

That is fantastic to hear :)

Because we're still pre-release on the next 'official' version, how about we go for 0.5
for the next version given the amount of work done so far and when we make an official
project release (most major bugs fixed) we'll match the jQuery UI version? :)

That hopefully won't be too long off!

Owner

gtraxx commented Jan 22, 2013

@addyosmani Here is a screenshot of the new version under development :)
The documentation uses jQuery UI bootstrap.

screenshot-new-ui-bootstrap

Owner

addyosmani commented Jan 22, 2013

Amazing start :) Looks exactly like what I was hoping for! Great work

On Tuesday, January 22, 2013, Gerits aurelien wrote:

@addyosmani https://github.com/addyosmani Here is a screenshot of the
new version under development :)
The documentation uses jQuery UI bootstrap.

[image: screenshot-new-ui-bootstrap]https://f.cloud.github.com/assets/356674/88134/4b0228c6-64df-11e2-9d9b-b5655a4eeaa3.png


Reply to this email directly or view it on GitHubhttps://github.com/addyosmani/jquery-ui-bootstrap/issues/133#issuecomment-12569384.

Addy Osmani

Developer Programs Engineer at Google
Blogger at: http://addyosmani.com
Phone: +44 7771 334170

Owner

gtraxx commented Jan 22, 2013

A screenshot of a demo for button + button set :D

screenshot-new-ui-button

To see the changes: https://github.com/gtraxx/jquery-ui-bootstrap

I sent when everything is finished but I'll fast forward

Owner

addyosmani commented Jan 23, 2013

Woot! +1 for those example snippets below each group. Great idea.

Owner

gtraxx commented Jan 23, 2013

Hi @addyosmani ,
I work in the new version of jQuery UI Bootstrap with jQuery 1.9.0 and jQuery UI 1.10.0 but is it possible to send me a compatible version of Wijmo to create the menu in the demo?
Version 1.5 does not work well with jQuery 1.9.0.

I use jquery-migrate for the script to work

Without "jQuery Migrate" script returns the error:

TypeError: a.browser is undefined (jquery.wijmo-open.1.5.0.min.js)

With "jQuery Migrate" script returns the message :

JQMIGRATE: jQuery.browser is deprecated (jquery.wijmo-open.1.5.0.min.js)

PS : I added Font-Awesome in the doc :D

Owner

addyosmani commented Feb 16, 2013

What's the current status of our Wijmo issues? I can ask someone from that team to help if we need it :)

Owner

gtraxx commented Feb 17, 2013

Hi Addy,
Yes an update to wijmo is necessary

Owner

addyosmani commented Feb 17, 2013

cc @banzor

Contributor

Heliosmaster commented Apr 15, 2013

Is this issue still actual?

Owner

gtraxx commented Apr 16, 2013

Yes, but not news of wijmo

Contributor

Heliosmaster commented Apr 16, 2013

Maybe a more appropriate issue can be opened? Technically this refers to jQuery UI 1.10 and the changes that are already implemented in the current tree.

Owner

gtraxx commented Apr 16, 2013

I close this ticket, you can create a new future for the Advancement of Version :)

@gtraxx gtraxx closed this Apr 16, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment