Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

List dependencies for each widget #48

Closed
scottgonzalez opened this Issue Oct 13, 2012 · 0 comments

Comments

Projects
None yet
1 participant
Owner

scottgonzalez commented Oct 13, 2012

In the old page, widgets used to have a list of their dependencies (e.g. autocomplete requires the core, widget and mouse modules and so on), which was kind of handy for those of us who include the individual files one-by-one (and merge them later in the framework).

Also, it would be good if you could clarify external dependencies. Right now, I'm looking at the spinner documentation and I couldn't say if Globalize is mandatory or optional. The demos use it and some options kind of suggest it should be there, but it would be nice if you could just spell it out somewhere, so that we don't have to find out by trial and error

@flack jquery/jqueryui.com#14

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment