New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem with page display with fixed header and footer in latest #3020

Closed
agcolom opened this Issue Nov 11, 2011 · 6 comments

Comments

Projects
None yet
3 participants
@agcolom
Member

agcolom commented Nov 11, 2011

Hi,

With the latest JQM (not RC2), the content background color stops at the end of the content instead of going all the way to the footer. See http://jsfiddle.net/agcolom/zYXLS/3/ (latest version) and compare with http://jsfiddle.net/agcolom/zYXLS/2/ (RC2)

Thanks,

Anne

@toddparker

This comment has been minimized.

Show comment
Hide comment
@toddparker

toddparker Nov 11, 2011

Contributor

Good catch. We'll take a look now.

Contributor

toddparker commented Nov 11, 2011

Good catch. We'll take a look now.

@ghost ghost assigned Wilto Nov 11, 2011

hpbuniat pushed a commit to hpbuniat/jquery-mobile that referenced this issue Nov 13, 2011

@toddparker

This comment has been minimized.

Show comment
Hide comment
@toddparker

toddparker Nov 15, 2011

Contributor

@agcolom - we're trying to track so stuff down on themes and now when we look at your two fiddles, they both look ok. Wondering is this issue was due to latest being out of sync?

Can you check to see if you can reproduce this issue on RC2, RC3 or latest?

Contributor

toddparker commented Nov 15, 2011

@agcolom - we're trying to track so stuff down on themes and now when we look at your two fiddles, they both look ok. Wondering is this issue was due to latest being out of sync?

Can you check to see if you can reproduce this issue on RC2, RC3 or latest?

@toddparker

This comment has been minimized.

Show comment
Hide comment
@toddparker

toddparker Nov 15, 2011

Contributor

Here is a fiddle running RC3 and it doesn't appear there:
http://jsfiddle.net/zYXLS/7/

Same goes for RC2 and latest. Feel like I'm losing my mind here.

Contributor

toddparker commented Nov 15, 2011

Here is a fiddle running RC3 and it doesn't appear there:
http://jsfiddle.net/zYXLS/7/

Same goes for RC2 and latest. Feel like I'm losing my mind here.

@agcolom

This comment has been minimized.

Show comment
Hide comment
@agcolom

agcolom Nov 16, 2011

Member

@toddparker I did check this yesterday with RC3 and the problem does not appear. I still get it with latest, so is latest still out of sync?
The latest: http://jsfiddle.net/agcolom/zYXLS/3/ (shows issue) (with FF 7.0.1 and Safari 5.0.5 both Mac OS)
RC2: http://jsfiddle.net/agcolom/zYXLS/2/ (doesn't show issue)
RC3: http://jsfiddle.net/agcolom/zYXLS/5/ (doesn't show issue)

Member

agcolom commented Nov 16, 2011

@toddparker I did check this yesterday with RC3 and the problem does not appear. I still get it with latest, so is latest still out of sync?
The latest: http://jsfiddle.net/agcolom/zYXLS/3/ (shows issue) (with FF 7.0.1 and Safari 5.0.5 both Mac OS)
RC2: http://jsfiddle.net/agcolom/zYXLS/2/ (doesn't show issue)
RC3: http://jsfiddle.net/agcolom/zYXLS/5/ (doesn't show issue)

@agcolom

This comment has been minimized.

Show comment
Hide comment
@agcolom

agcolom Nov 16, 2011

Member

The issue shown with a data-theme to the page: http://jsfiddle.net/agcolom/zYXLS/10/ the background restarts after the end of the content.

Member

agcolom commented Nov 16, 2011

The issue shown with a data-theme to the page: http://jsfiddle.net/agcolom/zYXLS/10/ the background restarts after the end of the content.

Wilto added a commit that referenced this issue Nov 16, 2011

Correctly addresses #3020 — “Content” elements now correctly apply th…
…emes, but do not inherit the theme set on the overall page.

@Wilto Wilto closed this Nov 16, 2011

@agcolom

This comment has been minimized.

Show comment
Hide comment
@agcolom

agcolom Nov 16, 2011

Member

yep, the issue is now fixed. Thank you :-)

Member

agcolom commented Nov 16, 2011

yep, the issue is now fixed. Thank you :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment