Skip to content

using custom themeroller theme breaks ajax transitions #3434

Closed
rbdcti opened this Issue Jan 14, 2012 · 2 comments

1 participant

@rbdcti
rbdcti commented Jan 14, 2012

Test case:
http://web01.paramise.com/jqmtest1/test1.html

Use case:

  • This problem does not exist from a master from 2 weeks ago, so it's recent (page transition merge broke it I think).
  • Simple 2 tab layout using ajax transitions.
  • Just made a theme in the themeroller on the site.
  • Just compiled jquery from master I got 30 min ago.
  • Click Test 2 at the bottom. Notice that the JS will fire off and the page will be loaded into the DOM, but you won't see it. CSS bug.
  • If the jquery.mobile.css include there at the top is uncommented on the pages, then it will work fine and you will still have the custom styles (as long as it comes first). This is the temp fix.
  • I'm thinking themeroller needs to be updated to include some missing CSS styles/tweaks that were recently added.
@rbdcti
rbdcti commented Jan 14, 2012

A few things:

  • I just noticed theme roller has its own page. I've posted this bug over there (see jquery/themeroller.jquerymobile.com#67). It can be closed here if a maintainer wishes. Sorry about that.
  • I downloaded the newest themeroller master from trunk and installed that. Issue persists.
@rbdcti
rbdcti commented Apr 10, 2012

Addressed with the 1.1RC1 release. Things work fine in this regard now.

@rbdcti rbdcti closed this Apr 10, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.