Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

jquery mobile select doesn't work when I use wizard #3991

Closed
noctrona opened this Issue Apr 9, 2012 · 1 comment

Comments

Projects
None yet
2 participants

noctrona commented Apr 9, 2012

Hi,

I have a html page in my Android(2.2) project, I invoke this html page by the WebView's loadUrl() function.
And in this page I want to achieve the pagination. So I use jquery mobile wizard and

tag to distinguish each section.
The following is my import js and css:

<link rel="stylesheet" href="../jquery/jquery.mobile-1.0.1.min.css" />
<link rel="stylesheet" href="../jquery/jquery.mobile.wizard.css" />
<script src="../jquery/jquery-1.6.4.min.js"></script>
<script src="../jquery/jquery.mobile-1.0.1.min.js"></script>
<script src="../jquery/jquery.mobile.wizard.js"></script>

I use (data-native-menu="false") in my select tag. When I run my project, the pagination can achieve, but all the select can't work.
And if I set the (data-native-menu="true"), when I click a select, I will see the options by the native effect, but if I select one option, the value can't display on select tag.
Then I add this (data-role="none") in my select tag and set (data-native-menu="false"), the select works well.

                        <select name="company_select" id="company_select" data-role="none" data-native-menu="false">
                            <option value="c_Intel">Intel</option>
                            <option value="c_avaya">Avaya</option>
                            <option value="c_oracle">Oracle</option>
                        </select>

So I don't know why this happened, whether there are some conflicts between my js files?

Contributor

toddparker commented Apr 9, 2012

Probably a conflict with that other script. I'd take a look at how it's attaching behavior to the form elements to see if it's conflicting with our default behavior. Closing since this seems to be an issue with external code.

@toddparker toddparker closed this Apr 9, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment