Skip to content
This repository

Ajax page loading does not work on Firefox 4 with JQM 1.1.0 and 1.1.1 #4957

Closed
connyhald opened this Issue · 4 comments

2 participants

Cornelius Hald Jasper de Groot
Cornelius Hald

Clicking a link just displays an empty page while changing the URL. It looks like the "ui-page-active" class is not properly set. Refreshing the page properly displays it.

To reproduce simply open the demo pages of JQM 1.1.0 or 1.1.1 and click on "Pages & Dialogs". The same works on JQM 1.0.0 and 1.0.1.

Not working:
http://jquerymobile.com/demos/1.1.0/
http://jquerymobile.com/demos/1.1.1/

Working:
http://jquerymobile.com/demos/1.0.0/
http://jquerymobile.com/demos/1.0.1/

I know Firefox 4 is very old, but the documentation still says that it's supported.
References regarding this issues can also be found here:
http://stackoverflow.com/questions/11494806/jquery-mobile-multipage-not-displaying-in-firefox-4
http://forum.jquery.com/topic/multipage-not-displaying-in-firefox-4

Jasper de Groot
Owner

@connyhald

Can you confirm that it works if you set transitions to "none"?

Cornelius Hald

@uGoMobi Yes, you're right. Disabling page transitions helps.

Jasper de Groot
Owner

@connyhald

Thanks for reporting back. It is a regression that came with the transitions revamp for 1.1. Will try to find out what exactly is causing the problem.

Cornelius Hald connyhald closed this
Cornelius Hald connyhald reopened this
Jasper de Groot
Owner
uGoMobi commented

Closing this ticket because we no longer support Firefox 4 as A-grade. See also ticket #5953.

Jasper de Groot uGoMobi closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.