Skip to content

Loading…

jQuery 1.3.0 beta 1 incompatible with jQuery.noConflict() #5448

Closed
KennyDs opened this Issue · 5 comments

4 participants

@KennyDs

1) Latest stable JQM alongside JQ 1.8.2 with noConflict() mode
2) JQM 1.3 beta 1 alongside JQ 1.8.3 with noConflict() mode

As you can see on the fiddles above the following error is produces in case 2:

Uncaught TypeError: Object function (el, nc){
return document.id(el, nc, this.document);
} has no method 'type'

OS: Ubuntu Linux
Browser: Chrome

@johnbender johnbender was assigned
@johnbender

This one's my fault. Need to wrap the path helper module in an anon func.

@johnbender

@KennyDs

http://jsfiddle.net/rZqzC/2/

Let me know if you run into issues, this will most likely end up in a second beta or our first rc.

@KennyDs

Thanks for the quick feedback, much appreciated ;)

@OZZlE

Was this really fixed? When I include jquery mobile 1.3.0 in my site it will not load properly! The page is displayed at first then it dissapears! :S

If I include jquery.mobile-1.0a2.min.js instead it will load fine but it craps up the viewport on mobiles!

This bug was reported 2 years ago even: http://forum.jquery.com/topic/noconflict-jquery-mobile

@toddparker

@OZZlE - If you're having issues, please provide a jsbin test page so we can take a look. See our contributing guidelines: https://github.com/jquery/jquery-mobile/blob/master/CONTRIBUTING.md

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.