jQuery 1.3.0 beta 1 incompatible with jQuery.noConflict() #5448

Closed
kennydeckers opened this Issue Jan 15, 2013 · 5 comments

Comments

Projects
None yet
4 participants
@kennydeckers
  1. Latest stable JQM alongside JQ 1.8.2 with noConflict() mode
  2. JQM 1.3 beta 1 alongside JQ 1.8.3 with noConflict() mode

As you can see on the fiddles above the following error is produces in case 2:

Uncaught TypeError: Object function (el, nc){ return document.id(el, nc, this.document); } has no method 'type'

OS: Ubuntu Linux
Browser: Chrome

@ghost ghost assigned johnbender Jan 15, 2013

@johnbender

This comment has been minimized.

Show comment
Hide comment
@johnbender

johnbender Jan 15, 2013

Contributor

This one's my fault. Need to wrap the path helper module in an anon func.

Contributor

johnbender commented Jan 15, 2013

This one's my fault. Need to wrap the path helper module in an anon func.

@johnbender

This comment has been minimized.

Show comment
Hide comment
@johnbender

johnbender Jan 15, 2013

Contributor

@kennyds

http://jsfiddle.net/rZqzC/2/

Let me know if you run into issues, this will most likely end up in a second beta or our first rc.

Contributor

johnbender commented Jan 15, 2013

@kennyds

http://jsfiddle.net/rZqzC/2/

Let me know if you run into issues, this will most likely end up in a second beta or our first rc.

@kennydeckers

This comment has been minimized.

Show comment
Hide comment
@kennydeckers

kennydeckers Jan 16, 2013

Thanks for the quick feedback, much appreciated ;)

Thanks for the quick feedback, much appreciated ;)

@OZZlE

This comment has been minimized.

Show comment
Hide comment
@OZZlE

OZZlE Apr 8, 2013

Was this really fixed? When I include jquery mobile 1.3.0 in my site it will not load properly! The page is displayed at first then it dissapears! :S

If I include jquery.mobile-1.0a2.min.js instead it will load fine but it craps up the viewport on mobiles!

This bug was reported 2 years ago even: http://forum.jquery.com/topic/noconflict-jquery-mobile

OZZlE commented Apr 8, 2013

Was this really fixed? When I include jquery mobile 1.3.0 in my site it will not load properly! The page is displayed at first then it dissapears! :S

If I include jquery.mobile-1.0a2.min.js instead it will load fine but it craps up the viewport on mobiles!

This bug was reported 2 years ago even: http://forum.jquery.com/topic/noconflict-jquery-mobile

@toddparker

This comment has been minimized.

Show comment
Hide comment
@toddparker

toddparker Apr 8, 2013

Contributor

@OZZlE - If you're having issues, please provide a jsbin test page so we can take a look. See our contributing guidelines: https://github.com/jquery/jquery-mobile/blob/master/CONTRIBUTING.md

Contributor

toddparker commented Apr 8, 2013

@OZZlE - If you're having issues, please provide a jsbin test page so we can take a look. See our contributing guidelines: https://github.com/jquery/jquery-mobile/blob/master/CONTRIBUTING.md

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment