[Windows RT] (IE10.0.9200.16635) - Open Demo button does nothing #6344

Closed
MaxiusMedia opened this Issue Aug 15, 2013 · 12 comments

Comments

Projects
None yet
2 participants
@jaspermdegroot

This comment has been minimized.

Show comment
Hide comment
@jaspermdegroot

jaspermdegroot Aug 15, 2013

Member

@MaxiusM

Can you test this with latest code: http://view.jquerymobile.com/master/demos/examples/ ? Thanks!
Note that we haven't updated those demos yet so the demo itself is probably broken. This view on latest code is a bit slower than a build like the 1.3.2 links you posted.

Member

jaspermdegroot commented Aug 15, 2013

@MaxiusM

Can you test this with latest code: http://view.jquerymobile.com/master/demos/examples/ ? Thanks!
Note that we haven't updated those demos yet so the demo itself is probably broken. This view on latest code is a bit slower than a build like the 1.3.2 links you posted.

@jaspermdegroot

This comment has been minimized.

Show comment
Hide comment
@jaspermdegroot

jaspermdegroot Aug 15, 2013

Member

@MaxiusM

Nevermind. I just tested on Win 7 / IE10 and can reproduce the problem there, also with latest code.

Member

jaspermdegroot commented Aug 15, 2013

@MaxiusM

Nevermind. I just tested on Win 7 / IE10 and can reproduce the problem there, also with latest code.

@MaxiusMedia

This comment has been minimized.

Show comment
Hide comment
@MaxiusMedia

MaxiusMedia Aug 15, 2013

I just tested, and it's still a problem there for me too.

I did also find a problem with
http://view.jquerymobile.com/1.3.2/dist/demos/examples/slider/tooltip.html
in trying to move the dots using my finger, but it's fixed in
http://view.jquerymobile.com/master/demos/examples/slider/tooltip.php
already. :)

I just tested, and it's still a problem there for me too.

I did also find a problem with
http://view.jquerymobile.com/1.3.2/dist/demos/examples/slider/tooltip.html
in trying to move the dots using my finger, but it's fixed in
http://view.jquerymobile.com/master/demos/examples/slider/tooltip.php
already. :)

@MaxiusMedia

This comment has been minimized.

Show comment
Hide comment
@MaxiusMedia

MaxiusMedia Aug 15, 2013

I just had a further look, and noticed something that might be of help: When you click the "Open Demo" button, the url goes from
/panels/panel-styling.html
to
/panels/panel-styling.html#demo-page
but the page doesn't actually transition.
Not sure if something is capturing and ignoring the page load/change event?

I just had a further look, and noticed something that might be of help: When you click the "Open Demo" button, the url goes from
/panels/panel-styling.html
to
/panels/panel-styling.html#demo-page
but the page doesn't actually transition.
Not sure if something is capturing and ignoring the page load/change event?

@jaspermdegroot

This comment has been minimized.

Show comment
Hide comment
@jaspermdegroot

jaspermdegroot Aug 15, 2013

Member

@MaxiusM - The problem is the data-ajax="false" on the link while we navigate to a JQM page in the same HTML document, i.e. we don't need to disable AJAX navigation. Fix is on its way.

Member

jaspermdegroot commented Aug 15, 2013

@MaxiusM - The problem is the data-ajax="false" on the link while we navigate to a JQM page in the same HTML document, i.e. we don't need to disable AJAX navigation. Fix is on its way.

@MaxiusMedia

This comment has been minimized.

Show comment
Hide comment
@MaxiusMedia

MaxiusMedia Aug 15, 2013

👍 Awesome, thanks for that.. hopefully I won't find anything else :)

👍 Awesome, thanks for that.. hopefully I won't find anything else :)

@jaspermdegroot

This comment has been minimized.

Show comment
Hide comment
@jaspermdegroot

jaspermdegroot Aug 15, 2013

Member

@MaxiusM

I couldn't reproduce the issue with http://view.jquerymobile.com/1.3.2/dist/demos/examples/swipe/swipe-page.html on Win 7 / IE10. We don't add data-ajax="false" there. Can you investigate a bit more on Win RT? Same problem with http://view.jquerymobile.com/master/demos/examples/swipe/newyork.html? Thanks again.

Member

jaspermdegroot commented Aug 15, 2013

@MaxiusM

I couldn't reproduce the issue with http://view.jquerymobile.com/1.3.2/dist/demos/examples/swipe/swipe-page.html on Win 7 / IE10. We don't add data-ajax="false" there. Can you investigate a bit more on Win RT? Same problem with http://view.jquerymobile.com/master/demos/examples/swipe/newyork.html? Thanks again.

@jaspermdegroot

This comment has been minimized.

Show comment
Hide comment
@jaspermdegroot

jaspermdegroot Aug 15, 2013

Member

@arschmitz @gabrielschulhof - It doesn't make sense to add data-ajax="false" to a link to a page in the same HTML document, but I wonder why it's causing the page not to load on IE10 while it doesn't cause an issue on Chrome for example.

Member

jaspermdegroot commented Aug 15, 2013

@arschmitz @gabrielschulhof - It doesn't make sense to add data-ajax="false" to a link to a page in the same HTML document, but I wonder why it's causing the page not to load on IE10 while it doesn't cause an issue on Chrome for example.

@MaxiusMedia

This comment has been minimized.

Show comment
Hide comment
@MaxiusMedia

MaxiusMedia Aug 15, 2013

The only obvious thing IE is complaining about is the unmatched tag here:
< p >Here some text.< /small >< /p >
But that shouldn't break it..

The behavior is the same as previously though;
Navigating to http://view.jquerymobile.com/1.3.2/dist/demos/examples/swipe/swipe-page.html
and then clicking the "Open demo" button changes the url to
http://view.jquerymobile.com/1.3.2/dist/demos/examples/swipe/newyork.html
but doesn't load.

Having IE Developer tools open whilst using WinRT's Desktop IE10 version, I monitored the Network tab.
Amongst other lines, there is:

When loading the swipe-page.php:
..../swipe/newyork.html | Method GET | Result 304 | Initiator XMLHttpRequest

After loading is complete, I clicked the button and it does
..../swipe/newyork.html | Method nothing | Result (Aborted) | Initiator click

(url shows newyork.html, as does the tab = "New York") - but nothing changes.

Wait a bit, then I clicked the button and it does
..../swipe/newyork.html | Method nothing | Result (Aborted) | Initiator click

Nothing changes.

Wait a bit, then I clicked the button and it does
..../swipe/newyork.html | Method GET | Result 200 | Initiator click

Nothing changes.

Wait a bit, then I clicked the button and it does
..../swipe/newyork.html | Method GET | Result 200 | Initiator click

Nothing changes..

The only obvious thing IE is complaining about is the unmatched tag here:
< p >Here some text.< /small >< /p >
But that shouldn't break it..

The behavior is the same as previously though;
Navigating to http://view.jquerymobile.com/1.3.2/dist/demos/examples/swipe/swipe-page.html
and then clicking the "Open demo" button changes the url to
http://view.jquerymobile.com/1.3.2/dist/demos/examples/swipe/newyork.html
but doesn't load.

Having IE Developer tools open whilst using WinRT's Desktop IE10 version, I monitored the Network tab.
Amongst other lines, there is:

When loading the swipe-page.php:
..../swipe/newyork.html | Method GET | Result 304 | Initiator XMLHttpRequest

After loading is complete, I clicked the button and it does
..../swipe/newyork.html | Method nothing | Result (Aborted) | Initiator click

(url shows newyork.html, as does the tab = "New York") - but nothing changes.

Wait a bit, then I clicked the button and it does
..../swipe/newyork.html | Method nothing | Result (Aborted) | Initiator click

Nothing changes.

Wait a bit, then I clicked the button and it does
..../swipe/newyork.html | Method GET | Result 200 | Initiator click

Nothing changes.

Wait a bit, then I clicked the button and it does
..../swipe/newyork.html | Method GET | Result 200 | Initiator click

Nothing changes..

@MaxiusMedia

This comment has been minimized.

Show comment
Hide comment
@MaxiusMedia

MaxiusMedia Aug 15, 2013

http://view.jquerymobile.com/master/demos/examples/panels/panel-styling.php
works now.

http://view.jquerymobile.com/master/demos/examples/panels/panel-swipe-open.php
also works, but when you try and swipe either way, it tries to navigate the browser. (e.g. swiping right is like clicking the back nav button)

http://view.jquerymobile.com/master/demos/examples/panels/panel-styling.php
works now.

http://view.jquerymobile.com/master/demos/examples/panels/panel-swipe-open.php
also works, but when you try and swipe either way, it tries to navigate the browser. (e.g. swiping right is like clicking the back nav button)

@MaxiusMedia

This comment has been minimized.

Show comment
Hide comment
@MaxiusMedia

MaxiusMedia Aug 15, 2013

@uGoMobi Sorry forgot to tag you

@uGoMobi Sorry forgot to tag you

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment