Skip to content
Permalink
Browse files
Build: Update to the latest version of Grunt & many other packages
JSHint, JSCS & QUnit-related packages are not updated as they need more code
adjustments.

Fixes #15112
Closes gh-1882
  • Loading branch information
mikhey authored and mgol committed Oct 14, 2020
1 parent f5d38e2 commit a22361dbe491c494a87f38600d9c1f91aa07d3e0
Show file tree
Hide file tree
Showing 6 changed files with 28 additions and 24 deletions.
@@ -7,6 +7,7 @@
"import": false,
"important": false,
"outline-none": false,
"order-alphabetical": false,
"overqualified-elements": false,
"text-indent": false
}
@@ -3,6 +3,7 @@ module.exports = function( grunt ) {
"use strict";

var
glob = require( "glob" ),

// files
coreFiles = [
@@ -93,7 +94,7 @@ function mapMinFile( file ) {
}

function expandFiles( files ) {
return grunt.util._.pluck( grunt.file.expandMapping( files ), "src" ).map( function( values ) {
return grunt.util._.map( grunt.file.expandMapping( files ), "src" ).map( function( values ) {
return values[ 0 ];
} );
}
@@ -133,7 +134,7 @@ function createBanner( files ) {
"<%= pkg.homepage ? '* ' + pkg.homepage + '\\n' : '' %>" +
( files ? "* Includes: " + fileNames.join( ", " ) + "\n" : "" ) +
"* Copyright <%= pkg.author.name %>;" +
" Licensed <%= _.pluck(pkg.licenses, 'type').join(', ') %> */\n";
" Licensed <%= _.map(pkg.licenses, 'type').join(', ') %> */\n";
}

grunt.initConfig( {
@@ -202,17 +203,18 @@ grunt.initConfig( {
ignore: [
/The text content of element “script” was not in the required format: Expected space, tab, newline, or slash but found “.” instead/
] },
src: [ "demos/**/*.html", "tests/**/*.html" ].concat( htmllintBad.map( function( file ) {
return "!" + file;
} ) )
src: glob.sync("{demos,tests}/**/*.html", {
ignore: htmllintBad
} )
},
bad: {
options: {
ignore: [
/Start tag seen without seeing a doctype first/,
/Element “head” is missing a required instance of child element “title”/,
/Element “object” is missing one or more of the following/,
/The “codebase” attribute on the “object” element is obsolete/
/The “codebase” attribute on the “object” element is obsolete/,
/Consider adding a “lang” attribute to the “html” start tag/
]
},
src: htmllintBad
@@ -49,23 +49,24 @@
"jquery": ">=1.8.0 <4.0.0"
},
"devDependencies": {
"commitplease": "2.3.0",
"grunt": "0.4.5",
"grunt-bowercopy": "1.2.4",
"grunt-cli": "0.1.13",
"grunt-compare-size": "0.4.0",
"grunt-contrib-concat": "0.5.1",
"grunt-contrib-csslint": "0.5.0",
"commitplease": "3.2.0",
"glob": "7.1.6",
"grunt": "1.3.0",
"grunt-bowercopy": "1.2.5",
"grunt-cli": "1.3.2",
"grunt-compare-size": "0.4.2",
"grunt-contrib-concat": "1.0.1",
"grunt-contrib-csslint": "2.0.0",
"grunt-contrib-jshint": "0.12.0",
"grunt-contrib-qunit": "1.0.1",
"grunt-contrib-requirejs": "0.4.4",
"grunt-contrib-uglify": "0.11.1",
"grunt-git-authors": "3.1.0",
"grunt-html": "6.0.0",
"grunt-contrib-requirejs": "1.0.0",
"grunt-contrib-uglify": "5.0.0",
"grunt-git-authors": "3.2.0",
"grunt-html": "14.2.0",
"grunt-jscs": "2.1.0",
"load-grunt-tasks": "3.4.0",
"rimraf": "2.5.1",
"testswarm": "1.1.0"
"load-grunt-tasks": "5.1.0",
"rimraf": "3.0.2",
"testswarm": "1.1.2"
},
"keywords": []
}
@@ -1,5 +1,5 @@
<!doctype html>
<html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>Menu Visual Test: Default</title>
@@ -1,5 +1,5 @@
<!doctype html>
<html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>Selectmenu Visual Test: Default</title>
@@ -1,6 +1,6 @@
<!DOCTYPE html>
<html>
<head lang="en">
<html lang="en">
<head>
<meta charset="UTF-8">
<title>jQuery UI Slider - Range slider</title>
<link rel="stylesheet" href="../../../themes/base/all.css">

0 comments on commit a22361d

Please sign in to comment.