Warn on unsupported browsers #226

Open
rxaviers opened this Issue Mar 27, 2013 · 4 comments

4 participants

@rxaviers
jQuery Foundation member

Sites currently support:

  • IE: >= 8
  • Firefox and Chrome: current major X - 1 (X.y.z)
  • Safari and Opera: current minor Y - 1 (x.Y.y)

For the browsers we have known-bugs at least, eg. IE<8 (known to be buggy and not supported on download builder), we could warn users like the example below:
unspoported

@rxaviers rxaviers referenced this issue in jquery/download.jqueryui.com Mar 27, 2013
Closed

List browsers that ThemeRoller works with #130

@arthurvr
jQuery Foundation member

👍 on this. Why not to link up something like http://browsehappy.com or http://outdatedbrowser.com?

Could be done using conditional comments, but those wouldn't catch old versions of other browsers.

@scottgonzalez
jQuery Foundation member

To be honest, we probably only care about catching old IE, if we really care about anything at all.

While we technically only support current - 1 for other browsers, in most cases even current - 10 will work just fine.

@mgol
jQuery Foundation member

I assume we'll be dropping IE8 compatibility with the release of jQuery 3.0.0; it would be bad if we couldn't upgrade to the latest version.

We could display a banner to IE<9 using conditional comments, I agree with @scottgonzalez that other browsers are not that important; the majority of old browsers visiting our sites will be old IE.

@arthurvr
jQuery Foundation member

I assume we'll be dropping IE8 compatibility with the release of jQuery 3.0.0; it would be bad if we couldn't upgrade to the latest version.

👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment