Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 91 lines (90 sloc) 1.994 kb
1434b5b @rwaldron Initial grunt implementation
rwaldron authored
1 {
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
2 "name": "jquery",
3 "title": "jQuery",
4 "description": "JavaScript library for DOM operations",
7a607c5 @timmywil Build: update version to 3.0.0-pre
timmywil authored
5 "version": "3.0.0-pre",
6fde975 @timmywil Fixes #14548. Add main property to package.json
timmywil authored
6 "main": "dist/jquery.js",
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
7 "homepage": "http://jquery.com",
8 "author": {
9 "name": "jQuery Foundation and other contributors",
10 "url": "https://github.com/jquery/jquery/blob/master/AUTHORS.txt"
11 },
12 "repository": {
13 "type": "git",
14 "url": "https://github.com/jquery/jquery.git"
15 },
16 "keywords": [
17 "jquery",
18 "javascript",
bbace10 @markelog Build: Spaces vs tabs
markelog authored
19 "browser",
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
20 "library"
21 ],
22 "bugs": {
3e89a53 @arthurvr Misc: Update all references to bugs.jquery.com
arthurvr authored
23 "url": "https://github.com/jquery/jquery/issues"
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
24 },
25 "licenses": [
26 {
27 "type": "MIT",
4f776e5 @scottgonzalez Build: Update license
scottgonzalez authored
28 "url": "https://github.com/jquery/jquery/blob/master/LICENSE.txt"
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
29 }
30 ],
31 "dependencies": {},
32 "devDependencies": {
5bc1ddc @jzaefferer Build: Upgrade to commitplease 2.0.0
jzaefferer authored
33 "commitplease": "2.0.0",
8e3a0ce @timmywil Build: update node dependencies barring jscs
timmywil authored
34 "grunt": "0.4.5",
d63243d @mzgol Build: Upgrade npm devDependencies
mzgol authored
35 "grunt-cli": "0.1.13",
3ffd95b @jzaefferer Package: Sort devDependencies
jzaefferer authored
36 "grunt-compare-size": "0.4.0",
269a27c @timmywil Build: update source map options for the new grunt jshint
timmywil authored
37 "grunt-contrib-jshint": "0.10.0",
a76c781 @timmywil Release: remove sourcemap comment from all copies of minified file
timmywil authored
38 "grunt-contrib-uglify": "0.7.0",
8e3a0ce @timmywil Build: update node dependencies barring jscs
timmywil authored
39 "grunt-contrib-watch": "0.6.1",
9101704 @timmywil Build: update node dependencies
timmywil authored
40 "grunt-git-authors": "2.0.1",
41 "grunt-jscs-checker": "0.8.1",
3ffd95b @jzaefferer Package: Sort devDependencies
jzaefferer authored
42 "grunt-jsonlint": "1.0.4",
e1949f4 @timmywil Build: drop bower; use npm for front-end deps
timmywil authored
43 "grunt-npmcopy": "0.1.0",
3ffd95b @jzaefferer Package: Sort devDependencies
jzaefferer authored
44 "gzip-js": "0.3.2",
9101704 @timmywil Build: update node dependencies
timmywil authored
45 "load-grunt-tasks": "1.0.0",
f5aa89a @mzgol Build: Update native-promise-only (again)
mzgol authored
46 "native-promise-only": "0.7.8-a",
555a50d @gibson042 Deferred: Backwards-compatible standards interoperability
gibson042 authored
47 "promises-aplus-tests": "2.1.0",
48 "q": "1.1.2",
2d5c5d2 @jzaefferer Build: Update QUnit to latest (1.17.1)
jzaefferer authored
49 "qunitjs": "1.17.1",
a644101 @markelog Build: update requirejs dependency to 2.1.17
markelog authored
50 "requirejs": "2.1.17",
98c25b7 @timmywil Build: save sinon update for later
timmywil authored
51 "sinon": "1.10.3",
3a0dd5a @timmywil Build: update Sizzle
timmywil authored
52 "sizzle": "2.2.0",
ab40725 @mzgol Core: Test all factory use cases from intro.js
mzgol authored
53 "testswarm": "1.1.0",
54 "win-spawn": "2.0.0"
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
55 },
5c3101f @timmywil Build: use different versions of jsdom for Node and iojs testing
timmywil authored
56 "jsdomVersions": {
57 "node": "3.1.2",
58 "iojs": "5.3.0"
59 },
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
60 "scripts": {
ac7ff97 @timmywil Use grunt and bower packages as local dependencies. Close gh-1433.
timmywil authored
61 "build": "npm install && grunt",
62 "start": "grunt watch",
bb928bd @gibson042 Build: Rearrange grunt/npm tasks into a build/dist/test pattern
gibson042 authored
63 "test": "grunt && grunt test"
0c9d018 @gibson042 Build: Specify valid components for commit messages
gibson042 authored
64 },
65 "commitplease": {
66 "components": [
67 "Docs",
68 "Tests",
69 "Build",
70 "Release",
71 "Core",
72 "Ajax",
73 "Attributes",
74 "Callbacks",
75 "CSS",
76 "Data",
77 "Deferred",
78 "Dimensions",
79 "Effects",
80 "Event",
81 "Manipulation",
82 "Offset",
83 "Queue",
84 "Selector",
85 "Serialize",
a4133ff @dmethvin Build: Sanctify the component name status of Wrap
dmethvin authored
86 "Traversing",
87 "Wrap"
0c9d018 @gibson042 Build: Specify valid components for commit messages
gibson042 authored
88 ]
310b8f5 @timmywil Update requirejs to compatible version, remove r.js
timmywil authored
89 }
1434b5b @rwaldron Initial grunt implementation
rwaldron authored
90 }
Something went wrong with that request. Please try again.