Skip to content
Permalink
Browse files

Tests: Skip nonce tests in old iOS/Android as well

Old iOS & Android Browser versions support script-src but not nonce, making the
nonce test impossible to run. Browsers not supporting CSP at all are not
a problem as they'll skip script-src restrictions completely.

Ref gh-3541
Ref gh-4269
Ref c7c2855
  • Loading branch information...
mgol committed Jan 14, 2019
1 parent c7c2855 commit 543d3d24eaefe09c4012171f30267783d51602dc
Showing with 5 additions and 2 deletions.
  1. +5 −2 test/unit/manipulation.js
@@ -2850,8 +2850,11 @@ testIframe(
} );
},

// Support: Edge 18+
// Support: Edge 18+, iOS 7-9 only, Android 4.0-4.4 only
// Edge doesn't support nonce in non-inline scripts.
// See https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/13246371/
QUnit[ /\bedge\//i.test( navigator.userAgent ) ? "skip" : "test" ]
// Old iOS & Android Browser versions support script-src but not nonce, making this test
// impossible to run. Browsers not supporting CSP at all are not a problem as they'll skip
// script-src restrictions completely.
QUnit[ /\bedge\/|iphone os [789]|android 4\./i.test( navigator.userAgent ) ? "skip" : "test" ]
);

0 comments on commit 543d3d2

Please sign in to comment.
You can’t perform that action at this time.