Skip to content
Permalink
Browse files

Effects: Don't check fill-opacity in Android 2.3, it's not supported

  • Loading branch information
mgol committed Feb 14, 2014
1 parent 6d2ab64 commit 70ac4485f30633074696fa28ca29b0325459f228
Showing with 6 additions and 1 deletion.
  1. +6 −1 test/unit/effects.js
@@ -1357,7 +1357,12 @@ test("Do not append px to 'fill-opacity' #9548", 1, function() {
var $div = jQuery("<div>").appendTo("#qunit-fixture");

$div.css("fill-opacity", 0).animate({ "fill-opacity": 1.0 }, 0, function () {
equal( jQuery(this).css("fill-opacity"), 1, "Do not append px to 'fill-opacity'");
// Support: Android 2.3 (no support for fill-opacity)
if ( jQuery( this ).css( "fill-opacity" ) ) {
equal( jQuery( this ).css( "fill-opacity" ), 1, "Do not append px to 'fill-opacity'" );
} else {
ok( true, "No support for fill-opacity CSS property" );
}
$div.remove();
});
});

0 comments on commit 70ac448

Please sign in to comment.
You can’t perform that action at this time.