Permalink
Browse files

Docs: 1.x-master branch -> compat branch; 2.x branch -> master branch

  • Loading branch information...
timmywil committed Nov 3, 2014
1 parent 7a607c5 commit 758fd6cea9e82f7bfebce07ba6ecf0d107e8a53c
Showing with 3 additions and 4 deletions.
  1. +1 −1 CONTRIBUTING.md
  2. +2 −2 README.md
  3. +0 −1 src/manipulation.js
View
@@ -211,4 +211,4 @@ This will only run the "css" module tests. This will significantly speed up your
Remember that jQuery supports multiple browsers and their versions; any contributed code must work in all of them. You can refer to the [browser support page](http://jquery.com/browser-support/) for the current list of supported browsers.
Note that browser support differs depending on whether you are targeting the `master` or `1.x-master` branch.
Note that browser support differs depending on whether you are targeting the `master` or `compat` branch.
View
@@ -14,8 +14,8 @@ In the spirit of open source software development, jQuery always encourages comm
Environments in which to use jQuery
--------------------------------------
- [Browser support](http://jquery.com/browser-support/) differs between the master (2.x) branch and the 1.x-master branch. Specifically, 2.x does not support legacy browsers such as IE6-8. The jQuery team continues to provide support for legacy browsers on the 1.x-master branch. Use the latest 1.x release if support for those browsers is required. See [browser support](http://jquery.com/browser-support/) for more info.
- To use jQuery in Node, browser extensions, and other non-browser environments, use only **2.x** releases. 1.x does not support these environments.
- [Browser support](http://jquery.com/browser-support/) differs between the master branch and the compat branch. Specifically, the master branch does not support legacy browsers such as IE6-8. The jQuery team continues to provide support for legacy browsers on the compat branch. Use the latest compat release if support for those browsers is required. See [browser support](http://jquery.com/browser-support/) for more info.
- To use jQuery in Node, browser extensions, and other non-browser environments, use only master branch releases given the name "jquery" rather than "jquery-compat". The compat branch does not support these environments.
What you need to build your own jQuery
View
@@ -46,7 +46,6 @@ wrapMap.optgroup = wrapMap.option;
wrapMap.tbody = wrapMap.tfoot = wrapMap.colgroup = wrapMap.caption = wrapMap.thead;
wrapMap.th = wrapMap.td;
// Support: 1.x compatibility
// Manipulating tables requires a tbody
function manipulationTarget( elem, content ) {
return jQuery.nodeName( elem, "table" ) &&

0 comments on commit 758fd6c

Please sign in to comment.