Skip to content
Permalink
Browse files

Build: Remove obsolete globals from ESLint configuration

We had quite a few obsolete globals declared in various ESLint config files. We also no longer allow to rely on the `noGlobal` & `jQuery` globals in the built file which is not needed.

Closes gh-4301
  • Loading branch information...
mgol committed Feb 19, 2019
1 parent 8751e9e commit c10945d0e15c5048ae8b5b7e3f8241ad27671a7c
Showing with 6 additions and 11 deletions.
  1. +1 −3 .eslintrc-browser.json
  2. +5 −1 src/.eslintrc.json
  3. +0 −7 test/.eslintrc.json
@@ -19,10 +19,8 @@

"globals": {
"window": true,
"jQuery": true,
"define": true,
"module": true,
"noGlobal": true
"module": true
},

"rules": {
@@ -1,5 +1,9 @@
{
"root": true,

"extends": "../.eslintrc-browser.json"
"extends": "../.eslintrc-browser.json",

"globals": {
"jQuery": true
}
}
@@ -12,22 +12,15 @@

"globals": {
"require": false,
"define": false,
"DOMParser": false,
"JSON": false,
"Promise": false,
"Symbol": false,
"QUnit": false,
"ajaxTest": false,
"testIframe": false,
"testIframeWithCallback": false,
"iframeCallback": true,
"createDashboardXML": false,
"createXMLFragment": false,
"moduleTeardown": false,
"testFoo": false,
"url": false,
"t": false,
"q": false,
"jQuery": true,
"sinon": true,

0 comments on commit c10945d

Please sign in to comment.
You can’t perform that action at this time.