Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error on Android native browser 4.x #3293

Closed
kennyhk opened this issue Aug 23, 2016 · 6 comments
Closed

Error on Android native browser 4.x #3293

kennyhk opened this issue Aug 23, 2016 · 6 comments

Comments

@kennyhk
Copy link

@kennyhk kennyhk commented Aug 23, 2016

i am using Webpack + babel6, every thing is OK with jQuery v2.2.x;

when update to jQuery v3.0.0 or v3.1.0, a browser run time error will throw on Android v4.4.4;
I have no idea what is the detail of problem because it is hard t trace the compiled code on Android.

Uncaught ReferenceError: __WEBPACK_AMD_DEFINE_ARRAY__ is not defined

@mgol
Copy link
Member

@mgol mgol commented Aug 23, 2016

This is not enough detail for us to work with, unfortunately. Could you
construct a minimal project example that exhibits the problem and share it?

Michał Gołębiowski

@kennyhk
Copy link
Author

@kennyhk kennyhk commented Aug 24, 2016

yes, but may be later.

@timmywil
Copy link
Member

@timmywil timmywil commented Aug 24, 2016

Thanks for opening an issue. Closing until we have more info.

@timmywil timmywil closed this Aug 24, 2016
@kennyhk
Copy link
Author

@kennyhk kennyhk commented Aug 26, 2016

minimal project example is here :
jquery-test.zip

please see read me for detail, thank you

@pwaldhauer
Copy link

@pwaldhauer pwaldhauer commented Oct 12, 2016

Could someone reopen this issue? I have exactly the same problem. @mgol

@dmethvin
Copy link
Member

@dmethvin dmethvin commented Oct 12, 2016

This seems like a debugging-Webpack thing and not a jQuery bug, but someone with more of a stake in the outcome can diagnose and let us know if there is anything we need to change in the way we build jQuery. This may help:

https://webpack.github.io/docs/shimming-modules.html

@lock lock bot locked as resolved and limited conversation to collaborators Jun 18, 2018
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants