JavaScript deprecation warnings in Google Chrome #100

Open
tomascassidy opened this Issue Jun 1, 2012 · 3 comments

Projects

None yet

2 participants

@tomascassidy

Google Chrome is showing the following message in the JavaScript console when JQM ThemeRoller is loaded:

"event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future."

The message is repeated each time the mouse hovers over any swatch element.

Tested on Google Chrome 19.0.1084.52 m on Windows 7 x64

@johnbender

@tomascassidy

This is addressed by upgrading your jquery version to 1.7.1

Thanks for logging the issue though :D

@johnbender johnbender closed this Jun 1, 2012
@tomascassidy

Would this mean that jQuery version should be updated on the JQM themeroller? http://jquerymobile.com/themeroller/ is currently running jQuery 1.6.4. I'm not seeing how upgrading jQuery applies to me, since I'm not running my own version of JQM themeroller.

@johnbender johnbender reopened this Jun 4, 2012
@johnbender

@tomascassidy

Ah, I responded to this issue from my notifications thinking it was for jqm itself. Reopening, and thanks for responding.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment