duplicate swatch css #108

Open
McWatt opened this Issue Sep 7, 2012 · 3 comments

Projects

None yet

2 participants

@McWatt
McWatt commented Sep 7, 2012

I created a 4 swatch theme and the generated CSS has duplicated styles for two of the swatches (B and C in my specific case).

shared theme link:
http://jquerymobile.com/themeroller/?ver=1.1.1&style_id=20120907-62

@tybenz
Contributor
tybenz commented Sep 7, 2012

Can you provide more specifics about the steps you took to create the theme?

I can tell that if you download the theme you can just rip those two swatches out of the CSS, but that won't help identify how ThemeRoller made the error occur.

If you can figure out how to recreate the error and post it, that would be a big help. Things I'm looking for are:

  • At what point did you add or delete any swatches?
  • Did you use the add-swatch or duplicate-swatch buttons?

I know remembering all of that may be tough, and if you can't recreate the error from scratch don't worry. I'll do a sweep through the add/duplicate/delete code either way. Some steps to recreate the error would just help me narrow it down.

@tybenz tybenz was assigned Sep 7, 2012
@McWatt
McWatt commented Sep 7, 2012

Off the top of my head, I remember doing the following:

  • adding a new swatch with the + tab button

These are things I did, but may not have been to this particular theme. I may have re-loaded a previous theme via a share link. I also may have used undo on this theme. Unfortunately i can't remember exactly what I did to which theme.

  • used undo a number of times while tweaking Global and/or Swatch D
  • tried to enter transparent as a background color on a swatch
  • tried to make a background color empty when I couldn't enter transparent (eventually I realized I was going about this all wrong)

I saved some previous versions of the theme. This is the one before I added swatch D, and before the duplicated CSS appeared:

http://jquerymobile.com/themeroller/?ver=1.1.1&style_id=20120906-82

For the one with the duplicate css, when I load it now, I see two broken swatches that were not there before (E and F).

I got my theme back to a working state by manually ripping out the duplicated css and importing it into ThemeRoller.

@McWatt
McWatt commented Sep 7, 2012

Try this:

I believe this causes the duplicated CSS issue, but haven't been able to confirm. I am using the latest stable release of Chrome (ver. 21).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment