Skip to content
This repository
Newer
Older
100644 38 lines (33 sloc) 2.021 kb
a6c2e8dd »
2009-09-22 Added gemspec so github will like me
1 # -*- encoding: utf-8 -*-
2
3 Gem::Specification.new do |s|
4 s.name = %q{authlogic-oauth}
5 s.version = "1.0.8"
6
7 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
8 s.authors = ["John Allison"]
9 s.date = %q{2009-09-22}
10 s.description = %q{An authlogic extension for authenticating via OAuth. This can be helpful for adding support for login/registration with Twitter credentials.}
11 s.email = %q{jrallison@gmail.com}
12 s.extra_rdoc_files = ["Manifest.txt", "CHANGELOG.rdoc", "README.rdoc"]
13 s.files = ["CHANGELOG.rdoc", "MIT-LICENSE", "Manifest.txt", "README.rdoc", "Rakefile", "init.rb", "lib/authlogic_oauth.rb", "lib/authlogic_oauth/acts_as_authentic.rb", "lib/authlogic_oauth/helper.rb", "lib/authlogic_oauth/oauth_process.rb", "lib/authlogic_oauth/session.rb", "lib/authlogic_oauth/version.rb", "lib/oauth_callback_filter.rb", "rails/init.rb", "test/acts_as_authentic_test.rb", "test/fixtures/users.yml", "test/lib/user.rb", "test/lib/user_session.rb", "test/session_test.rb", "test/test_helper.rb"]
14 s.homepage = %q{http://github.com/jrallison/authlogic_oauth}
15 s.rdoc_options = ["--main", "README.rdoc"]
16 s.require_paths = ["lib"]
17 s.rubyforge_project = %q{authlogic-oauth}
18 s.rubygems_version = %q{1.3.5}
19 s.summary = %q{An authlogic extension for authenticating via OAuth. (I.E. Twitter login)}
20 s.test_files = ["test/acts_as_authentic_test.rb", "test/session_test.rb"]
21
22 if s.respond_to? :specification_version then
23 current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
24 s.specification_version = 3
25
26 if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
27 s.add_runtime_dependency(%q<activesupport>, [">= 0"])
28 s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
29 else
30 s.add_dependency(%q<activesupport>, [">= 0"])
31 s.add_dependency(%q<hoe>, [">= 2.3.3"])
32 end
33 else
34 s.add_dependency(%q<activesupport>, [">= 0"])
35 s.add_dependency(%q<hoe>, [">= 2.3.3"])
36 end
37 end
Something went wrong with that request. Please try again.