Permalink
Browse files

Set $LIBTOOLIZE to overide those autogen scripts that try to use

glibtoolize.
  • Loading branch information...
jralls committed Jun 17, 2012
1 parent 313a39d commit 76d6167d72d44381e7983f4f65ee890c931339c8
Showing with 4 additions and 0 deletions.
  1. +4 −0 jhbuildrc-gtk-osx
View
@@ -305,6 +305,10 @@ def setup_sdk(target, sdk_version, architectures=[_default_arch]):
environ_append("OBJCFLAGS", "-mmacosx-version-min=" + target)
environ_append("LDFLAGS", "-mmacosx-version-min=" + target)
+ #Some autogens detect that it's a Mac and use glibtoolize if it's
+ #available. Override this behavior.
+ environ_append('LIBTOOLIZE', os.path.join(prefix, "bin", "libtoolize"))
+
#Overcome Python's obnoxious misconfiguration of portable builds
if len(architectures) == 1:
os.environ["BUILDCFLAGS"] = os.environ["CFLAGS"]

0 comments on commit 76d6167

Please sign in to comment.