New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Invalid Face Reference #234

Closed
jmquigley opened this Issue Aug 5, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@jmquigley

jmquigley commented Aug 5, 2017

The mode is generating the following error over and over:

Invalid face reference: markdown-header-face-7 [105 times]

If I scroll through the document it generates this error hundreds of times. It looks like it is no longer scaling any of the markdown headers either.

Emacs 26.0.5 (in console, using WSL)
Markdown mode latest: 20170803.1101

@jrblevin

This comment has been minimized.

Show comment
Hide comment
@jrblevin

jrblevin Aug 6, 2017

Owner

Does your test file by chance have level-7 headings? HTML, and hence Markdown, only define h1 through h6, so that's all markdown-mode tries to handle.

The bug here most likely is that markdown-mode is trying to apply a non-existent face.

Owner

jrblevin commented Aug 6, 2017

Does your test file by chance have level-7 headings? HTML, and hence Markdown, only define h1 through h6, so that's all markdown-mode tries to handle.

The bug here most likely is that markdown-mode is trying to apply a non-existent face.

@jrblevin jrblevin added the bug label Aug 6, 2017

@jmquigley

This comment has been minimized.

Show comment
Hide comment
@jmquigley

jmquigley Aug 6, 2017

The readme file that I'm working on has a max level header of 4.

https://raw.githubusercontent.com/jmquigley/gadgets/master/README.md

jmquigley commented Aug 6, 2017

The readme file that I'm working on has a max level header of 4.

https://raw.githubusercontent.com/jmquigley/gadgets/master/README.md

@jrblevin

This comment has been minimized.

Show comment
Hide comment
@jrblevin

jrblevin Aug 6, 2017

Owner

Thanks for sending the file. I can reproduce this and will take a closer look soon.

Owner

jrblevin commented Aug 6, 2017

Thanks for sending the file. I can reproduce this and will take a closer look soon.

@jrblevin jrblevin closed this in 09b1074 Aug 30, 2017

@jrblevin

This comment has been minimized.

Show comment
Hide comment
@jrblevin

jrblevin Aug 30, 2017

Owner

It turns out that this was related to the lack of whitespace between some of the headings and the code blocks that followed. It should be fixed now, but let me know if you still see the error.

Owner

jrblevin commented Aug 30, 2017

It turns out that this was related to the lack of whitespace between some of the headings and the code blocks that followed. It should be fixed now, but let me know if you still see the error.

@jmquigley

This comment has been minimized.

Show comment
Hide comment
@jmquigley

jmquigley Aug 30, 2017

This fixed the issue. Thanks.

jmquigley commented Aug 30, 2017

This fixed the issue. Thanks.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment