Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Unable to Install from Github #1

ramnathv opened this Issue · 13 comments

4 participants


The themes look great, but I am unable to install it. I have copied the error log to a gist. I am running Mac OS 10.5.8 and R 2.15.0. Any thoughts on why installation fails?


Mmm. The DESCRIPTION file says it need R version > 2.15.0. Wonder what changed from 2.15.0 to 2.15.1 that crashes the installation.


What's the output of your sessionInfo()?


Here is my sessionInfo

R version 2.15.0 (2012-03-30)
Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit)

[1] en_CA.UTF-8/en_CA.UTF-8/en_CA.UTF-8/C/en_CA.UTF-8/en_CA.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] devtools_0.7.1

loaded via a namespace (and not attached):
[1] digest_0.5.2  httr_0.1.1    memoise_0.1   plyr_1.7.1    RCurl_1.91-1  stringr_0.6.1 tools_2.15.0 

load the ggplot library. library(ggplot2) and then tell me that version. The newest version of ggplot2 0.9.2 has themes replacing opts and element replacing theme. So this package of themes will not work unless you have the newest ggplot2.


To be clear, the Warning: package 'ggplot2' was built under R version 2.15.1 warnings are not your problem. They are just warnings. Is there a reason not obvious to me we think the Error in library.dynam(lib, package, package.lib) :
shared object '' not found
error is a version problem? If I am missing that, my apologies.

Otherwise, @ramnathv, can you load the MASS package in a fresh R session. Next, can you load ggplot2 in a fresh R session.


@karthikram, @ramnathv is using R's package installation interface and @jrnold's code has an explicit dependency on the correct ggplot2 version. Unless that's broken (an unlikely explanation), we can take as given that @ramnathv has met the dependencies based on how far the installation got.


I am using ggplot2_0.9.2 checking from sessionInfo. I also tried explicitly loading MASS and ggplot2 before installing this package, but that does not work either.

I think R 2.15.1 must have changed something that causes this failure. Maybe, it is time to upgrade to 2.15.1 :-)


@ramnathv, this isn't a ggplot or ggplotJrnold issue at all, so figuring the rest of the problem out in this issue thread wouldn't really be appropriate, but if you get stuck, you can shoot me a message. Some last thoughts: reinstall MASS from source, if possible.


I understand. I am just going to install R 2.15.1 and get it over with !

UPDATE: Just upgraded to R 2.15.1 and the installation works smoothly. Maybe, the DESCRIPTION should be changed to indicate that you need R 2.15.1 to use this package, if there is really an issue.

@ramnathv ramnathv closed this

@ramnathv From the error message it looks like the problem was that that for some reason you had some packages built with R 2.15.1, but were using R 2.15.0, with the particular problem coming from MASS. Even the newest version of ggplot only requires R >= 2.14, and the version of ggplot is the only real constraint on the use of this package.

btw, your name looked familiar, and then I realized that you also submitted a restructured text patch to knitr along with me.


Yes. I did! Awesome work with this package. I really love the Tufte theme.


I'm glad you like it! Do you mean the theme where I just set everything to element_blank() :-) ? You might also like geom_tufteboxplot, which is Tufte's minimalist version of the boxplot.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.