Permalink
Browse files

Require newer MX::R::P

  • Loading branch information...
bobtfish authored and jrockway committed May 8, 2010
1 parent e10a23e commit a1a3522ff77663f0041d25caa5ec8b6d32cc110a
Showing with 10 additions and 2 deletions.
  1. +3 −0 Changes
  2. +2 −0 Makefile.PL
  3. +5 −2 t/parameterized.t
View
@@ -1,3 +1,6 @@
+ - Require newer version of MX::Role::Parameterized in the parameterized
+ role test. (RT#49873).
+
0.09 Tue Apr 6 22:51:40 CDT 2010
- Class->with_traits(...)->new is now preferred over
Class->new_with_traits(...).
View
@@ -1,4 +1,5 @@
use inc::Module::Install;
+use Module::Install::AuthorRequires;
name 'MooseX-Traits';
all_from 'lib/MooseX/Traits.pm';
@@ -13,5 +14,6 @@ build_requires 'Moose';
build_requires 'Test::Exception';
build_requires 'Test::More';
build_requires 'ok';
+author_requires 'MooseX::Role::Parameterized' => '0.13';
WriteAll();
View
@@ -4,8 +4,11 @@ use Test::More;
use Test::Exception;
BEGIN {
- plan 'skip_all', 'testing parameterized roles requires MooseX::Role::Parameterized'
- unless eval 'require MooseX::Role::Parameterized; 1';
+ plan 'skip_all', 'testing parameterized roles requires MooseX::Role::Parameterized 0.13'
+ unless eval {
+ require MooseX::Role::Parameterized;
+ MooseX::Role::Parameterized->VERSION('0.13');
+ };
plan tests => 11;
}

0 comments on commit a1a3522

Please sign in to comment.