Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Bump version to 1.0.0.beta1

  • Loading branch information...
commit 1d3fb8d28057ff9324168bc66f61f409f3cdefae 1 parent cedda7e
@nicksieger nicksieger authored
View
17 activerecord-jdbc-adapter.gemspec
@@ -2,18 +2,18 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbc-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{activerecord-jdbc-adapter is a database adapter for Rails' ActiveRecord
component that can be used with JRuby[http://www.jruby.org/]. It allows use of
virtually any JDBC-compliant database with your JRuby on Rails application.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["History.txt", "Manifest.txt", "README.txt", "LICENSE.txt"]
- s.files = ["History.txt", "Manifest.txt", "README.txt", "Rakefile", "LICENSE.txt", "lib/activerecord-jdbc-adapter.rb", "lib/arjdbc.rb", "lib/jdbc_adapter.rb", "lib/pg.rb", "lib/active_record/connection_adapters/cachedb_adapter.rb", "lib/active_record/connection_adapters/derby_adapter.rb", "lib/active_record/connection_adapters/h2_adapter.rb", "lib/active_record/connection_adapters/hsqldb_adapter.rb", "lib/active_record/connection_adapters/informix_adapter.rb", "lib/active_record/connection_adapters/jdbc_adapter.rb", "lib/active_record/connection_adapters/jndi_adapter.rb", "lib/active_record/connection_adapters/mssql_adapter.rb", "lib/active_record/connection_adapters/mysql_adapter.rb", "lib/active_record/connection_adapters/oracle_adapter.rb", "lib/active_record/connection_adapters/postgresql_adapter.rb", "lib/active_record/connection_adapters/sqlite3_adapter.rb", "lib/arel/engines/sql/compilers/db2_compiler.rb", "lib/arel/engines/sql/compilers/derby_compiler.rb", "lib/arel/engines/sql/compilers/h2_compiler.rb", "lib/arel/engines/sql/compilers/hsqldb_compiler.rb", "lib/arel/engines/sql/compilers/jdbc_compiler.rb", "lib/arjdbc/derby.rb", "lib/arjdbc/h2.rb", "lib/arjdbc/hsqldb.rb", "lib/arjdbc/jdbc.rb", "lib/arjdbc/mssql.rb", "lib/arjdbc/mysql.rb", "lib/arjdbc/oracle.rb", "lib/arjdbc/postgresql.rb", "lib/arjdbc/sqlite3.rb", "lib/arjdbc/version.rb", "lib/arjdbc/derby/adapter.rb", "lib/arjdbc/derby/connection_methods.rb", "lib/arjdbc/h2/adapter.rb", "lib/arjdbc/h2/connection_methods.rb", "lib/arjdbc/hsqldb/adapter.rb", "lib/arjdbc/hsqldb/connection_methods.rb", "lib/arjdbc/jdbc/adapters.rb", "lib/arjdbc/jdbc/jdbc_cachedb.rb", "lib/arjdbc/jdbc/jdbc_db2.rb", "lib/arjdbc/jdbc/jdbc_firebird.rb", "lib/arjdbc/jdbc/jdbc_informix.rb", "lib/arjdbc/jdbc/jdbc_mimer.rb", "lib/arjdbc/jdbc/jdbc_mssql.rb", "lib/arjdbc/jdbc/jdbc_mysql.rb", "lib/arjdbc/jdbc/jdbc_oracle.rb", "lib/arjdbc/jdbc/jdbc_postgresql.rb", "lib/arjdbc/jdbc/jdbc_sqlite3.rb", "lib/arjdbc/jdbc/jdbc_sybase.rb", "lib/arjdbc/jdbc/missing_functionality_helper.rb", "lib/arjdbc/jdbc/railtie.rb", "lib/arjdbc/jdbc/rake_tasks.rb", "lib/arjdbc/jdbc/require_driver.rb", "lib/arjdbc/jdbc/tsql_helper.rb", "lib/generators/jdbc/jdbc_generator.rb", "lib/jdbc_adapter/version.rb", "lib/arjdbc/jdbc/adapter_java.jar", "test/abstract_db_create.rb", "test/cachedb_simple_test.rb", "test/db2_simple_test.rb", "test/derby_migration_test.rb", "test/derby_multibyte_test.rb", "test/derby_simple_test.rb", "test/generic_jdbc_connection_test.rb", "test/h2_simple_test.rb", "test/has_many_through.rb", "test/helper.rb", "test/hsqldb_simple_test.rb", "test/informix_simple_test.rb", "test/jdbc_common.rb", "test/jndi_callbacks_test.rb", "test/jndi_test.rb", "test/manualTestDatabase.rb", "test/minirunit.rb", "test/mssql_db_create_test.rb", "test/mssql_identity_insert_test.rb", "test/mssql_legacy_types_test.rb", "test/mssql_limit_offset_test.rb", "test/mssql_multibyte_test.rb", "test/mssql_simple_test.rb", "test/mysql_db_create_test.rb", "test/mysql_info_test.rb", "test/mysql_multibyte_test.rb", "test/mysql_nonstandard_primary_key_test.rb", "test/mysql_simple_test.rb", "test/oracle_simple_test.rb", "test/pick_rails_version.rb", "test/postgres_db_create_test.rb", "test/postgres_mixed_case_test.rb", "test/postgres_nonseq_pkey_test.rb", "test/postgres_reserved_test.rb", "test/postgres_schema_search_path_test.rb", "test/postgres_simple_test.rb", "test/simple.rb", "test/sqlite3_simple_test.rb", "test/sybase_jtds_simple_test.rb", "test/activerecord/connection_adapters/type_conversion_test.rb", "test/activerecord/connections/native_jdbc_mysql/connection.rb", "test/db/cachedb.rb", "test/db/db2.rb", "test/db/derby.rb", "test/db/h2.rb", "test/db/hsqldb.rb", "test/db/informix.rb", "test/db/jdbc.rb", "test/db/jndi_config.rb", "test/db/logger.rb", "test/db/mssql.rb", "test/db/mysql.rb", "test/db/oracle.rb", "test/db/postgres.rb", "test/db/sqlite3.rb", "test/jdbc_adapter/jdbc_db2_test.rb", "test/jdbc_adapter/jdbc_sybase_test.rb", "test/minirunit/testConnect.rb", "test/minirunit/testH2.rb", "test/minirunit/testHsqldb.rb", "test/minirunit/testLoadActiveRecord.rb", "test/minirunit/testMysql.rb", "test/minirunit/testRawSelect.rb", "test/models/add_not_null_column_to_table.rb", "test/models/auto_id.rb", "test/models/data_types.rb", "test/models/entry.rb", "test/models/mixed_case.rb", "test/models/reserved_word.rb", "test/models/string_id.rb", "test/models/validates_uniqueness_of_string.rb", "lib/arjdbc/jdbc/jdbc.rake", "src/java/arjdbc/derby/DerbyModule.java", "src/java/arjdbc/jdbc/AdapterJavaService.java", "src/java/arjdbc/jdbc/JdbcConnectionFactory.java", "src/java/arjdbc/jdbc/RubyJdbcConnection.java", "src/java/arjdbc/jdbc/SQLBlock.java", "src/java/arjdbc/mssql/MssqlRubyJdbcConnection.java", "src/java/arjdbc/mysql/MySQLModule.java", "src/java/arjdbc/postgresql/PostgresqlRubyJdbcConnection.java", "src/java/arjdbc/sqlite3/Sqlite3RubyJdbcConnection.java", "rakelib/compile.rake", "rakelib/package.rake", "rakelib/rails.rake", "rakelib/test.rake", "rails_generators/jdbc_generator.rb", "rails_generators/templates/config/initializers/jdbc.rb", "rails_generators/templates/lib/tasks/jdbc.rake"]
+ s.files = ["History.txt", "Manifest.txt", "README.txt", "Rakefile", "LICENSE.txt", "lib/activerecord-jdbc-adapter.rb", "lib/arjdbc.rb", "lib/jdbc_adapter.rb", "lib/pg.rb", "lib/active_record/connection_adapters/cachedb_adapter.rb", "lib/active_record/connection_adapters/derby_adapter.rb", "lib/active_record/connection_adapters/h2_adapter.rb", "lib/active_record/connection_adapters/hsqldb_adapter.rb", "lib/active_record/connection_adapters/informix_adapter.rb", "lib/active_record/connection_adapters/jdbc_adapter.rb", "lib/active_record/connection_adapters/jndi_adapter.rb", "lib/active_record/connection_adapters/mssql_adapter.rb", "lib/active_record/connection_adapters/mysql_adapter.rb", "lib/active_record/connection_adapters/oracle_adapter.rb", "lib/active_record/connection_adapters/postgresql_adapter.rb", "lib/active_record/connection_adapters/sqlite3_adapter.rb", "lib/arel/engines/sql/compilers/db2_compiler.rb", "lib/arel/engines/sql/compilers/derby_compiler.rb", "lib/arel/engines/sql/compilers/h2_compiler.rb", "lib/arel/engines/sql/compilers/hsqldb_compiler.rb", "lib/arel/engines/sql/compilers/jdbc_compiler.rb", "lib/arjdbc/cachedb.rb", "lib/arjdbc/db2.rb", "lib/arjdbc/derby.rb", "lib/arjdbc/discover.rb", "lib/arjdbc/firebird.rb", "lib/arjdbc/h2.rb", "lib/arjdbc/hsqldb.rb", "lib/arjdbc/informix.rb", "lib/arjdbc/jdbc.rb", "lib/arjdbc/mimer.rb", "lib/arjdbc/mssql.rb", "lib/arjdbc/mysql.rb", "lib/arjdbc/oracle.rb", "lib/arjdbc/postgresql.rb", "lib/arjdbc/sqlite3.rb", "lib/arjdbc/sybase.rb", "lib/arjdbc/version.rb", "lib/arjdbc/cachedb/adapter.rb", "lib/arjdbc/cachedb/connection_methods.rb", "lib/arjdbc/db2/adapter.rb", "lib/arjdbc/derby/adapter.rb", "lib/arjdbc/derby/connection_methods.rb", "lib/arjdbc/firebird/adapter.rb", "lib/arjdbc/h2/adapter.rb", "lib/arjdbc/h2/connection_methods.rb", "lib/arjdbc/hsqldb/adapter.rb", "lib/arjdbc/hsqldb/connection_methods.rb", "lib/arjdbc/informix/adapter.rb", "lib/arjdbc/informix/connection_methods.rb", "lib/arjdbc/jdbc/adapter.rb", "lib/arjdbc/jdbc/callbacks.rb", "lib/arjdbc/jdbc/column.rb", "lib/arjdbc/jdbc/compatibility.rb", "lib/arjdbc/jdbc/connection.rb", "lib/arjdbc/jdbc/connection_methods.rb", "lib/arjdbc/jdbc/core_ext.rb", "lib/arjdbc/jdbc/discover.rb", "lib/arjdbc/jdbc/driver.rb", "lib/arjdbc/jdbc/extension.rb", "lib/arjdbc/jdbc/java.rb", "lib/arjdbc/jdbc/missing_functionality_helper.rb", "lib/arjdbc/jdbc/quoted_primary_key.rb", "lib/arjdbc/jdbc/railtie.rb", "lib/arjdbc/jdbc/rake_tasks.rb", "lib/arjdbc/jdbc/require_driver.rb", "lib/arjdbc/jdbc/type_converter.rb", "lib/arjdbc/mimer/adapter.rb", "lib/arjdbc/mssql/adapter.rb", "lib/arjdbc/mssql/connection_methods.rb", "lib/arjdbc/mssql/tsql_helper.rb", "lib/arjdbc/mysql/adapter.rb", "lib/arjdbc/mysql/connection_methods.rb", "lib/arjdbc/oracle/adapter.rb", "lib/arjdbc/oracle/connection_methods.rb", "lib/arjdbc/postgresql/adapter.rb", "lib/arjdbc/postgresql/connection_methods.rb", "lib/arjdbc/sqlite3/adapter.rb", "lib/arjdbc/sqlite3/connection_methods.rb", "lib/arjdbc/sybase/adapter.rb", "lib/generators/jdbc/jdbc_generator.rb", "lib/jdbc_adapter/version.rb", "lib/arjdbc/jdbc/adapter_java.jar", "test/abstract_db_create.rb", "test/cachedb_simple_test.rb", "test/db2_simple_test.rb", "test/derby_migration_test.rb", "test/derby_multibyte_test.rb", "test/derby_simple_test.rb", "test/generic_jdbc_connection_test.rb", "test/h2_simple_test.rb", "test/has_many_through.rb", "test/helper.rb", "test/hsqldb_simple_test.rb", "test/informix_simple_test.rb", "test/jdbc_common.rb", "test/jndi_callbacks_test.rb", "test/jndi_test.rb", "test/manualTestDatabase.rb", "test/mssql_db_create_test.rb", "test/mssql_identity_insert_test.rb", "test/mssql_legacy_types_test.rb", "test/mssql_limit_offset_test.rb", "test/mssql_multibyte_test.rb", "test/mssql_simple_test.rb", "test/mysql_db_create_test.rb", "test/mysql_info_test.rb", "test/mysql_multibyte_test.rb", "test/mysql_nonstandard_primary_key_test.rb", "test/mysql_simple_test.rb", "test/oracle_simple_test.rb", "test/pick_rails_version.rb", "test/postgres_db_create_test.rb", "test/postgres_mixed_case_test.rb", "test/postgres_nonseq_pkey_test.rb", "test/postgres_reserved_test.rb", "test/postgres_schema_search_path_test.rb", "test/postgres_simple_test.rb", "test/simple.rb", "test/sqlite3_simple_test.rb", "test/sybase_jtds_simple_test.rb", "test/activerecord/connection_adapters/type_conversion_test.rb", "test/activerecord/connections/native_jdbc_mysql/connection.rb", "test/db/cachedb.rb", "test/db/db2.rb", "test/db/derby.rb", "test/db/h2.rb", "test/db/hsqldb.rb", "test/db/informix.rb", "test/db/jdbc.rb", "test/db/jndi_config.rb", "test/db/logger.rb", "test/db/mssql.rb", "test/db/mysql.rb", "test/db/oracle.rb", "test/db/postgres.rb", "test/db/sqlite3.rb", "test/models/add_not_null_column_to_table.rb", "test/models/auto_id.rb", "test/models/data_types.rb", "test/models/entry.rb", "test/models/mixed_case.rb", "test/models/reserved_word.rb", "test/models/string_id.rb", "test/models/validates_uniqueness_of_string.rb", "lib/arjdbc/jdbc/jdbc.rake", "src/java/arjdbc/derby/DerbyModule.java", "src/java/arjdbc/jdbc/AdapterJavaService.java", "src/java/arjdbc/jdbc/JdbcConnectionFactory.java", "src/java/arjdbc/jdbc/RubyJdbcConnection.java", "src/java/arjdbc/jdbc/SQLBlock.java", "src/java/arjdbc/mssql/MssqlRubyJdbcConnection.java", "src/java/arjdbc/mysql/MySQLModule.java", "src/java/arjdbc/postgresql/PostgresqlRubyJdbcConnection.java", "src/java/arjdbc/sqlite3/Sqlite3RubyJdbcConnection.java", "rakelib/compile.rake", "rakelib/package.rake", "rakelib/rails.rake", "rakelib/test.rake", "rails_generators/jdbc_generator.rb", "rails_generators/templates/config/initializers/jdbc.rb", "rails_generators/templates/lib/tasks/jdbc.rake"]
s.homepage = %q{http://jruby-extras.rubyforge.org/activerecord-jdbc-adapter}
s.rdoc_options = ["--main", "README.txt"]
s.require_paths = ["lib"]
@@ -26,14 +26,11 @@ virtually any JDBC-compliant database with your JRuby on Rails application.}
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/derby/activerecord-jdbcderby-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcderby-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use Derby with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-derby>, [">= 10.5.3.0"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-derby>, [">= 10.5.3.0"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-derby>, [">= 10.5.3.0"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/h2/activerecord-jdbch2-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbch2-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use H2 with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-h2>, [">= 1.1.107"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-h2>, [">= 1.1.107"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-h2>, [">= 1.1.107"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/hsqldb/activerecord-jdbchsqldb-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbchsqldb-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use HSQLDB with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-hsqldb>, [">= 1.8.0.7"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-hsqldb>, [">= 1.8.0.7"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-hsqldb>, [">= 1.8.0.7"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/mssql/activerecord-jdbcmssql-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcmssql-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use MS-SQL with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-jtds>, [">= 1.2.5"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-jtds>, [">= 1.2.5"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-jtds>, [">= 1.2.5"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/mysql/activerecord-jdbcmysql-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcmysql-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use MySQL with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-mysql>, [">= 5.0.4"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-mysql>, [">= 5.0.4"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-mysql>, [">= 5.0.4"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/postgresql/activerecord-jdbcpostgresql-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcpostgresql-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use Postgres with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-postgres>, [">= 8.4.701"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-postgres>, [">= 8.4.701"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-postgres>, [">= 8.4.701"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
21 adapters/sqlite3/activerecord-jdbcsqlite3-adapter.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcsqlite3-adapter}
- s.version = "0.9.8"
+ s.version = "1.0.0.beta1"
s.platform = Gem::Platform.new([nil, "java", nil])
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-07-01}
+ s.date = %q{2010-07-20}
s.description = %q{Install this gem to use SQLite3 with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,20 +24,17 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_runtime_dependency(%q<jdbc-sqlite3>, [">= 3.6.3.054"])
- s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-sqlite3>, [">= 3.6.3.054"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.8"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.0.0.beta1"])
s.add_dependency(%q<jdbc-sqlite3>, [">= 3.6.3.054"])
- s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
- s.add_dependency(%q<hoe>, [">= 2.6.1"])
+ s.add_dependency(%q<hoe>, [">= 2.3.3"])
end
end
View
2  lib/arjdbc/version.rb
@@ -1,6 +1,6 @@
module ArJdbc
module Version
- VERSION = "0.9.8"
+ VERSION = "1.0.0.beta1"
end
end
# Compatibility with older versions of ar-jdbc for other extensions out there
Please sign in to comment.
Something went wrong with that request. Please try again.