Permalink
Browse files

Update history and version to 0.9.6

  • Loading branch information...
nicksieger committed May 5, 2010
1 parent 2d67abe commit 9922180262ff1f6c13c2284ce6cf5918fb0ed3d8
View
@@ -1,3 +1,17 @@
+== 0.9.6
+
+- The Oracle release!
+- Oracle should be working much better with this release. Also updated
+ to work with Rails 3.
+- Get all unit tests running cleanly on Oracle, fixing previous
+ datetime/timezone issues.
+- ACTIVERECORD_JDBC-83: Add :sequence_start_value option to
+ create_table, following oracle_enhanced adapter
+- ACTIVERECORD_JDBC-33: Don't double-quote table names in oracle
+- ACTIVERECORD_JDBC-17: Fix Oracle primary keys so that /^NUMBER$/ => :integer
+- Fix remaining blockers ACTIVERECORD_JDBC-82, JRUBY-3675,
+ ACTIVERECORD_JDBC-22, ACTIVERECORD_JDBC-27, JRUBY-4759
+
== 0.9.5
- The MSSQL release, courtesy of Mike Williams and Lonely
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbc-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{activerecord-jdbc-adapter is a database adapter for Rails' ActiveRecord
component that can be used with JRuby[http://www.jruby.org/]. It allows use of
virtually any JDBC-compliant database with your JRuby on Rails application.}
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbch2-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{Install this gem to use H2 with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,14 +24,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_runtime_dependency(%q<jdbc-h2>, [">= 1.1.107"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-h2>, [">= 1.1.107"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-h2>, [">= 1.1.107"])
end
end
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbchsqldb-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{Install this gem to use HSQLDB with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,14 +24,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_runtime_dependency(%q<jdbc-hsqldb>, [">= 1.8.0.7"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-hsqldb>, [">= 1.8.0.7"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-hsqldb>, [">= 1.8.0.7"])
end
end
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcmssql-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{Install this gem to use MS-SQL with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,14 +24,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_runtime_dependency(%q<jdbc-jtds>, [">= 1.2.5"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-jtds>, [">= 1.2.5"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-jtds>, [">= 1.2.5"])
end
end
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcmysql-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{Install this gem to use MySQL with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,14 +24,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_runtime_dependency(%q<jdbc-mysql>, [">= 5.0.4"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-mysql>, [">= 5.0.4"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-mysql>, [">= 5.0.4"])
end
end
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcpostgresql-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{Install this gem to use Postgres with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,14 +24,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_runtime_dependency(%q<jdbc-postgres>, [">= 8.4.701"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-postgres>, [">= 8.4.701"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-postgres>, [">= 8.4.701"])
end
end
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{activerecord-jdbcsqlite3-adapter}
- s.version = "0.9.5"
+ s.version = "0.9.6"
s.platform = Gem::Platform.new([nil, "java", nil])
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nick Sieger, Ola Bini and JRuby contributors"]
- s.date = %q{2010-04-22}
+ s.date = %q{2010-05-05}
s.description = %q{Install this gem to use SQLite3 with JRuby on Rails.}
s.email = %q{nick@nicksieger.com, ola.bini@gmail.com}
s.extra_rdoc_files = ["Manifest.txt", "README.txt", "LICENSE.txt"]
@@ -24,14 +24,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_runtime_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_runtime_dependency(%q<jdbc-sqlite3>, [">= 3.6.3.054"])
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-sqlite3>, [">= 3.6.3.054"])
end
else
- s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.5"])
+ s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 0.9.6"])
s.add_dependency(%q<jdbc-sqlite3>, [">= 3.6.3.054"])
end
end
@@ -1,5 +1,5 @@
module JdbcAdapter
module Version
- VERSION = "0.9.5"
+ VERSION = "0.9.6"
end
end

0 comments on commit 9922180

Please sign in to comment.