Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

prepare for 1.2.7

  • Loading branch information...
commit d0211d6e055f23e11ca57e292cb21a9eef4dbfa4 1 parent 0c58881
@kares kares authored
View
12 History.txt
@@ -1,6 +1,16 @@
+== 1.2.7 (02/12/13)
+
+- add some (probably redundant) synchronization + "arjdbc.disconnect.debug" flag
+ as an attempt to detect when connection is set to null (#197 and #198)
+ avoid (deprecated) Java.java_to_ruby when wrapping java.sql.Connection
+- follow Column-naming convention in MySQL adapter ArJdbc module
+- make sure update_sql is public in mysql adapter (Rails compatibility)
+- fix 1.2.6 regression - incorrectly setup to_sql method based on Rails version
+ this caused double '?' bind substitution issues (#322)
+
== 1.2.6 (01/31/13)
-- [postgres] only set --schema (to seach path) for pg_dump if configured (#315)
+- [postgres] only set --schema (to search path) for pg_dump if configured (#315)
- [oracle] id limits + quoting; current user/db/schema + savepoint support
- execute "log" (sql) name correctly based on AR version
- deprecate substitute_binds and extract_sql
View
BIN  lib/arjdbc/jdbc/adapter_java.jar
Binary file not shown
View
2  lib/arjdbc/version.rb
@@ -1,6 +1,6 @@
module ArJdbc
module Version
- VERSION = "1.2.6"
+ VERSION = "1.2.7"
end
end
# Compatibility with older versions of ar-jdbc for other extensions out there
Please sign in to comment.
Something went wrong with that request. Please try again.