Skip to content
This repository

Jan 02, 2013

  1. Arun Agrawal

    version bump

    arunagw authored

Dec 30, 2012

  1. Arun Agrawal

    Merge pull request #284 from kares/master

    fix the (for some adapter gems) broken **1.2.4** release
    arunagw authored

Dec 28, 2012

  1. Arun Agrawal

    Merge pull request #281 from gregors/update_appraisal_in_gemfiles

    make sure appraisal gemfiles use the same appraisal versions.
    arunagw authored
  2. Arun Agrawal

    it should be jtds Closes #283

    arunagw authored

Dec 27, 2012

  1. Karol Bucek

    backwards compat with older jdbc- (driver) gems (fixes #279)

    kares authored

Dec 26, 2012

  1. Gregory Ostermayr

    make sure appraisal gemfiles use the same appraisal version as main g…

    …emfile
    gregors authored
  2. Arun Agrawal

    version bump

    arunagw authored
  3. Arun Agrawal

    Merge pull request #278 from jruby/fix_loading_jdbc_driver

    fixed uninitialized constant Jdbc
    arunagw authored
  4. Arun Agrawal

    fixed uninitialized constant Jdbc

    arunagw authored
  5. Arun Agrawal

    Version bump!

    arunagw authored
  6. Arun Agrawal

    summary for JTDS

    arunagw authored

Dec 20, 2012

  1. Guillermo Iguaran

    Merge pull request #276 from kares/jndi-driver

    JNDI updates
    guilleiguaran authored
  2. Karol Bucek

    deps update - make sure test deps are in appraised gemfiles

    kares authored
  3. Karol Bucek

    include jndi tests with rake test + run test_jndi on travis as well

    kares authored

Dec 19, 2012

  1. Karol Bucek

    move Derby specific hack out of the (generic) jdbc adapter

    there's some duplication now about DS lookup but the first one is generic for all specs while the username is strictly Derby adapter specific code
    
    make sure we  always close the obtained DB connection (not just on errors) as jndi DS will be pooled most likely
    kares authored
  2. Karol Bucek

    run JNDI tests with a pooled data source as well

    kares authored
  3. Karol Bucek

    refactor #adapter_spec

    - 2.times code seemed really hard to grasp
    - predictable order of ArJdbc (adapter) DB vendor matching
    kares authored
  4. Karol Bucek

    double check before going synchronized

    kares authored
  5. Karol Bucek

    less config constants + dry up mysql config on one place

    kares authored
  6. Karol Bucek

    no need to set the :driver for jndi config (did not work anyways)

    when jdbc is being configured do not raise if there's a :driver_instance instead of the :driver
    kares authored
  7. Karol Bucek

    do not depend on Sun's "old" FS JNDI (no where to be found)

    instead use Tomcat's JNDI impl ... jars get auto-downloaded
    kares authored
  8. Anthony Juckel

    Merge pull request #258 from tinylox/oracle-in-clause-limits

     Oracle has a 1000 entry in clause limit.
    ajuckel authored
  9. Anthony Juckel

    Remove duplicated primary_key method

    I wasn't careful enough rebasing that last change, and needlessly duplicated
    the primary_key method.
    ajuckel authored
  10. Keenan Brock

    extra options for creating postgres databases

    kbrock authored ajuckel committed

Dec 18, 2012

  1. Guillermo Iguaran

    Merge pull request #273 from kares/master

    backwards compat with current Jdbc gems (without #load_driver)
    guilleiguaran authored
  2. Karol Bucek

    allow for building + releasing of the jdbc driver gems separately

    these will be tagged as "jdbc-mysql-x.x.x"
    kares authored
  3. Karol Bucek

    generic jdbc adadpter tests do not auto-load the correct driver

    kares authored
  4. Karol Bucek

    relax jdbc-hsqldb gem requirement (no release for a long time)

    kares authored
  5. Karol Bucek

    update Derby to 10.8.2.2

    kares authored
  6. Karol Bucek

    update H2 to 1.3.170

    kares authored
  7. Karol Bucek

    backwards compat with current Jdbc gems (no #load_driver)

    kares authored

Dec 17, 2012

  1. Guillermo Iguaran

    Merge pull request #272 from kares/master

    make sure we can use the latest driver gems from AR-adapter gems
    guilleiguaran authored
  2. Karol Bucek

    make sure we can use the latest jdbc driver gems with AR gems :

    - for MS SQL we have the jTDS 1.3.0 JDBC driver
    - for Postgres we now recommend the 9.2 driver
    - for Derby we shall allow to package latest (10.9.1) driver
    kares authored
  3. Karol Bucek

    we do not really need to load the JDBC driver here

    happens when the jdbc-adapter gets required (on connection initialization) 
    @see f15684f
    kares authored
  4. Karol Bucek

    BigDecimal is only required in MySQL adapter

    (BigDecimal nor #to_d ain't used anywhere else)
    kares authored
Something went wrong with that request. Please try again.