Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

NameError for org.postgresql.Driver with 9.2.1002 #285

Closed
nelsnelson opened this Issue · 2 comments

2 participants

@nelsnelson

This doesn't happen when I downgrade to version 9.1.901 of the jdbc-postgres gem:

NameError: missing class or uppercase package name (`org.postgresql.Driver')
get_proxy_or_package_under_package at org/jruby/javasupport/JavaUtilities.java:54
method_missing at file:/usr/java/jruby-1.7.1/lib/jruby.jar!/jruby/java/java_package_module_template.rb:10
JDBC at /usr/java/jruby-1.7.1/lib/ruby/gems/shared/gems/sequel-3.42.0/lib/sequel/adapters/jdbc.rb:37
call at org/jruby/RubyProc.java:249
initialize at /usr/java/jruby-1.7.1/lib/ruby/gems/shared/gems/sequel-3.42.0/lib/sequel/adapters/jdbc.rb:174
connect at /usr/java/jruby-1.7.1/lib/ruby/gems/shared/gems/sequel-3.42.0/lib/sequel/database/connecting.rb:78
connect at /usr/java/jruby-1.7.1/lib/ruby/gems/shared/gems/sequel-3.42.0/lib/sequel/core.rb:147
(root) at /Users/nels.nelson/Documents/sandbox/tmp/sequel_identity_tests/0_sequel_identity_test.rb:11
require at org/jruby/RubyKernel.java:1027
(root) at /usr/java/jruby-1.7.1/lib/ruby/shared/rubygems/custom_require.rb:1
(root) at ./test.rb:5

@atambo
Collaborator

This is the same issue as #280 and will be fixed by jeremyevans/sequel#598.

@nelsnelson

Oops! Okay, thanks!

@nelsnelson nelsnelson closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.