0.7.3 doesn't work with older versions of jruby #5

Open
bpardee opened this Issue Mar 16, 2011 · 2 comments

Comments

Projects
None yet
3 participants

bpardee commented Mar 16, 2011

I attempted to upgrade form 0.7.2 to 0.7.3 under jruby 1.5.1. I now get the exception below.

I'll be upgrading to 1.6 soon so it's not a priority for me but I thought I would let you know.

Java::JavaLang::NoSuchMethodError: org.jruby.Ruby.getSelectorPool()Lorg/jruby/util/io/SelectorPool;
from org.jruby.ext.openssl.SSLSocket.waitSelect(SSLSocket.java:259)
from org.jruby.ext.openssl.SSLSocket.doHandshake(SSLSocket.java:313)
from org.jruby.ext.openssl.SSLSocket.connect(SSLSocket.java:170)
from org.jruby.ext.openssl.SSLSocket$i_method_0_0$RUBYINVOKER$connect.call(org/jruby/ext/openssl/SSLSocket$i_method_0_0$RUBYINVOKER$connect.gen:65535)
from org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:289)

You (and Google) saved my day! Thank you!

Save me as well. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment