Skip to content

JRUBY-6961 Make openssl selectively load gem only if jruby < 1.7 #29

Open
wants to merge 3 commits into from

1 participant

@dekellum

This pull includes a version bump to 0.7.8 and change where openssl.rb detects if it is running
under jruby 1.7+, and if so, loads what jruby's openssl.rb would load instead of the gem contents.

This is a bit of hack, but I can only think of one other alternative which is also a hack:

  • Modify jruby 1.7+ rubygems to ignore activating a gem by the name of 'jruby-openssl'

That doesn't seem like a lesser evil, and has the disadvantage of not being able to help the situation on jruby 1.7.0 which is already released.

dekellum added some commits Oct 25, 2012
@dekellum dekellum Version bump to 0.7.8 4637e51
@dekellum dekellum JRUBY-6961 Make openssl selectively load gem only if jruby < 1.7
This is a bit of a hack, but hopefully offers a better transition
experience to end users than the alternative of doing nothing.

With this change the included openssl.rb detects if it is running
under jruby 1.7+, and if so, loads what jruby's openssl.rb would load
instead of the gem contents.
1c9e07d
@dekellum dekellum JRUBY-6961 Simplify loading of jruby 1.7's impl
Actually the potential maintenance headache can also be avoided by
using load here.  Feels like less of a hack now.
189b253
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.