Permalink
Browse files

prepare for 1.1.8 + appraise latest and greatest

  • Loading branch information...
1 parent 7899e0d commit 9cea492054f63d54f8a41249bfef1f3966d8d6af @kares kares committed Aug 17, 2012
View
@@ -3,13 +3,13 @@ appraise "rails23" do
end
appraise "rails30" do
- gem "rails", "~> 3.0.16"
+ gem "rails", "~> 3.0.17"
end
appraise "rails31" do
- gem "rails", "~> 3.1.7"
+ gem "rails", "~> 3.1.8"
end
appraise "rails32" do
- gem "rails", "~> 3.2.7"
+ gem "rails", "~> 3.2.8"
end
View
@@ -10,14 +10,14 @@ GEM
bouncy-castle-java (>= 1.5.0146.1)
rack (1.4.1)
rake (0.9.2.2)
- rspec (2.10.0)
- rspec-core (~> 2.10.0)
- rspec-expectations (~> 2.10.0)
- rspec-mocks (~> 2.10.0)
- rspec-core (2.10.1)
- rspec-expectations (2.10.0)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.2)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.10.1)
+ rspec-mocks (2.11.1)
PLATFORMS
java
View
@@ -1,3 +1,32 @@
+== 1.1.8 (17/08/12)
+
+ - introduced ServletEnv for cases when it's desirable to fully use the servlet
+ environment to create the rack env (and not let Rack::Request parse params
+ but rely on the parameters already parsed and available from the servlet
+ request #110). this is an experimental feature that might change in the
+ future and requires setting 'jruby.rack.handler.env' param to 'servlet' !
+ - separated out Env (LazyEnv) into a separate file :
+ - Env got refactored into DefaultEnv (with lazyness built-in)
+ - LazyEnv got removed as it is not longer necessary
+ - Rack::Handler::Servlet.env sets the used env conversion class
+ - introduce a generic getNumberProperty on RackConfig
+ - introduce a base RackException and add a custom AcquireTimeoutException for
+ pool timeouts (related to jruby.runtime.acquire.timeout parameter)
+ - RackInitializationException changed to unchecked as it inherits from
+ RackException now
+ - PoolingRackApplication (and related) polishing :
+ - avoid creating a new application from getApplication when a permit is
+ granted but pool is empty
+ - support to wait till pool becomes ready by default otherwise wait until
+ initial application objects are present in the pool before returning
+ (controlled with the jruby.runtime.init.wait accepting true/false/integer)
+ - edge case handling where (in case were set to not wait for initialization)
+ we should wait for an initializer thread to put an application into the pool
+ - allow acquire timeout (jruby.runtime.acquire.timeout param) to be specified
+ as a decimal number for finer control and decreased the timeout default
+ from 30s to 10s (although seems still too high for a default)
+ - jruby runtime pooling for plain Rack applications (not just Rails)
+
== 1.1.7 (21/06/12)
- support for delegating logs to java.util.logging (jruby.rack.logging: JUL)
View
@@ -214,7 +214,8 @@ task :release_checks do
" git push origin :#{JRuby::Rack::VERSION}" if ok
end
- pom_version = `mvn -o validate | grep JRuby-Rack | sed 's/.*JRuby-Rack //'`.chomp
+ pom_version = `mvn help:evaluate -Dexpression=project.version`.
+ split("\n").reject { |line| line =~ /[INFO]/ }.first.chomp
if pom_version =~ /dev|SNAPSHOT/
fail "Can't release a dev/snapshot version.\n" +
"Please update pom.xml to the final release version, run `mvn install', and commit the result."
@@ -27,14 +27,14 @@ GEM
activesupport (= 2.3.14)
rake (>= 0.8.3)
rake (0.9.2.2)
- rspec (2.10.0)
- rspec-core (~> 2.10.0)
- rspec-expectations (~> 2.10.0)
- rspec-mocks (~> 2.10.0)
- rspec-core (2.10.1)
- rspec-expectations (2.10.0)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.2)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.10.1)
+ rspec-mocks (2.11.1)
PLATFORMS
java
@@ -45,4 +45,4 @@ DEPENDENCIES
rack
rails (~> 2.3.14)
rake
- rspec (~> 2.10)
+ rspec (~> 2.11)
View
@@ -7,5 +7,5 @@ gem "appraisal"
gem "rake", :group=>:test
gem "rspec", "~> 2.10", :group=>:test
gem "jruby-openssl", :group=>:test
-gem "rails", "~> 3.0.16"
+gem "rails", "~> 3.0.17"
@@ -2,32 +2,32 @@ GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
- actionmailer (3.0.16)
- actionpack (= 3.0.16)
+ actionmailer (3.0.17)
+ actionpack (= 3.0.17)
mail (~> 2.2.19)
- actionpack (3.0.16)
- activemodel (= 3.0.16)
- activesupport (= 3.0.16)
+ actionpack (3.0.17)
+ activemodel (= 3.0.17)
+ activesupport (= 3.0.17)
builder (~> 2.1.2)
erubis (~> 2.6.6)
i18n (~> 0.5.0)
rack (~> 1.2.5)
rack-mount (~> 0.6.14)
rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
- activemodel (3.0.16)
- activesupport (= 3.0.16)
+ activemodel (3.0.17)
+ activesupport (= 3.0.17)
builder (~> 2.1.2)
i18n (~> 0.5.0)
- activerecord (3.0.16)
- activemodel (= 3.0.16)
- activesupport (= 3.0.16)
+ activerecord (3.0.17)
+ activemodel (= 3.0.17)
+ activesupport (= 3.0.17)
arel (~> 2.0.10)
tzinfo (~> 0.3.23)
- activeresource (3.0.16)
- activemodel (= 3.0.16)
- activesupport (= 3.0.16)
- activesupport (3.0.16)
+ activeresource (3.0.17)
+ activemodel (= 3.0.17)
+ activesupport (= 3.0.17)
+ activesupport (3.0.17)
appraisal (0.4.1)
bundler
rake
@@ -53,31 +53,31 @@ GEM
rack (>= 1.0.0)
rack-test (0.5.7)
rack (>= 1.0)
- rails (3.0.16)
- actionmailer (= 3.0.16)
- actionpack (= 3.0.16)
- activerecord (= 3.0.16)
- activeresource (= 3.0.16)
- activesupport (= 3.0.16)
+ rails (3.0.17)
+ actionmailer (= 3.0.17)
+ actionpack (= 3.0.17)
+ activerecord (= 3.0.17)
+ activeresource (= 3.0.17)
+ activesupport (= 3.0.17)
bundler (~> 1.0)
- railties (= 3.0.16)
- railties (3.0.16)
- actionpack (= 3.0.16)
- activesupport (= 3.0.16)
+ railties (= 3.0.17)
+ railties (3.0.17)
+ actionpack (= 3.0.17)
+ activesupport (= 3.0.17)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.4)
rake (0.9.2.2)
rdoc (3.12)
json (~> 1.4)
- rspec (2.10.0)
- rspec-core (~> 2.10.0)
- rspec-expectations (~> 2.10.0)
- rspec-mocks (~> 2.10.0)
- rspec-core (2.10.1)
- rspec-expectations (2.10.0)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.2)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.10.1)
+ rspec-mocks (2.11.1)
thor (0.14.6)
treetop (1.4.10)
polyglot
@@ -91,6 +91,6 @@ DEPENDENCIES
appraisal
jruby-openssl
rack
- rails (~> 3.0.16)
+ rails (~> 3.0.17)
rake
- rspec (~> 2.10)
+ rspec (~> 2.11)
View
@@ -7,5 +7,5 @@ gem "appraisal"
gem "rake", :group=>:test
gem "rspec", "~> 2.10", :group=>:test
gem "jruby-openssl", :group=>:test
-gem "rails", "~> 3.1.7"
+gem "rails", "~> 3.1.8"
@@ -1,12 +1,12 @@
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.7)
- actionpack (= 3.1.7)
+ actionmailer (3.1.8)
+ actionpack (= 3.1.8)
mail (~> 2.3.3)
- actionpack (3.1.7)
- activemodel (= 3.1.7)
- activesupport (= 3.1.7)
+ actionpack (3.1.8)
+ activemodel (= 3.1.8)
+ activesupport (= 3.1.8)
builder (~> 3.0.0)
erubis (~> 2.7.0)
i18n (~> 0.6)
@@ -15,19 +15,19 @@ GEM
rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
sprockets (~> 2.0.4)
- activemodel (3.1.7)
- activesupport (= 3.1.7)
+ activemodel (3.1.8)
+ activesupport (= 3.1.8)
builder (~> 3.0.0)
i18n (~> 0.6)
- activerecord (3.1.7)
- activemodel (= 3.1.7)
- activesupport (= 3.1.7)
+ activerecord (3.1.8)
+ activemodel (= 3.1.8)
+ activesupport (= 3.1.8)
arel (~> 2.2.3)
tzinfo (~> 0.3.29)
- activeresource (3.1.7)
- activemodel (= 3.1.7)
- activesupport (= 3.1.7)
- activesupport (3.1.7)
+ activeresource (3.1.8)
+ activemodel (= 3.1.8)
+ activesupport (= 3.1.8)
+ activesupport (3.1.8)
multi_json (>= 1.0, < 1.3)
appraisal (0.4.1)
bundler
@@ -58,32 +58,32 @@ GEM
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.7)
- actionmailer (= 3.1.7)
- actionpack (= 3.1.7)
- activerecord (= 3.1.7)
- activeresource (= 3.1.7)
- activesupport (= 3.1.7)
+ rails (3.1.8)
+ actionmailer (= 3.1.8)
+ actionpack (= 3.1.8)
+ activerecord (= 3.1.8)
+ activeresource (= 3.1.8)
+ activesupport (= 3.1.8)
bundler (~> 1.0)
- railties (= 3.1.7)
- railties (3.1.7)
- actionpack (= 3.1.7)
- activesupport (= 3.1.7)
+ railties (= 3.1.8)
+ railties (3.1.8)
+ actionpack (= 3.1.8)
+ activesupport (= 3.1.8)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2.2)
rdoc (3.12)
json (~> 1.4)
- rspec (2.10.0)
- rspec-core (~> 2.10.0)
- rspec-expectations (~> 2.10.0)
- rspec-mocks (~> 2.10.0)
- rspec-core (2.10.1)
- rspec-expectations (2.10.0)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.2)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.10.1)
+ rspec-mocks (2.11.1)
sprockets (2.0.4)
hike (~> 1.2)
rack (~> 1.0)
@@ -102,6 +102,6 @@ DEPENDENCIES
appraisal
jruby-openssl
rack
- rails (~> 3.1.7)
+ rails (~> 3.1.8)
rake
rspec (~> 2.10)
View
@@ -7,5 +7,5 @@ gem "appraisal"
gem "rake", :group=>:test
gem "rspec", "~> 2.10", :group=>:test
gem "jruby-openssl", :group=>:test
-gem "rails", "~> 3.2.7"
+gem "rails", "~> 3.2.8"
Oops, something went wrong.

0 comments on commit 9cea492

Please sign in to comment.