Permalink
Browse files

Make openssl load in 1.8 mode but not load krypt (see GH #516 on poss…

…ibly making it load in 1.8 mode)
  • Loading branch information...
1 parent 53de2d2 commit 3f60d0fb5d2af76243f4532f2a74972d72a9f085 @enebo enebo committed Jan 29, 2013
Showing with 7 additions and 5 deletions.
  1. +7 −5 lib/ruby/shared/krypt/ossl.rb
@@ -29,10 +29,12 @@
=end
-require 'krypt'
+if RUBY_VERSION.to_f >= 1.9
+ require 'krypt'
-module OpenSSL
- class Error < StandardError; end
-end unless defined? OpenSSL
+ module OpenSSL
+ class Error < StandardError; end
+ end unless defined? OpenSSL
-require_relative 'ossl/pkcs5'
+ require_relative 'ossl/pkcs5'
+end

0 comments on commit 3f60d0f

Please sign in to comment.