Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Disable invokedynamic for Java 7 #1034

Closed
donv opened this Issue · 2 comments

2 participants

@donv
Collaborator

I asked @headius on #jruby, and he said invokedynamic will be disabled for Java 7 for JRuby 1.7.5. Just tested from source and rvm, and invokedynamic seems to be enabled still for Java 7:


macbeth:~ uwe$ rvm use jruby-head
Using /Users/uwe/.rvm/gems/jruby-head
macbeth:~ uwe$ java8
macbeth:~ uwe$ jruby --version
jruby 1.7.5.dev (1.9.3p392) 2013-09-21 @jruby.revision@ on Java HotSpot(TM) 64-Bit Server VM 1.8.0-ea-b106 +indy [darwin-x86_64]
macbeth:~ uwe$ java7
macbeth:~ uwe$ jruby --version
jruby 1.7.5.dev (1.9.3p392) 2013-09-21 @jruby.revision@ on Java HotSpot(TM) 64-Bit Server VM 1.7.0_40-b43 +indy [darwin-x86_64]
@donv
Collaborator

d343680 claims to require Java 8, but compares to >= 1.7. I can fix it, but I am unsure if this is correct for non-hotspot JVMs.

@donv donv closed this
@headius
Owner

Wow, thank you for catching that, Uwe. That would have been disastrous if it had gotten into the release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.