Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unsupported platform: unknown-linux (ppc64le) #1753

Closed
mbruzek opened this issue Jun 18, 2014 · 4 comments
Closed

Unsupported platform: unknown-linux (ppc64le) #1753

mbruzek opened this issue Jun 18, 2014 · 4 comments

Comments

@mbruzek
Copy link

@mbruzek mbruzek commented Jun 18, 2014

It appears the POWER8 architecture (ppc64le) is not supported by jruby.

I am trying to get logstash (which uses jruby) to run on Linux using Power PC hardware. When I run logstash I get the error "Unsupported platform: unknown-linux"

I am using the OpenJDK version 1.7.0_55
ubuntu@ubuntu-power-machine-1:~$ java -version
java version "1.7.0_55"
OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)
OpenJDK 64-Bit Zero VM (build 24.51-b03, interpreted mode)

The kernel is 3.18.0 and the Power architecture is ppc64le (little endian).
ubuntu@ubuntu-power-machine-1:~$ uname -a
Linux ubuntu-power-machine-1 3.13.0-8-generic #28-Ubuntu SMP Mon Feb 17 08:22:39 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

You can see the jruby stack trace when running the logstash command:

ubuntu@ubuntu-power-machine-1:~$ /opt/logstash/bin/logstash
LoadError: Unsupported platform: unknown-linux
require at org/jruby/RubyKernel.java:1085
require at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55
(root) at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/ffi/ffi.rb:69
require at org/jruby/RubyKernel.java:1085
(root) at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1
require at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55
require at org/jruby/RubyKernel.java:1085
(root) at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/ffi.rb:1
(root) at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1
require at file:/opt/logstash/vendor/jar/jruby-complete-1.7.11.jar!/META-INF/jruby.home/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55
require at org/jruby/RubyKernel.java:1085
LibC at /opt/logstash/lib/logstash/util/prctl.rb:4
(root) at /opt/logstash/lib/logstash/util/prctl.rb:3
main at /opt/logstash/lib/logstash/runner.rb:79
(root) at /opt/logstash/lib/logstash/runner.rb:215

@ghost
Copy link

@ghost ghost commented Jul 29, 2014

JRuby's FFI does not support ppc64le yet. I will work on fixing this issue.

@laggarcia
Copy link

@laggarcia laggarcia commented Nov 24, 2014

It seems vitordelima's patches that adds support for ppc64le were already included upstream.

@gustavotemple
Copy link
Contributor

@gustavotemple gustavotemple commented Mar 31, 2015

@mbruzek, can you retest, please? thanks

@kares
Copy link
Member

@kares kares commented Apr 9, 2015

this can now be closed since #2812 is merged (will be in 1.7.20)

@kares kares closed this Apr 9, 2015
@kares kares added this to the JRuby 1.7.20 milestone Apr 9, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants