Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bundle fails with Java::JavaLang::StackOverflowError with git-hosted gems #2185

Closed
mjc opened this Issue Nov 12, 2014 · 6 comments

Comments

Projects
None yet
5 participants
@mjc
Copy link
Contributor

mjc commented Nov 12, 2014

With a rails project that includes one gem hosted on a git repository, bundle fails:

Java::JavaLang::StackOverflowError: An error occurred while installing example (0.0.example), and Bundler cannot continue.

Removing that gem from the gemfile allows the bundle to complete successfully.

@kares

This comment has been minimized.

Copy link
Member

kares commented Nov 13, 2014

Thanks Michael, would be great to know what gem as this seems like not JRuby's fault on first sight ...
(and maybe an isolated way to reproduce with a sample Gemfile)

@mjc

This comment has been minimized.

Copy link
Contributor Author

mjc commented Nov 14, 2014

It seems to work now as of 9e6c2be.

@rtyler

This comment has been minimized.

Copy link

rtyler commented Dec 9, 2014

@mjc Can we close this issue out? Also I'm assuming by the commit you've referenced that this is just an issue relating to JRuby 9.0.0.0

@mjc

This comment has been minimized.

Copy link
Contributor Author

mjc commented Dec 29, 2014

Yes we can close this. sorry for the delay.

@mjc mjc closed this Dec 29, 2014

@enebo enebo added this to the 9.0.0.0.pre2 milestone Jan 30, 2015

@mungler

This comment has been minimized.

Copy link

mungler commented Nov 16, 2015

I'm seeing this on one of my machines under JRuby 9.0.3.0, but not on the other. I thought it was due to it being on Java 7, but after upgrading to Java 8 i'm seeing the same thing.

rory@Marvin: $ java -version
java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

rory@Marvin: $ bundle install
Fetching gem metadata from https://rubygems.org/.........
Fetching version metadata from https://rubygems.org/..
Resolving dependencies....
Using bundler 1.10.6

Java::JavaLang::StackOverflowError: Java::JavaLang::StackOverflowError: Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: 
Java::JavaLang::StackOverflowError: An error occurred while installing bond (0.5.1), and Bundler cannot continue.
Make sure that `gem install bond -v '0.5.1'` succeeds before bundling.
rory@Marvin: $ 
@mungler

This comment has been minimized.

Copy link

mungler commented Nov 16, 2015

My bad. I had the -Xss thread stack size option set too large for my laptop, so I guess it was running out of memory.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.