Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rack tests broken #2428

Closed
raggi opened this Issue Jan 5, 2015 · 9 comments

Comments

Projects
None yet
5 participants
@raggi
Copy link

commented Jan 5, 2015

We have two failing tests on jruby 9k: https://travis-ci.org/rack/rack/jobs/45815446

As yet, I haven't diagnosed myself. Associated Rack ticket: rack/rack#778

Thanks!

@headius

This comment has been minimized.

Copy link
Member

commented Jan 6, 2015

This actually appears to work on 9k and not on 1.7. Notice in your log that the bacon.rb warning is coming from a 1.7.18-d19 install in rvm.

However, I can't reproduce it on either 9k or 1.7 on OS X. It may be specific to Linux.

@raggi Are you on Linux? If so, can you try running there with both versions and report back?

@raggi

This comment has been minimized.

Copy link
Author

commented Jan 6, 2015

I haven't replicated this locally (I'm keeping my rack time minimal these days, as I have absolutely no use for it (or ruby) anymore). It's occurring on travis.

@raggi

This comment has been minimized.

Copy link
Author

commented Jan 6, 2015

So it is. Eugh, travis.

@headius

This comment has been minimized.

Copy link
Member

commented Jan 6, 2015

It is specific to Linux or specific to Travis?

@raggi

This comment has been minimized.

Copy link
Author

commented Jan 6, 2015

Sorry, I'm shaving yaks right now (bundler, travis, optional dependencies, platforms). I'll have some better answers for you in maybe 20 minutes.

@raggi

This comment has been minimized.

Copy link
Author

commented Jan 6, 2015

Yes, it's 1.7.18 on linux that's failing. My apologies for the confusion.

It passes on 1.7.9 on OSX. Installing 1.7.18 on OSX now.

Confirm, it passes on OSX.

@headius headius added the JRuby 1.7.x label Jan 6, 2015

@headius headius added this to the JRuby 1.7.19 milestone Jan 6, 2015

@headius

This comment has been minimized.

Copy link
Member

commented Jan 6, 2015

@raggi Ok, thank you for confirming. I think we can take it from here.

@mkristian

This comment has been minimized.

Copy link
Member

commented Apr 9, 2015

@raggi I tried to reproduce the issue on current master - I could not reproduce it with jruby-1.7.19 or jruby-9.0.0.0-pre1 and rack on travis seems to be green now.

would like either to fix the problem or close this issue

@raggi

This comment has been minimized.

Copy link
Author

commented Apr 11, 2015

Feel free to close

@mkristian mkristian closed this Apr 12, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.