Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bundler won't use dependency API in 2.0 mode for JRuby 1.7.18 #2457

Closed
rosenfeld opened this issue Jan 13, 2015 · 11 comments
Closed

Bundler won't use dependency API in 2.0 mode for JRuby 1.7.18 #2457

rosenfeld opened this issue Jan 13, 2015 · 11 comments

Comments

@rosenfeld
Copy link

@rosenfeld rosenfeld commented Jan 13, 2015

It boils down to this according to my experiments:

irb -r net/http -r openssl
irb(main):001:0> Net::HTTP.get 'bundler.rubygems.org', '/api/v1/dependencies?gems=railties,actionmailer,sprockets-rails,sprockets,puma,foreman,jruby-openssl,rsolr,activesupport,rake,rspec,guard-rspec,nokogiri,tidy_ffi,fakefs,pry-byebug'
=> ""

The response is not empty as you can confirm by either downloading the URL or running this on MRI or on 1.9 mode.

@Who828
Copy link
Contributor

@Who828 Who828 commented Jan 14, 2015

I can confirm that it's working on master (JRuby 9000) with 2.x mode.
guess this will be fixed once its out.

@headius
Copy link
Member

@headius headius commented Jan 14, 2015

One liner that reproduces this on 1.7:

jruby -rnet/http -ropenssl -e "p Net::HTTP.get 'bundler.rubygems.org', '/api/v1/dependencies?gems=railties,actionmailer,sprockets-rails,sprockets,puma,foreman,jruby-openssl,rsolr,activesupport,rake,rspec,guard-rspec,nokogiri,tidy_ffi,fakefs,pry-byebug'"

@mkristian
Copy link
Member

@mkristian mkristian commented Jan 14, 2015

I needed to add --2.0:

jruby --2.0 -rnet/http -ropenssl -e "p Net::HTTP.get 'bundler.rubygems.org', '/api/v1/dependencies?gems=railties,actionmailer,sprockets-rails,sprockets,puma,foreman,jruby-openssl,rsolr,activesupport,rake,rspec,guard-rspec,nokogiri,tidy_ffi,fakefs,pry-byebug'"

@headius
Copy link
Member

@headius headius commented Jan 14, 2015

Oh, right, you need that too :-)

@perlun
Copy link
Contributor

@perlun perlun commented Jan 14, 2015

Does this work properly on older JRuby 1.7 versions?

@rosenfeld
Copy link
Author

@rosenfeld rosenfeld commented Jan 14, 2015

This is the only one I tried. I wanted to test one request in my app without the GVL in MRI, that is how I found out this issue...

@rosenfeld
Copy link
Author

@rosenfeld rosenfeld commented Feb 2, 2015

This issue also prevents rbenv from installing JRuby if you have compat.version=2.0 in your ~/.jrubyrc, which is my case:

rbenv/ruby-build#718

@hathawad
Copy link

@hathawad hathawad commented Jun 25, 2015

This works properly in JRuby 1.7.13

@rosenfeld
Copy link
Author

@rosenfeld rosenfeld commented Jun 25, 2015

Weird... I just checked that one-liner with 1.7.19 and it worked... Maybe the guys in bundler.rubygems.org changed something that affected this somehow... Not sure how to proceed from here... Should we close this ticket and re-open if it happens again? I suspect there's still some hidden bug but now it's no longer reproducible...

@digitalextremist
Copy link
Contributor

@digitalextremist digitalextremist commented Jul 18, 2015

This is occurring with 1.7.21

In fact, no remote gems are directly installable with 2.0 enabled either.

@kares
Copy link
Member

@kares kares commented May 23, 2017

closing since this was a JRuby 1.7.x issue ... seems fine by now (on JRuby 1.7.25+ using Bundler 1.13)

@kares kares closed this as completed May 23, 2017
@kares kares added this to the Invalid or Duplicate milestone May 23, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

8 participants