Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

load error: jopenssl/load in jruby 9.0.0.0.pre1 #2507

Closed
raskhadafi opened this issue Jan 23, 2015 · 4 comments
Closed

load error: jopenssl/load in jruby 9.0.0.0.pre1 #2507

raskhadafi opened this issue Jan 23, 2015 · 4 comments

Comments

@raskhadafi
Copy link

@raskhadafi raskhadafi commented Jan 23, 2015

On my osx with jruby 9.0.0.0.pre1 (2.2.0p0) 2015-01-20 d537cab Java HotSpot(TM) 64-Bit Server VM 25.5-b02 on 1.8.0_05-b13 +jit [darwin-x86_64]

Used gem: airbrake

I get:

LoadError: load error: jopenssl/load -- java.lang.SecurityException: class "org.bouncycastle.asn1.ASN1Primitive"'s signer information does not match signer information of other classes in the same package
  require at org/jruby/RubyKernel.java:954
   (root) at /Mobiles/107446/.rvm/rubies/jruby-9.0.0.0.pre1/lib/ruby/stdlib/openssl.rb:1
  require at org/jruby/RubyKernel.java:954
   (root) at /Mobiles/107446/.rvm/rubies/jruby-9.0.0.0.pre1/lib/ruby/stdlib/net/https.rb:1
  require at org/jruby/RubyKernel.java:954
   (root) at /Mobiles/107446/.rvm/rubies/jruby-9.0.0.0.pre1/lib/ruby/stdlib/net/https.rb:22
  require at org/jruby/RubyKernel.java:954
   (root) at /Mobiles/107446/.rvm/gems/jruby-9.0.0.0.pre1@pdf_box/gems/airbrake-4.1.0/lib/airbrake.rb:1
  require at org/jruby/RubyKernel.java:954
   (root) at /Mobiles/107446/.rvm/gems/jruby-9.0.0.0.pre1@pdf_box/gems/airbrake-4.1.0/lib/airbrake.rb:12
  require at org/jruby/RubyKernel.java:954
@mkristian
Copy link
Member

@mkristian mkristian commented Jan 23, 2015

this probably has two reasons: one it the reversed classloader hierarchy of jruby-9.0.0.0.pre1 and second that you probably have BC in your extension classloader (i.e. BC is part of your java installation)

the first part will be reverted to what we have in jruby-1_7 in 9.0.0.0.pre2

Loading

@raskhadafi
Copy link
Author

@raskhadafi raskhadafi commented Jan 23, 2015

Thanks for your immediate answer!

For BC should I use the lastest version? Thanks in advance for your help.

Loading

@mkristian
Copy link
Member

@mkristian mkristian commented Jan 23, 2015

either remove it from your jdk installation if that is possible or
use jdk15on-1.49 which comes with jruby-9.0.0.0.pre1 (which still could
create problems with the current release)

Loading

@kares
Copy link
Member

@kares kares commented Jun 3, 2015

@raskhadafi any chance to confirm if this is still an issue with 9K-pre2 ?

Loading

@kares kares added the openssl label Jun 3, 2015
@kares kares closed this Jul 13, 2015
@kares kares added this to the JRuby 9.0.0.0.pre2 milestone Jul 13, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants