Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

how do I install with Jars? Re: "deprecated. use instead jars/installer" message #2726

Closed
aplatypus opened this Issue Mar 19, 2015 · 2 comments

Comments

Projects
None yet
3 participants
@aplatypus
Copy link

aplatypus commented Mar 19, 2015

Hi,

I came here from the thread_safe gem project, both projects are emitting the message:

"deprecated. use instead jars/installer"

There's nothing fancy going on, apart from me using JRuby 9.0.0 at this point. The install commands:

  • jruby -S gem install jruby-jars
  • jruby -S gem install addressable
  • jruby -S gem install thread_safe
  • jruby -S gem install concurrent-ruby

Produce this as output:

  jruby -S gem install addressable
  Fetching: addressable-2.3.7.gem (100%)
  deprecated. use instead jars/installer
  Successfully installed addressable-2.3.7
  1 gem installed

then

  jruby -S gem  install  jruby-jars
  Fetching: jruby-jars-1.7.19.gem (100%)
  deprecated. use instead jars/installer
  Successfully installed jruby-jars-1.7.19
  1 gem installed

then

  jruby -S gem  install  thread_safe
  deprecated. use instead jars/installer
  Successfully installed thread_safe-0.3.5-java
  1 gem installed

and

  jruby -S gem  install  concurrent-ruby
  Fetching: concurrent-ruby-0.8.0-java.gem (100%)
  deprecated. use instead jars/installer
  Successfully installed concurrent-ruby-0.8.0-java
  1 gem installed

I'm unclear on where this message fits or how to 'resolve' this warning. A search of thread_safe and concurrent-ruby haven't revealed any specific instruction or comments.

What is the solution?

 JRuby 9.0.0.0.pre1 (2.2.0p0) 2015-01-20 d537cab 
 Java HotSpot(TM) 64-Bit Server VM 25.25-b02 on 1.8.0_25-b18 +jit 
 [Windows 7-amd64]
@mkristian

This comment has been minimized.

Copy link
Member

mkristian commented Mar 19, 2015

@aplatypus

This comment has been minimized.

Copy link
Author

aplatypus commented Mar 20, 2015

@mkristian - Thanks for that. Yes it is very confusing because it often comes up in the middle of another Gem or dependencies, etc.

@enebo enebo added this to the 9.0.0.0.pre2 milestone Apr 28, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.