Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

jgem jruby-9000 not recognised as ~> 2.0.0 #2813

Closed
monkstone opened this issue Apr 9, 2015 · 4 comments
Closed

jgem jruby-9000 not recognised as ~> 2.0.0 #2813

monkstone opened this issue Apr 9, 2015 · 4 comments

Comments

@monkstone
Copy link
Contributor

@monkstone monkstone commented Apr 9, 2015

When trying to install a local gem with jgem (jruby-9000) with requirement for at least 2.0.0 ruby version install fails not reqd version level. However jruby -S gem for same gem works fine.

@headius
Copy link
Member

@headius headius commented Apr 17, 2015

Could you tell us what gem it is? JRuby 9000 should report RUBY_VERSION as 2.2 and pass any 2.0.0 requirements easily.

@headius headius added this to the 9.0.0.0.rc1 milestone Apr 17, 2015
@monkstone
Copy link
Contributor Author

@monkstone monkstone commented Apr 17, 2015

The gem was one of my own jruby_art, but it is available as from rubygems gem install jruby-art --pre. To be clear I was using both jruby and jgem from the build directory (fully qualified path to jruby 9000).
jgem --version 2.1.9
jruby --version jruby 9.0.0.0-SNAPSHOT (2.2.1) 2015-04-15 7e4e64f OpenJDK 64-Bit Server VM 25.40-b23 on 1.8.0_40-b20 +jit [linux-amd64]

@enebo enebo removed this from the JRuby 9.0.0.0.rc1 milestone Jun 10, 2015
@enebo enebo added this to the JRuby 9.0.0.0.rc2 milestone Jun 10, 2015
@enebo enebo added this to the JRuby 9.0.0.0.rc2 milestone Jun 10, 2015
@enebo enebo removed this from the JRuby 9.0.0.0.rc1 milestone Jun 10, 2015
@headius
Copy link
Member

@headius headius commented Jul 2, 2015

The following appears to work correctly on master (to be 9k.rc2) so I'm going to call this fixed. This code mimics RubyGems' own logic for checking Ruby versions.

If you still have the problem, please provide a gem that fails to install against JRuby master (or 9k.rc1) so we can reproduce the issue.

$ jruby -e "p Gem::Requirement.create('>=2.0.0').satisfied_by? Gem.ruby_version"
true
@headius headius closed this Jul 2, 2015
@headius headius added this to the Invalid or Duplicate milestone Jul 2, 2015
@headius headius removed this from the JRuby 9.0.0.0.rc2 milestone Jul 2, 2015
@headius headius added this to the JRuby 9.0.0.0.rc2 milestone Jul 2, 2015
@headius headius removed this from the Invalid or Duplicate milestone Jul 2, 2015
@monkstone
Copy link
Contributor Author

@monkstone monkstone commented Jul 3, 2015

@headius confirmed as fixed on latest Snapshot

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants