Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NotImplementedError: waitpid unsupported or native support failed to load on OS X 10.9.5 / OpenJDK 8 / rbenv #2974

Closed
jirutka opened this Issue May 22, 2015 · 7 comments

Comments

Projects
None yet
4 participants
@jirutka
Copy link

jirutka commented May 22, 2015

Installation of the current head version fails on my system (OS X 10.9.5 / OpenJDK 1.8.0-u60-b07 / rbenv), but jruby-9.0.0.0.pre2 install fine.

$ rbenv install jruby-9.0.0.0-dev
Downloading jruby-dist-9.0.0.0-SNAPSHOT-bin.tar.gz...
-> http://ci.jruby.org/snapshots/master/jruby-dist-9.0.0.0-SNAPSHOT-bin.tar.gz
Installing jruby-9.0.0.0-SNAPSHOT...

BUILD FAILED (OS X 10.9.5 using ruby-build 20150519)

Inspect or clean up the working tree at /var/folders/jm/8y686qds3mq3tb0qvpnztk9r0000gn/T/ruby-build.20150522224250.51951
Results logged to /var/folders/jm/8y686qds3mq3tb0qvpnztk9r0000gn/T/ruby-build.20150522224250.51951.log
/var/folders/jm/8y686qds3mq3tb0qvpnztk9r0000gn/T/ruby-build.20150522224250.51951 ~
/var/folders/jm/8y686qds3mq3tb0qvpnztk9r0000gn/T/ruby-build.20150522224250.51951/jruby-9.0.0.0-SNAPSHOT /var/folders/jm/8y686qds3mq3tb0qvpnztk9r0000gn/T/ruby-build.20150522224250.51951 ~
NotImplementedError: waitpid unsupported or native support failed to load
                   flock at org/jruby/RubyFile.java:298
    block in read_binary at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems.rb:773
                    open at org/jruby/RubyIO.java:1126
                    open at org/jruby/RubyKernel.java:311
             read_binary at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems.rb:772
              fetch_spec at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/source.rb:145
                    spec at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/resolver/api_specification.rb:76
      add_always_install at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/resolver/installer_set.rb:77
    resolve_dependencies at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/dependency_installer.rb:473
             install_gem at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/commands/install_command.rb:238
   block in install_gems at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/commands/install_command.rb:299
                    each at org/jruby/RubyArray.java:1571
            install_gems at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/commands/install_command.rb:295
                 execute at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/commands/install_command.rb:202
  invoke_with_build_args at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/command.rb:307
            process_args at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/command_manager.rb:168
                     run at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/command_manager.rb:138
                     run at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/lib/ruby/stdlib/rubygems/gem_runner.rb:54
                   <top> at /Users/jimmy/.rbenv/versions/jruby-9.0.0.0-dev/bin/jgem:21
                    load at org/jruby/RubyKernel.java:959
                   <top> at gem:4
$ java -version
openjdk version "1.8.0-u60-b07"
OpenJDK Runtime Environment (build 1.8.0-u60-b07-20150322)
OpenJDK 64-Bit Server VM (build 25.60-b07, mixed mode)

$  ruby-build --version
ruby-build 20150519
@headius

This comment has been minimized.

Copy link
Member

headius commented May 22, 2015

Sorry, this is because the CI builds stopped building a week ago, and it's fixed on really real master. I'm fixing the CI builds now and then you can try reinstalling.

@jirutka

This comment has been minimized.

Copy link
Author

jirutka commented May 22, 2015

Okay, please let me know then!

@jirutka

This comment has been minimized.

Copy link
Author

jirutka commented May 23, 2015

I can confirm that “really real master” works, so closing this.

@jirutka jirutka closed this May 23, 2015

@headius

This comment has been minimized.

Copy link
Member

headius commented May 26, 2015

Thanks! And the CI builds should be working properly now.

@mdaniel

This comment has been minimized.

Copy link

mdaniel commented Jul 23, 2015

I am experiencing this same kaboom on ubuntu 14.04.1 LTS:

$ curl -vLJO https://s3.amazonaws.com/jruby.org/downloads/9.0.0.0/jruby-bin-9.0.0.0.tar.gz
$ tar xzf jruby-bin-9.0.0.0.tar.gz
$ PATH=/tmp/jruby-9.0.0.0/bin:$PATH
$ type jruby
jruby is /tmp/jruby-9.0.0.0/bin/jruby

$ gem install bundler
Fetching: bundler-1.10.6.gem (100%)
NotImplementedError: waitpid unsupported or native support failed to load
                       flock at org/jruby/RubyFile.java:298
  block in cache_update_path at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/remote_fetcher.rb:316
                        open at org/jruby/RubyIO.java:1126
                        open at org/jruby/RubyKernel.java:311
           cache_update_path at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/remote_fetcher.rb:315
                    download at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/remote_fetcher.rb:174
                    download at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/source.rb:210
                    download at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/resolver/activation_request.rb:60
            block in install at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/request_set.rb:160
                        each at org/jruby/RubyArray.java:1560
                     install at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/request_set.rb:150
                 install_gem at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/commands/install_command.rb:249
       block in install_gems at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/commands/install_command.rb:299
                        each at org/jruby/RubyArray.java:1560
                install_gems at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/commands/install_command.rb:295
                     execute at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/commands/install_command.rb:202
      invoke_with_build_args at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/command.rb:307
                process_args at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/command_manager.rb:168
                         run at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/command_manager.rb:138
                         run at /tmp/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/gem_runner.rb:54
                       <top> at /tmp/jruby-9.0.0.0/bin/jgem:21
                        load at org/jruby/RubyKernel.java:958
                       <top> at /tmp/jruby-9.0.0.0/bin/gem:4

$ jruby --version
jruby 9.0.0.0 (2.2.2) 2015-07-21 e10ec96 Java HotSpot(TM) 64-Bit Server VM 25.45-b02 on 1.8.0_45-b14 +jit [linux-amd64]

$ java -version
java version "1.8.0_45"
Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

$ uname -a
Linux ip-10-0-2-210 3.13.0-44-generic #73-Ubuntu SMP Tue Dec 16 00:22:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
@stefanhorning

This comment has been minimized.

Copy link

stefanhorning commented Sep 30, 2015

I am getting the same error as @mdaniel . While jruby-9.0.1.0 installed fine (using ruby-install and oracle java 8) the gem command seems to fail in exactly the same way as abose. Also on Ubuntu 14.04.

As not solution was provided here I am not sure if it makes sense to open another ticket for this. Also #3285 looks somehow simillar...

@stefanhorning

This comment has been minimized.

Copy link

stefanhorning commented Sep 30, 2015

@mdaniel ans apt-get install libc6-dev fixed the problem for me see #3285 for more details.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.